Форматируйте минифицированный JavaScript или сжимайте его с безопасной обработкой строк, шаблонов и регулярных выражений.
Проверьте, работает ли сайт, и узнайте хостинг, наличие WordPress, SSL, DNS, SEO и производительность.
Сравните скорость выполнения 2+ фрагментов JS в изолированном Web Worker.
Прочитайте карту любого сайта, посмотрите структуру страниц в виде дерева и графа и проверьте заголовки, мета-теги и коды ответа.
Соберите Info.plist для iOS/macOS из типичных ключей bundle и конфиденциальности.
Нажмите клавишу, чтобы увидеть её значения key/code/keyCode из KeyboardEvent в реальном времени.
Просмотрите URL в типичных размерах области просмотра устройств.
Превращайте скриншоты в аккуратные изображения с рамками устройств, градиентами, тенями и текстом.
Соберите канонический тег link.
Добавляйте пометки к скриншотам для сообщений об ошибках.
Создайте заметки о релизе по слитым PR.
Выполняйте запросы к любому GraphQL-эндпоинту и изучайте его схему.
Секундомер в браузере с отсечками кругов.
Показывает IP-адрес, с которого наш сервер видит ваше подключение.
Узнайте регистрационные данные домена.
Создайте сканируемый QR-код с пресетами, цветами, экспортом SVG/PNG и пакетным режимом.
Создавайте надёжные случайные пароли.
Создавайте пароли, API-ключи, ключи AES, UUID и пары ключей RSA/SSH — всё на стороне клиента.
Создавайте UUID v4/v7 пачками.
Классический текст-заполнитель для макетов.
Проверьте, какие функции веб-платформы поддерживает ваш браузер.
Показывает размер экрана и области просмотра в реальном времени.
Проверьте каждую клавишу новой или старой клавиатуры: экранная раскладка, обнаружение двойных нажатий, тест rollover, тепловая карта и скорость печати.
Перерасставьте отступы или минифицируйте CSS.
Переведите длину CSS между px, rem, em, pt и %.
Создавайте CSS глассморфизма.
Форматируйте и минифицируйте HTML-разметку.
Преобразуйте между Markdown и HTML.
Создавайте CSS-анимации @keyframes.
Минифицируйте и очищайте SVG-разметку.
Создайте все стандартные размеры favicon.
Создавайте и экспортируйте CSS-градиенты.
Создавайте многослойные CSS box-shadow.
Визуально создайте HTML-таблицу.
Создавайте гармоничные цветовые палитры.
Сравните два снимка HTML.
Кодируйте или декодируйте HTML-сущности.
Создавайте мета-теги head, Open Graph и Twitter Card.
Преобразуйте файл шрифта между TTF/OTF и WOFF.
Визуально собирайте комбинации классов Tailwind.
Создавайте CSS неоморфизма.
Проследите веб-адрес через все перенаправления и узнайте коды статуса, циклы и переходы на HTTPS.
Добавьте длительность к времени начала и увидьте итоговые дату и время.
Переводите размеры данных между байтами/КБ/МБ/ГБ/ТБ, десятичные или двоичные.
Двоичная арифметика и конвертер систем счисления.
AND/OR/XOR/NOT/сдвиги с побитовым представлением.
Раскройте блок CIDR или диапазон адресов во все отдельные IP-адреса.
Расчёт подсетей: адрес сети и широковещательный адрес, маска, диапазон хостов.
Переводите между секундами, ЧЧ:ММ:СС и читаемыми длительностями.
Преобразуйте IPv4 в целое/шестнадцатеричное представление и IPv6, отображённый из IPv4.
Расшифруйте битовые флаги MAC-адреса и найдите производителя по возможности.
Четыре распространённых расчёта процентов в одном месте.
Переводите между градусами Цельсия, Фаренгейта и кельвинами.
Преобразуйте форматы MAC-адресов, получите адрес IPv6 link-local и магический пакет Wake-on-LAN.
Создайте префикс уникального локального адреса RFC 4193 для частной нумерации IPv6.
Преобразуйте CIDR, маску подсети и wildcard-маску и создавайте строки ACL для Cisco.
Создавайте случайные номера портов TCP/UDP для серверов разработки и конфигураций.
Создавайте случайные локально администрируемые MAC-адреса.
Шестнадцатеричная арифметика и битовые операции плюс конвертер систем счисления.
Узнайте владельца, AS-источник, анонсируемый префикс и BGP-соседей для IP, префикса, номера AS или имени хоста.
Список распространённых портов TCP и UDP и использующих их служб с поиском.
Переводите бит/с, Мбит/с и т. д. и оценивайте время загрузки.
Преобразуйте время между часовыми поясами с учётом летнего времени и найдите время встречи для всех.
Рассчитайте нужное окно TCP и реальную пропускную способность при заданных пропускной способности, задержке и потерях пакетов.
Суммируйте маршруты IPv4 и IPv6 в минимальный список префиксов или один суммарный маршрут.
Преобразуйте текст в 8-битные двоичные байты и обратно.
Кодируйте процентами или декодируйте текст в режиме компонента или полного URI.
Преобразуйте текст в десятичные коды символов и обратно.
Преобразуйте текст в кодовые точки Unicode (U+XXXX) и обратно.
Преобразуйте текст в шестнадцатеричные байты и обратно.
Преобразуйте текст в/из Base58 (алфавит Bitcoin).
Автоматически определяйте и декодируйте Base64, hex, URL-кодирование, gzip и другое, слой за слоем.
Преобразуйте текст в/из Base32 (RFC 4648).
Преобразуйте любой файл в data URI Base64 прямо в браузере.
Преобразуйте Base64 в строку шестнадцатеричных байтов и обратно.
Преобразуйте query string URL в JSON-объект и обратно.
Проверяйте шаблон на тексте с подсветкой совпадений в реальном времени и группами захвата.
Вычислите математическое выражение настоящим парсером (без eval): операторы, функции, константы.
Случайно перемешайте порядок строк.
Преобразуйте список: обрезка, удаление дублей, сортировка, обрамление и объединение любым разделителем.
Подсчёт символов, слов, строк и предложений в реальном времени.
Удаляйте пустые строки и строки только из пробелов.
Ищите и заменяйте текст с regex и поиском целых слов.
Поиск по токенам, квантификаторам и распространённым шаблонам regex.
Построчное сравнение текста с подсветкой добавленного и удалённого.
Преобразуйте между ВЕРХНИМ/нижним/Заглавным/camelCase/snake_case и др.
Приведите email к канонической форме провайдера для удаления дублей.
Превратите текст в ASCII-арт, сэмплируя настоящий шрифт, а не фиксированный набор глифов.
Преобразуйте текст в slug, безопасный для URL.
Сокращайте слова как «i18n»: первая буква, число букв между ними, последняя буква.
Сортируйте строки по алфавиту: А-Я или Я-А.
Ищите и копируйте из подобранного набора распространённых эмодзи по категориям.
Случайный текст-заполнитель из распространённых английских слов.
Произнесите текст по фонетическому алфавиту НАТО.
Удаляйте повторы, сохраняя первое вхождение.
Преобразуйте между арабскими и римскими числами.
Разберите номер телефона на код страны E.164, страну и национальный номер.
Соберите альтернативные теги link hreflang для языковых версий.
Соберите sitemap.xml из вставленного списка URL.
Соберите robots.txt из групп правил.
Создайте структурированные данные JSON-LD для распространённых типов.
Соберите JSON-документ политики AWS IAM.
Разделите CIDR VPC на равные подсети.
Переключайте права доступа Unix, чтобы собрать команду chmod.
Соберите файл переменных Terraform.
Разберите или соберите AWS ARN.
Найдите коды регионов AWS/GCP/Azure.
Примеры событий для S3/API Gateway/SNS/SQS/EventBridge.
Перерасставьте отступы в конфигурации Terraform.
Управляйте файлами .env и сравнивайте их.
Преобразуйте команду docker run в эквивалентный блок сервиса docker-compose.yml.
Создайте рабочий процесс GitHub Actions для Node, Python, PHP, Go, Java, Rust, .NET, Docker или Pages.
Разбирайте и собирайте URL S3 (virtual-hosted, path-style, s3://).
Преобразуйте файл .env в JSON или YAML и обратно.
Преобразуйте между обычным JSON и JSON AttributeValue DynamoDB.
Проверьте, какие версии удовлетворяют диапазону семантических версий в стиле npm.
Создайте файл .htaccess для Apache: редиректы, HTTPS, кэширование, сжатие и безопасность, с правилами для Nginx.
Создавайте блоки server для nginx.
Отслеживайте доступность сайтов и сервисов.
Создайте Dockerfile для распространённых стеков.
Создавайте и объясняйте cron-выражения.
Разберите строку User-Agent.
Создайте файл docker-compose.yml.
Создавайте манифесты Kubernetes.
Кодируйте или декодируйте текст и файлы в Base64.
Создавайте безопасные случайные токены и API-ключи.
Создавайте хеши семейства MD5/SHA.
Создавайте пачками сортируемые ULID в кодировке Base32 Крокфорда.
Создайте актуальный TOTP-код (RFC 6238) из секрета Base32 или URI otpauth://.
Ищите идентификатор CVE или продукт: критичность, статус CISA KEV, вероятность эксплуатации, затронутые продукты и ссылки.
Хешируйте или проверяйте текст через bcrypt с помощью встроенных password_hash/password_verify в PHP.
Проверьте поведение CORS эндпоинта.
Читайте версию и время создания внутри UUID и генерируйте сортируемые UUID v7.
Покажите отпечатки SHA256 и MD5, тип и размер открытого SSH-ключа и сравните его с другим.
Оценивайте уязвимости по CVSS 3.1: базовая, временная и контекстная оценки и строка вектора.
Проверьте контрольную сумму mod-97 IBAN и разберите его на страну и BBAN.
Вычислите HMAC по сообщению и секретному ключу (SHA-1/256/384/512).
Шифруйте и расшифровывайте текст распространёнными шифрами.
Замаскируйте середину строки, чтобы скрыть ключи и email на скриншотах.
Создайте мнемоническую seed-фразу BIP39 (12–24 слова) с корректной энтропией и контрольной суммой.
Создайте Content-Security-Policy и найдите слабые места в существующей.
Проверьте, встречается ли пароль в известных утечках, не отправляя его.
Создайте атрибут integrity и HTML-тег для скриптов и стилей, загружаемых с CDN.
Извлекайте IP, домены, URL, email, хеши и CVE из текста, обезвреживайте и восстанавливайте ссылки.
Оцените надёжность пароля и время его взлома, полностью на стороне клиента.
Создайте файл security.txt по RFC 9116, чтобы исследователи знали, как сообщать об уязвимостях.
Узнайте, каким алгоритмом получен хеш, или вычислите контрольную сумму файла с помощью MD5, SHA-1 и SHA-2.
Декодируйте сертификат X.509 или CSR: субъект, издатель, срок действия, SAN, ключ и отпечатки.
Отслеживайте даты истечения SSL-сертификатов.
Отправьте серию запросов к эндпоинту, чтобы найти его реальный лимит.
Поиск по соответствию расширение файла <-> MIME-тип.
Fill in {{variable}} prompt templates and preview the resolved prompt.
Справочник всех стандартных кодов состояния HTTP с поиском.
Создавайте и отправляйте HTTP-запросы, изучайте ответы и сохраняйте историю.
Проверьте запрос chat completions или структуру схемы функции/инструмента.
Преобразуйте команды curl в fetch, Python, PHP или HTTPie и обратно.
Соберите или декодируйте HTTP-заголовок Authorization: Basic.
Получает URL и объясняет заголовки ответа, с оценкой безопасности.
Проектируйте спецификации REST-эндпоинтов и создавайте по ним документацию и моки.
Декодируйте и изучайте заголовок и полезную нагрузку JWT, проверяйте подписи.
Пройдите поток OAuth2 с кодом авторизации и изучите токены.
Сравните два ответа API и увидьте различия в структурированном виде.
Оцените количество токенов в промпте для LLM.
Преобразуйте спецификацию OpenAPI/Swagger в коллекцию Postman и обратно.
Получите уникальный адрес почтового ящика и просматривайте входящие вебхук-запросы в реальном времени.
Постоянно отслеживайте доступность и задержку эндпоинта через cron.
Коэффициент контрастности текста и фона по WCAG, результат AA/AAA.
Преобразуйте между RGB и HSV/HSB — моделью выбора цвета в Photoshop и Figma.
Преобразуйте между шестнадцатеричными кодами и значениями RGB.
Преобразуйте между RGB и HSL.
Выберите цвет и увидьте его в HEX/RGB/HSL.
Преобразуйте между значениями CMYK (печать) и RGB (экран).
Создавайте случайные HEX-цвета (пастельные/яркие/тёмные).
Просматривайте стандартную палитру цветов Tailwind CSS.
Преобразуйте между стандартными именами цветов CSS и HEX-кодами.
Просматривайте палитру цветов Material Design от Google.
Соберите примеры payload для APNs и FCM.
Проверьте google-services.json на соответствие ожидаемой структуре конфигурации Firebase.
Соберите файл .entitlements (связанные домены, группы приложений, push, iCloud и др.).
Создайте все необходимые размеры иконки приложения.
Создайте политику конфиденциальности для мобильного приложения.
Управляйте строками перевода для разных языков.
Анализируйте конкурентность ключевых слов.
Список файлов и размеров внутри APK.
Найдите ценные ключевые слова для ASO.
Создавайте метаданные для App Store и Play Store.
Создавайте заметки о релизе для магазинов приложений.
Соберите .gitignore из списков по языку, редактору и ОС.
Поиск по распространённым командам git.
Создайте conventional-сообщение коммита.
Визуализируйте конфликты слияния и помогайте их разрешать.
Найдите устаревшие или уже слитые ветки для удаления.
Создавайте значки shields.io для версии, сборки, лицензии и загрузок и копируйте их как Markdown или HTML.
Создайте журнал изменений по истории коммитов.
Проверяйте и форматируйте YAML-документы.
Сравните два JSON-документа.
Проверяйте, форматируйте и минифицируйте JSON.
Форматируйте и проверяйте XML.
Преобразуйте между TOML и JSON/YAML.
Преобразуйте JSON в XML по соглашениям нашего конвертера XML в JSON.
Создавайте реалистичный пример JSON по JSON Schema с воспроизводимым seed.
Визуально постройте JSON Schema по примерам данных.
Преобразуйте JSON в CSV с разворачиванием вложенности, разделителями и совместимостью с Excel.
Создавайте типы TypeScript, Go, Java, C# или Python из примера JSON.
Преобразуйте XML-документы в JSON.
Перерасставьте отступы в правилах безопасности Firestore.
Проверяйте выражения JSONPath на примере JSON.
Проверяйте TOML и просматривайте его как JSON.
Преобразуйте файл Java .properties в JSON или YAML и обратно.
Преобразуйте между CSV и JSON.
Преобразуйте распространённое подмножество YAML в JSON и обратно.
Преобразуйте CSV в настоящий файл .xlsx и обратно.
Создавайте тестовые адреса email в доменах, зарезервированных RFC 2606.
Создавайте поддельные номера телефонов (американский обменный код 555 и т. д.).
Создавайте поддельные имена, email и логины для тестирования.
Создавайте фиктивные номера карт, корректные по Луну, для тестов в песочнице.
Создавайте поддельные почтовые адреса для тестирования.
Безопасно просматривайте SVG-разметку (отображается как изображение, без внедрения).
Уменьшайте изображение с настраиваемым качеством JPEG/WebP.
Выделите область перетаскиванием и обрежьте изображение.
Измените размер изображения до точных значений.
Преобразуйте изображение в data URI base64 и обратно.
Превратите фрагмент кода в стильный PNG с темами, рамками окна и номерами строк.
Растеризуйте SVG-разметку в PNG или JPEG любого размера.
Преобразуйте изображение между форматами.
Создайте лёгкое встроенное SVG-изображение-заглушку без сетевого запроса.
Восстановите исходный URL из ссылки, обёрнутой Microsoft Safe Links.
Преобразуйте между временными метками Unix и датами.
Разберите URL на протокол, хост, путь, параметры запроса и хеш.
Соберите deep link с собственной схемой URI.
Соберите кроссплатформенную ссылку sms: с готовым сообщением.
Соберите ссылку Google Play Store по имени пакета.
Соберите ссылку Apple App Store по ID приложения.
Соберите ссылку mailto: с темой, текстом, копией и скрытой копией.
Соберите ссылку wa.me для чата в один клик.
Проследите перенаправления до конечного адреса.
Создавайте короткие ссылки-перенаправления.
Стройте запросы MongoDB визуально.
Преобразуйте строки CSV в операторы INSERT.
Форматируйте и украшайте SQL-запросы.
Проанализируйте запрос на возможные проблемы с производительностью.
Визуализируйте связи между таблицами.
Преобразуйте операторы INSERT в массив JSON.
Сравните два снимка схемы или запросов.
Создайте ER-диаграмму по схеме.
Визуализируйте план EXPLAIN.
Отформатируйте запрос или документ MongoDB.
Создайте штрихкод EAN-13.
Приведите необработанные стек-трейсы к читаемому виду.
Сводка по частоте и шаблонам ошибок в логах.
Разбирайте и обобщайте отчёты о сбоях.
Ищите и следите в реальном времени за загруженными лог-файлами.