Formatuj zminifikowany JavaScript lub go kompaktuj, z bezpieczną obsługą ciągów, szablonów i regex.
Sprawdź, czy witryna działa, i zobacz hosting, wykrywanie WordPressa, SSL, DNS, SEO i wydajność.
Porównaj szybkość wykonania 2+ fragmentów JS w izolowanym Web Workerze.
Odczytaj mapę witryny dowolnej strony, zobacz strukturę podstron jako drzewo i graf oraz sprawdź tytuły, tagi meta i kody stanu.
Zbuduj Info.plist iOS/macOS z typowych kluczy bundle i prywatności.
Naciśnij klawisz, aby zobaczyć na żywo jego wartości key/code/keyCode z KeyboardEvent.
Wyświetl podgląd adresu URL w typowych rozmiarach viewportu urządzeń.
Zamień zrzuty ekranu w dopracowane obrazy z ramkami urządzeń, gradientami, cieniami i tekstem.
Zbuduj kanoniczny tag link.
Dodawaj adnotacje do zrzutów ekranu, aby zgłaszać błędy.
Wygeneruj notatki o wydaniu ze scalonych PR-ów.
Wykonuj zapytania do dowolnego endpointu GraphQL i przeglądaj jego schemat.
Stoper w przeglądarce z czasami okrążeń.
Pokazuje adres IP, z którego widzi Cię nasz serwer.
Sprawdź dane rejestracyjne domeny.
Generuj skanowalny kod QR z ustawieniami, kolorami, eksportem SVG/PNG i trybem wsadowym.
Generuj silne losowe hasła.
Generuj hasła, klucze API, klucze AES, UUID i pary kluczy RSA/SSH — wszystko po stronie klienta.
Generuj UUID v4/v7 hurtowo.
Klasyczny tekst zastępczy do makiet.
Sprawdź, które funkcje platformy webowej obsługuje Twoja przeglądarka.
Pokazuje na żywo rozmiar ekranu i viewportu.
Przetestuj każdy klawisz nowej lub starej klawiatury: układ na ekranie, wykrywanie podwójnych naciśnięć, test rollover, mapa cieplna i szybkość pisania.
Ponownie wcinaj lub minifikuj CSS.
Przelicz długość CSS między px, rem, em, pt i %.
Generuj CSS glassmorphism.
Formatuj i minifikuj kod HTML.
Konwertuj między Markdown a HTML.
Projektuj animacje CSS @keyframes.
Minifikuj i czyść kod SVG.
Generuj wszystkie standardowe rozmiary favicon.
Projektuj i eksportuj gradienty CSS.
Projektuj warstwowe box-shadow w CSS.
Wizualnie zbuduj tabelę HTML.
Generuj harmonijne palety kolorów.
Porównaj dwie migawki HTML.
Koduj lub dekoduj encje HTML.
Generuj tagi meta head, Open Graph i Twitter Card.
Konwertuj plik czcionki między TTF/OTF a WOFF.
Wizualnie buduj kombinacje klas Tailwind.
Generuj CSS neumorfizmu.
Śledź adres internetowy przez każde przekierowanie i sprawdź kody stanu, pętle i przejścia na HTTPS.
Dodaj czas trwania do godziny startu i zobacz wynikową datę/godzinę.
Przeliczaj rozmiary danych między bajtami/KB/MB/GB/TB, dziesiętnie lub binarnie.
Arytmetyka binarna i konwerter systemów liczbowych.
AND/OR/XOR/NOT/przesunięcia z widokiem na poziomie bitów.
Rozwiń blok CIDR lub zakres adresów do wszystkich pojedynczych adresów IP.
Obliczenia podsieci: adres sieci i rozgłoszeniowy, maska, zakres hostów.
Przeliczaj między sekundami, GG:MM:SS i czytelnymi czasami trwania.
Konwertuj IPv4 na postać całkowitą/szesnastkową i IPv6 mapowany z IPv4.
Zdekoduj flagi bitowe adresu MAC oraz najlepsze możliwe wyszukanie producenta.
Cztery popularne obliczenia procentowe w jednym miejscu.
Przeliczaj między Celsjuszem, Fahrenheitem i Kelwinem.
Konwertuj formaty adresów MAC i uzyskaj adres IPv6 link-local oraz pakiet magiczny Wake-on-LAN.
Wygeneruj prefiks Unique Local Address RFC 4193 do prywatnej numeracji IPv6.
Przeliczaj CIDR, maskę podsieci i maskę wildcard oraz generuj linie ACL Cisco.
Generuj losowe numery portów TCP/UDP dla serwerów deweloperskich i konfiguracji.
Generuj losowe, lokalnie administrowane adresy MAC.
Arytmetyka i operacje bitowe w systemie szesnastkowym oraz konwerter systemów.
Znajdź właściciela, AS pochodzenia, ogłaszany prefiks i sąsiadów BGP dla IP, prefiksu, numeru AS lub nazwy hosta.
Przeszukiwalna lista popularnych portów TCP i UDP oraz usług, które z nich korzystają.
Przeliczaj bps/Mbps itd. i szacuj czas pobierania.
Przeliczaj czas między strefami z uwzględnieniem czasu letniego i znajdź godzinę spotkania dla wszystkich.
Oblicz potrzebne okno TCP i rzeczywistą przepustowość przy danej przepustowości łącza, opóźnieniu i utracie pakietów.
Agreguj trasy IPv4 i IPv6 do najmniejszej listy prefiksów lub jednej trasy zbiorczej.
Konwertuj tekst na 8-bitowe bajty binarne i z powrotem.
Koduj procentowo lub dekoduj tekst w trybie komponentu lub pełnego URI.
Konwertuj tekst na dziesiętne kody znaków i z powrotem.
Konwertuj tekst na punkty kodowe Unicode (U+XXXX) i z powrotem.
Konwertuj tekst na bajty szesnastkowe i z powrotem.
Konwertuj tekst do/z Base58 (alfabet Bitcoina).
Automatycznie wykrywaj i dekoduj Base64, szesnastkowy, kodowanie URL, gzip i inne, warstwa po warstwie.
Konwertuj tekst do/z Base32 (RFC 4648).
Zamień dowolny plik na data URI Base64, w całości w przeglądarce.
Konwertuj Base64 na ciąg bajtów szesnastkowych i z powrotem.
Konwertuj query string adresu URL na obiekt JSON i z powrotem.
Testuj wzorzec na tekście z podświetlaniem dopasowań na żywo i grupami przechwytującymi.
Oblicz wyrażenie matematyczne prawdziwym parserem (bez eval): operatory, funkcje, stałe.
Losowo zmień kolejność linii.
Przekształć listę: przytnij, usuń duplikaty, posortuj, ujmij w cudzysłowy i połącz dowolnym separatorem.
Liczba znaków, słów, linii i zdań na żywo.
Usuń puste lub zawierające tylko białe znaki linie.
Znajduj i zamieniaj tekst z opcjami regex i całych słów.
Przeszukiwalny zbiór tokenów, kwantyfikatorów i popularnych wzorców regex.
Porównanie tekstu linia po linii z wyróżnieniem dodanych i usuniętych.
Konwertuj między WIELKIMI/małymi/Tytułowymi/camelCase/snake_case itd.
Znormalizuj e-mail do postaci kanonicznej dla dostawcy, aby usuwać duplikaty.
Zamień tekst na ASCII art, próbkując prawdziwą czcionkę, a nie stały zestaw glifów.
Zamień tekst na slug bezpieczny dla adresów URL.
Skracaj słowa jak „i18n”: pierwsza litera, liczba liter w środku, ostatnia litera.
Sortuj linie alfabetycznie, A-Z lub Z-A.
Szukaj i kopiuj z wyselekcjonowanego zestawu popularnych emoji, pogrupowanych według kategorii.
Losowy tekst wypełniający z popularnych angielskich słów.
Przeliteruj tekst alfabetem fonetycznym NATO.
Usuń powtórzone linie, zachowując pierwsze wystąpienie.
Konwertuj między liczbami arabskimi a rzymskimi.
Rozbij numer telefonu na kod kraju E.164, kraj i numer krajowy.
Zbuduj alternatywne tagi link hreflang dla wersji językowych.
Zbuduj sitemap.xml z wklejonej listy adresów URL.
Zbuduj robots.txt z grup reguł.
Zbuduj dane strukturalne JSON-LD dla popularnych typów.
Zbuduj dokument JSON polityki AWS IAM.
Podziel CIDR VPC na równe podsieci.
Przełączaj uprawnienia plików Unix, aby zbudować polecenie chmod.
Zbuduj plik zmiennych Terraform.
Analizuj lub buduj ARN AWS.
Sprawdź kody regionów AWS/GCP/Azure.
Przykładowe zdarzenia dla S3/API Gateway/SNS/SQS/EventBridge.
Ponownie wcinaj konfigurację Terraform.
Zarządzaj plikami .env i porównuj je.
Zamień polecenie docker run na równoważny blok usługi docker-compose.yml.
Wygeneruj przepływ pracy GitHub Actions dla Node, Python, PHP, Go, Java, Rust, .NET, Docker lub Pages.
Analizuj i buduj adresy S3 (virtual-hosted, path-style, s3://).
Konwertuj plik .env na JSON lub YAML i z powrotem.
Konwertuj między zwykłym JSON a JSON AttributeValue DynamoDB.
Sprawdź, które wersje spełniają zakres wersji semantycznych w stylu npm.
Zbuduj plik .htaccess dla Apache: przekierowania, HTTPS, cache, kompresja i bezpieczeństwo, z regułami Nginx.
Generuj bloki server nginx.
Monitoruj dostępność stron i usług.
Wygeneruj Dockerfile dla popularnych stosów.
Buduj i objaśniaj wyrażenia cron.
Analizuj ciąg User-Agent.
Wygeneruj plik docker-compose.yml.
Generuj manifesty Kubernetes.
Koduj lub dekoduj tekst i pliki w Base64.
Generuj bezpieczne losowe tokeny i klucze API.
Generuj skróty z rodziny MD5/SHA.
Generuj hurtowo sortowalne ULID kodowane Base32 Crockforda.
Generuj na żywo kod TOTP (RFC 6238) z sekretu Base32 lub URI otpauth://.
Wyszukaj identyfikator CVE lub produkt: ważność, status CISA KEV, prawdopodobieństwo wykorzystania, dotknięte produkty i odnośniki.
Haszuj lub weryfikuj tekst bcryptem, używając natywnych password_hash/password_verify w PHP.
Testuj zachowanie CORS endpointu.
Odczytaj wersję i czas utworzenia zapisane w UUID i generuj sortowalne UUID v7.
Pokaż odcisk SHA256 i MD5, typ oraz rozmiar publicznego klucza SSH i porównaj go z innym.
Oceniaj podatności według CVSS 3.1: wyniki bazowy, czasowy i środowiskowy oraz ciąg wektora.
Zwaliduj sumę kontrolną mod-97 numeru IBAN i rozbij go na kraj i BBAN.
Oblicz HMAC z wiadomości i tajnego klucza (SHA-1/256/384/512).
Szyfruj i odszyfrowuj tekst popularnymi szyframi.
Zamaskuj środek ciągu, aby ukryć klucze/e-maile na zrzutach ekranu.
Wygeneruj frazę seed BIP39 (12-24 słowa) z poprawną entropią i sumą kontrolną.
Zbuduj Content-Security-Policy i znajdź słabe punkty w istniejącej.
Sprawdź, czy hasło występuje w znanych wyciekach, bez jego wysyłania.
Utwórz atrybut integrity i znacznik HTML dla skryptów i arkuszy stylów ładowanych z CDN.
Wyodrębnij IP, domeny, URL, e-maile, skróty i CVE z tekstu oraz zneutralizuj lub przywróć linki.
Oceń siłę hasła i oszacuj czas jego złamania, w całości po stronie klienta.
Utwórz plik security.txt zgodny z RFC 9116, aby badacze wiedzieli, jak zgłaszać luki.
Sprawdź, jaki algorytm utworzył skrót, lub oblicz sumę kontrolną pliku za pomocą MD5, SHA-1 i SHA-2.
Zdekoduj certyfikat X.509 lub CSR: podmiot, wystawca, ważność, SAN, klucz i odciski.
Monitoruj daty wygaśnięcia certyfikatów SSL.
Wyślij serię żądań do endpointu, aby znaleźć jego rzeczywisty limit.
Przeszukiwalny wykaz rozszerzenie pliku <-> typ MIME.
Fill in {{variable}} prompt templates and preview the resolved prompt.
Przeszukiwalny wykaz wszystkich standardowych kodów statusu odpowiedzi HTTP.
Twórz i wysyłaj żądania HTTP, sprawdzaj odpowiedzi i zapisuj historię.
Zwaliduj żądanie chat completions lub kształt schematu funkcji/narzędzia.
Konwertuj polecenia curl na fetch, Python, PHP lub HTTPie i z powrotem.
Zbuduj lub zdekoduj nagłówek HTTP Authorization: Basic.
Pobiera adres URL i wyjaśnia jego nagłówki odpowiedzi, z oceną bezpieczeństwa.
Projektuj specyfikacje endpointów REST i generuj z nich dokumentację oraz makiety.
Dekoduj i sprawdzaj nagłówek oraz payload JWT, weryfikuj podpisy.
Przejdź przez przepływ OAuth2 z kodem autoryzacji i sprawdź tokeny.
Porównaj dwie odpowiedzi API i zobacz różnice w uporządkowanej formie.
Oszacuj liczbę tokenów promptu dla LLM.
Konwertuj specyfikację OpenAPI/Swagger na kolekcję Postman i z powrotem.
Uzyskaj unikalny adres skrzynki i na żywo sprawdzaj przychodzące żądania webhook.
Stale monitoruj dostępność i opóźnienia endpointu przez cron.
Współczynnik kontrastu WCAG tekstu do tła, wynik AA/AAA.
Konwertuj między RGB a HSV/HSB, modelem używanym w próbnikach Photoshopa i Figmy.
Konwertuj między kodami szesnastkowymi a wartościami RGB.
Konwertuj między RGB a HSL.
Wybierz kolor i zobacz go jako HEX/RGB/HSL.
Konwertuj między wartościami CMYK (druk) a RGB (ekran).
Generuj losowe kolory szesnastkowe (pastelowe/żywe/ciemne).
Przeglądaj domyślną paletę kolorów Tailwind CSS.
Konwertuj między standardowymi nazwami kolorów CSS a kodami szesnastkowymi.
Przeglądaj paletę kolorów Material Design Google.
Buduj przykładowe payloady APNs i FCM.
Zwaliduj google-services.json względem oczekiwanej struktury konfiguracji Firebase.
Zbuduj plik .entitlements (powiązane domeny, grupy aplikacji, push, iCloud itd.).
Generuj wszystkie wymagane rozmiary ikon aplikacji.
Wygeneruj politykę prywatności aplikacji mobilnej.
Zarządzaj ciągami tłumaczeń w wielu językach.
Analizuj konkurencyjność słów kluczowych.
Wyświetl pliki i rozmiary wewnątrz APK.
Znajdź cenne słowa kluczowe ASO.
Generuj metadane dla App Store i Play Store.
Generuj notatki o wydaniu dla sklepów z aplikacjami.
Zbuduj .gitignore z list kontrolnych dla języka, edytora i systemu.
Przeszukiwalny zbiór popularnych poleceń git.
Wygeneruj konwencjonalny komunikat commit.
Wizualizuj konflikty scalania i pomagaj je rozwiązywać.
Znajdź nieaktualne lub scalone gałęzie do usunięcia.
Twórz plakietki shields.io dla wersji, budowania, licencji i pobrań i kopiuj je jako Markdown lub HTML.
Wygeneruj changelog z historii commitów.
Waliduj i formatuj dokumenty YAML.
Porównaj dwa dokumenty JSON.
Waliduj, formatuj i minifikuj JSON.
Formatuj i waliduj XML.
Konwertuj między TOML a JSON/YAML.
Konwertuj JSON na XML, zgodnie z konwencjami naszego konwertera XML na JSON.
Generuj realistyczny przykładowy JSON zgodny z JSON Schema, z powtarzalnym ziarnem.
Zbuduj schemat JSON wizualnie na podstawie przykładowych danych.
Konwertuj JSON na CSV ze spłaszczaniem, separatorami i wynikiem przyjaznym dla Excela.
Generuj typy TypeScript, Go, Java, C# lub Python z przykładowego JSON.
Konwertuj dokumenty XML na JSON.
Ponownie wcinaj reguły bezpieczeństwa Firestore.
Testuj wyrażenia JSONPath na przykładowym JSON-ie.
Waliduj TOML i wyświetl podgląd jako JSON.
Konwertuj plik .properties Javy na JSON lub YAML i z powrotem.
Konwertuj między CSV a JSON.
Konwertuj popularny podzbiór YAML na JSON i z powrotem.
Konwertuj CSV na prawdziwy plik .xlsx i z powrotem.
Generuj testowe adresy e-mail w domenach zarezerwowanych przez RFC 2606.
Generuj fałszywe numery telefonów (centrala 555 w USA itd.).
Generuj fałszywe imiona, e-maile i nazwy użytkowników do testów.
Generuj poprawne wg Luhna fikcyjne numery kart do testów w sandboxie.
Generuj fałszywe adresy pocztowe do testów.
Bezpiecznie wyświetl podgląd kodu SVG (renderowany jako obraz, niewstrzykiwany).
Zmniejsz obraz dzięki regulowanej jakości JPEG/WebP.
Zaznacz przeciągnięciem i przytnij obraz.
Zmień rozmiar obrazu na dokładne wymiary.
Konwertuj obraz na data URI base64 i z powrotem.
Zamień fragment kodu w stylowy PNG z motywami, ramkami okna i numerami wierszy.
Rasteryzuj kod SVG do PNG lub JPEG w dowolnym rozmiarze.
Konwertuj obraz między formatami.
Generuj lekki zastępczy obraz inline SVG bez żądania sieciowego.
Odzyskaj oryginalny adres z linku opakowanego przez Microsoft Safe Links.
Konwertuj między znacznikami czasu Unix a datami.
Rozbij URL na protokół, host, ścieżkę, parametry zapytania i hash.
Zbuduj deep link z własnym schematem URI.
Zbuduj wieloplatformowy link sms: z wypełnioną wiadomością.
Zbuduj link do Google Play Store z nazwy pakietu.
Zbuduj link do Apple App Store z identyfikatora aplikacji.
Zbuduj link mailto: z tematem/treścią/DW/UDW.
Zbuduj link wa.me do rozpoczęcia czatu jednym kliknięciem.
Śledź przekierowania do ostatecznego celu.
Twórz krótkie linki przekierowujące.
Buduj zapytania MongoDB wizualnie.
Konwertuj wiersze CSV na instrukcje INSERT.
Formatuj i upiększaj zapytania SQL.
Przeanalizuj zapytanie pod kątem potencjalnych problemów z wydajnością.
Wizualizuj relacje między tabelami.
Przetwórz instrukcje INSERT na tablicę JSON.
Porównaj dwie migawki schematu lub zapytań.
Wygeneruj diagram ER ze schematu.
Wizualizuj plan EXPLAIN.
Sformatuj czytelnie zapytanie/dokument MongoDB.
Generuj kod kreskowy EAN-13.
Formatuj surowe stack trace do czytelnej postaci.
Podsumuj wskaźniki i wzorce błędów w logach.
Analizuj i podsumowuj raporty awarii.
Przeszukuj i śledź na żywo wgrane pliki logów.