בדיקות API, כלי JSON/מסדי נתונים/Git, מחוללי ענן, כלי בינה מלאכותית למפתחים ועוד — בחינם, ובלי הרשמה לשימוש בסיסי.
לחצו על מקש כדי לראות בזמן אמת את ערכי key, code ו-keyCode של KeyboardEvent.
המירו פקודות curl ל-fetch, Python, PHP או HTTPie ובחזרה.
צרו ושלחו בקשות HTTP, בדקו תגובות ושמרו היסטוריה.
בדקו אילו יכולות של פלטפורמת האינטרנט הדפדפן שלכם תומך בהן.
מדריך חיפוש לכל קודי הסטטוס הסטנדרטיים של תגובות HTTP.
בנו או פענחו כותרת HTTP Authorization: Basic.
השוו את מהירות הריצה של 2 קטעי JS או יותר ב-Web Worker מבודד.
קודדו באחוזים או פענחו טקסט, במצב רכיב או URI מלא.
המירו בין TOML ל-JSON/YAML.
בדקו תבנית על טקסט עם הדגשה חיה של התאמות וקבוצות לכידה.
הפכו צילומי מסך לתמונות מלוטשות עם מסגרות מכשיר, גרדיאנטים, צללים וטקסט.
שעון עצר בדפדפן עם זמני הקפות.
מציג את כתובת ה-IP שממנה השרת שלנו רואה אתכם מתחברים.
חפשו פרטי רישום של דומיין.
צרו קוד QR הניתן לסריקה עם הגדרות מוכנות, צבעים, ייצוא SVG/PNG ומצב אצווה.
צרו סיסמאות אקראיות חזקות.
צרו סיסמאות, מפתחות API, מפתחות AES, UUID וזוגות מפתחות RSA/SSH — הכול בצד הלקוח.
צרו UUID מגרסאות v4/v7 בכמות גדולה.
טקסט מילוי קלאסי לדגמים.
הסירו שורות ריקות או שורות של רווחים בלבד.
ספירה חיה של תווים, מילים, שורות ומשפטים.
שלחו התפרצות בקשות לנקודת קצה כדי למצוא את מגבלת הקצב בפועל.
השוו בין שתי תגובות API וראו את ההבדלים בצורה מובנית.
הריצו שאילתות מול כל נקודת קצה של GraphQL וסיירו בסכמה שלה.
מושך כתובת URL ומסביר את כותרות התגובה שלה, עם ציון אבטחה.
פענחו ובדקו את הכותרת והמטען של JWT ואמתו חתימות.
מדריך חיפוש להתאמות בין סיומת קובץ <-> סוג MIME.
עברו על זרימת קוד האימות של OAuth2 ובדקו את האסימונים.
אמתו בקשת chat completions או את מבנה סכמת הפונקציה/הכלי.
המירו מפרט OpenAPI/Swagger לאוסף Postman ובחזרה.
Fill in {{variable}} prompt templates and preview the resolved prompt.
תכננו מפרטי נקודות קצה של REST והפיקו מהם תיעוד ודמיות.
העריכו את מספר האסימונים בהנחיית LLM.
נטרו באופן רציף את זמינות נקודת הקצה ואת זמן התגובה שלה באמצעות cron.
קבלו כתובת תיבת דואר ייחודית ובדקו בקשות webhook נכנסות בזמן אמת.
מציג בזמן אמת את גודל המסך ואזור התצוגה.
הציגו תצוגה מקדימה של URL בגדלי אזור תצוגה של מכשירים נפוצים.
המירו קובץ .env ל-JSON או YAML ובחזרה.
בנו קובץ משתנים של Terraform.
נתחו או בנו ARN של AWS.
החליפו הרשאות קבצים ב-Unix כדי לבנות פקודת chmod.
חפשו קודי אזורים של AWS/GCP/Azure.
בנו והסבירו ביטויי cron.
צרו קובץ docker-compose.yml.
המירו פקודת docker run לבלוק שירות מקביל ב-docker-compose.yml.
צרו Dockerfile למחסניות נפוצות.
המירו בין JSON רגיל ל-JSON בפורמט AttributeValue של DynamoDB.
נהלו והשוו קובצי .env.
בנו מסמך JSON של מדיניות AWS IAM.
צרו מניפסטים של Kubernetes.
מטענים לדוגמה לאירועי S3/API Gateway/SNS/SQS/EventBridge.
צרו בלוקי server של nginx.
נתחו/בנו כתובות S3 (virtual-hosted, path-style, s3://).
סדרו מחדש את ההזחה של תצורת Terraform.
נטרו את זמינות האתרים והשירותים.
נתחו מחרוזת User-Agent.
חלקו CIDR של VPC לרשתות משנה שוות בגודלן.
המירו בין ערכי צבע CMYK (הדפסה) ל-RGB (מסך).
המירו בין שמות צבעים סטנדרטיים ב-CSS לקודים הקסדצימליים.
בחרו צבע וראו אותו כ-HEX/RGB/HSL.
יחס ניגודיות WCAG בין טקסט לרקע, עם עובר/נכשל ל-AA/AAA.
המירו בין קודי צבע הקסדצימליים לערכי RGB.
עיינו בפלטת הצבעים של Material Design מבית Google.
צרו צבעים הקסדצימליים אקראיים (פסטל/חיוניים/כהים).
המירו בין RGB ל-HSL.
המירו בין RGB ל-HSV/HSB, המודל שבו משתמשים בוררי הצבעים של Photoshop ו-Figma.
עיינו בפלטת הצבעים המובנית של Tailwind CSS.
המירו שורות CSV להצהרות INSERT.
הציגו חזותית את הקשרים בין טבלאות.
צרו דיאגרמת ER מסכמה.
עצבו שאילתה/מסמך של MongoDB בצורה קריאה.
בנו שאילתות MongoDB באופן חזותי.
הציגו חזותית תוכנית EXPLAIN.
השוו בין שני צילומי מצב של סכמה או שאילתות.
עצבו ויפו שאילתות SQL.
נתחו שאילתה לאיתור בעיות ביצועים אפשריות.
נתחו הצהרות INSERT למערך JSON.
המירו טקסט לקודי תווים עשרוניים ובחזרה.
המירו טקסט אל/מ-Base32 (RFC 4648).
המירו טקסט אל/מ-Base58 (האלפבית של ביטקוין).
המירו Base64 למחרוזת בתים הקסדצימלית ובחזרה.
המירו טקסט לבתים בינאריים של 8 סיביות ובחזרה.
המירו כל קובץ ל-data URI של Base64 בתוך הדפדפן שלכם.
המירו טקסט לבתים הקסדצימליים ובחזרה.
המירו מחרוזת שאילתה של URL לאובייקט JSON ובחזרה.
המירו טקסט לנקודות קוד של Unicode (U+XXXX) ובחזרה.
צרו מספרי כרטיס פיקטיביים תקינים לפי Luhn לבדיקות בסביבת ארגז חול.
צרו כתובות דואר מדומות לבדיקות.
צרו מספרי טלפון מדומים (מרכזיית 555 האמריקאית ועוד).
צרו שמות, אימיילים ושמות משתמש מדומים לבדיקות.
צרו כתובות אימייל לבדיקות בדומיינים השמורים לפי RFC 2606.
צרו פלטות צבעים הרמוניות.
עצבו אנימציות CSS עם @keyframes.
סדרו מחדש את ההזחה של CSS או צמצמו אותו.
עצבו וייצאו גרדיאנטים ב-CSS.
המירו אורך CSS בין px, rem, em, pt ו-%.
צרו את כל גדלי ה-favicon הסטנדרטיים.
המירו קובץ גופן בין TTF/OTF ל-WOFF.
צרו CSS בסגנון Glassmorphism.
השוו בין שני צילומי מצב של HTML.
קודדו או פענחו ישויות HTML.
עצבו וצמצמו קוד HTML.
בנו טבלת HTML באופן חזותי.
המירו בין Markdown ל-HTML.
צרו תגי meta, Open Graph ו-Twitter Card לראש הדף.
צרו CSS בסגנון Neumorphism.
עצבו box-shadow רב-שכבתי ב-CSS.
צמצמו ונקו קוד SVG.
בנו שילובי מחלקות Tailwind באופן חזותי.
בנו קובץ .gitignore מרשימות סימון לפי שפה, עורך ומערכת הפעלה.
מצאו ענפים ישנים או ממוזגים לניקוי.
צרו יומן שינויים מהיסטוריית commit.
מדריך חיפוש לפקודות git נפוצות.
צרו הודעת commit בפורמט Conventional Commits.
הציגו קונפליקטים במיזוג וסייעו בפתרונם.
צרו הערות גרסה מ-PR שמוזגו.
המירו תמונה ל-data URI של base64 ובחזרה.
הקטינו תמונה בעזרת איכות JPEG/WebP מתכווננת.
סמנו בגרירה וחתכו תמונה.
שנו גודל של תמונה למידות מדויקות.
המירו תמונה בין פורמטים.
צרו תמונה זמנית קלת משקל בפורמט SVG מוטבע ללא בקשת רשת.
הפכו קוד SVG ל-PNG או JPEG בכל גודל.
הציגו קוד SVG בבטחה (מוצג כתמונה ולא מוזרק לדף).
המירו בין CSV ל-JSON.
המירו CSV לקובץ .xlsx אמיתי ובחזרה.
סדרו מחדש את ההזחה של כללי האבטחה של Firestore.
המירו קובץ Java .properties ל-JSON או YAML ובחזרה.
השוו בין שני מסמכי JSON.
אמתו, עצבו וצמצמו JSON.
בדקו ביטויי JSONPath על JSON לדוגמה.
בנו סכמת JSON באופן חזותי מנתוני דוגמה.
המירו JSON ל-XML לפי המוסכמות של ממיר ה-XML ל-JSON שלנו.
אמתו TOML והציגו אותו כ-JSON.
עצבו ואמתו XML.
המירו מסמכי XML ל-JSON.
המירו תת-קבוצה נפוצה של YAML ל-JSON ובחזרה.
אמתו ועצבו מסמכי YAML.
נתחו וסכמו דוחות קריסה.
הוסיפו הערות לצילומי מסך כדי לדווח על באגים.
סכמו שיעורי שגיאות ודפוסים ביומנים.
חפשו ועקבו בזמן אמת אחרי קובצי יומן שהועלו.
עצבו Stack Trace גולמיים לצורה קריאה.
הציגו רשימת קבצים וגדלים בתוך APK.
צרו את כל גדלי סמל האפליקציה הנדרשים.
צרו מדיניות פרטיות לאפליקציה לנייד.
צרו הערות גרסה לחנויות האפליקציות.
נתחו את רמת התחרותיות של מילות מפתח.
צרו מטא-נתונים עבור App Store/Play Store.
מצאו מילות מפתח ל-ASO בעלות ערך גבוה.
בנו קובץ .entitlements (דומיינים משויכים, קבוצות אפליקציות, דחיפה, iCloud ועוד).
אמתו קובץ google-services.json מול מבנה התצורה הצפוי של Firebase.
בנו Info.plist ל-iOS/macOS ממפתחות נפוצים של חבילה ופרטיות.
נהלו מחרוזות תרגום בין שפות.
בנו מטענים לדוגמה להתראות APNs ו-FCM.
אריתמטיקה בינארית וממיר בסיסים.
AND/OR/XOR/NOT/הזזה עם תצוגה ברמת הסיבית.
חישובי רשתות משנה: כתובת רשת ושידור, מסכת רשת, טווח מארחים.
המירו בין שניות, HH:MM:SS ומשכי זמן קריאים.
הוסיפו משך זמן לשעת התחלה וראו את התאריך והשעה שיתקבלו.
אריתמטיקה ופעולות סיביות בהקסדצימלי וממיר בסיסים.
המירו IPv4 לצורת מספר שלם/הקסדצימלי ול-IPv6 ממופה מ-IPv4.
הרחיבו בלוק CIDR או טווח כתובות לכל כתובות ה-IP הבודדות.
צרו קידומת כתובת מקומית ייחודית לפי RFC 4193 למספור IPv6 פרטי.
צרו כתובות MAC אקראיות בניהול מקומי.
פענחו את דגלי הסיביות של כתובת MAC וחפשו יצרן בכמיטב היכולת.
המירו bps/Mbps ועוד והעריכו זמן הורדה.
ארבעה חישובי אחוזים נפוצים במקום אחד.
צרו מספרי פורט TCP/UDP אקראיים לשרתי פיתוח ולתצורות.
המירו גדלי נתונים בין בתים/KB/MB/GB/TB, בשיטה עשרונית או בינארית.
המירו בין צלזיוס, פרנהייט וקלווין.
בדוק אם אתר מקוון וראה את האחסון, זיהוי וורדפרס, SSL, DNS, SEO וביצועים.
צרו ברקוד EAN-13.
קודדו או פענחו טקסט וקבצים ב-Base64.
גבבו או אמתו טקסט באמצעות bcrypt, בעזרת password_hash/password_verify המובנות של PHP.
צרו ביטוי זרע BIP39 (12-24 מילים) עם אנטרופיה וסכום ביקורת תקינים.
בדקו את התנהגות ה-CORS של נקודת קצה.
הצפינו ופענחו טקסט בצפנים נפוצים.
צרו גיבובים ממשפחת MD5/SHA.
חשבו HMAC מהודעה ומפתח סודי (SHA-1/256/384/512).
אמתו את סכום הביקורת mod-97 של IBAN ופרקו אותו למדינה ו-BBAN.
צרו קוד TOTP חי (RFC 6238) מסוד Base32 או מ-URI בפורמט otpauth://.
דרגו את חוזק הסיסמה והעריכו כמה זמן ייקח לפצח אותה, הכול בצד הלקוח.
נטרו תאריכי תפוגה של אישורי SSL.
הסתירו את אמצע המחרוזת כדי להסתיר מפתחות/אימיילים בצילומי מסך.
צרו אסימונים ומפתחות API אקראיים ובטוחים.
צרו ULID ניתנים למיון בקידוד Crockford Base32 בכמות גדולה.
בנו תג link קנוני.
בנו תגי link חלופיים של hreflang לגרסאות שפה.
בנו קובץ robots.txt מקבוצות כללים.
בנו נתונים מובנים בפורמט JSON-LD לסוגים נפוצים.
בנו sitemap.xml מרשימת כתובות URL שהדבקתם.
הפכו טקסט לאמנות ASCII על ידי דגימת גופן אמיתי ולא קבוצת גליפים קבועה.
המירו בין UPPER/lower/Title/camelCase/snake_case ועוד.
הסירו שורות חוזרות ושמרו את המופע הראשון.
נרמלו כתובת אימייל לצורה הקנונית של הספק כדי להסיר כפילויות.
חפשו והעתיקו מתוך מבחר אמוג'י נפוצים, מקובצים לפי קטגוריה.
חפשו והחליפו טקסט עם regex ואפשרויות של מילה שלמה.
עצבו רשימה מחדש: חיתוך רווחים, הסרת כפילויות, מיון, עטיפה וחיבור בכל מפריד.
חשבו ביטוי מתמטי באמצעות מנתח אמיתי (ללא eval) — אופרטורים, פונקציות וקבועים.
קצרו מילים כמו "i18n": האות הראשונה, מספר האותיות שבאמצע והאות האחרונה.
פרקו מספר טלפון לקידומת E.164, מדינה ומספר מקומי.
טקסט מילוי אקראי ממילים נפוצות באנגלית.
מדריך חיפוש לאסימוני regex, כמתים ותבניות נפוצות.
המירו בין מספרים ערביים לספרות רומיות.
סדרו את השורות בסדר אקראי.
המירו טקסט ל-slug בטוח לשימוש ב-URL.
מיינו שורות לפי סדר אלפביתי, A-Z או Z-A.
השוואת שורות בטקסט רגיל עם הדגשת תוספות והסרות.
אייתו טקסט באמצעות האלפבית הפונטי של נאט"ו.
בנו קישור ל-Apple App Store ממזהה אפליקציה.
בנו קישור עמוק עם סכמת URI מותאמת.
בנו קישור mailto: עם נושא, גוף, העתק והעתק מוסתר.
בנו קישור ל-Google Play Store משם חבילה.
שחזרו את כתובת ה-URL המקורית מקישור שעטף Microsoft Safe Links.
בנו קישור sms: חוצה פלטפורמות עם הודעה שמולאה מראש.
המירו בין חותמות זמן של Unix לתאריכים.
עקבו אחר הפניות עד היעד הסופי.
פרקו כתובת URL לפרוטוקול, מארח, נתיב, פרמטרי שאילתה ו-hash.
צרו קישורי הפניה קצרים.
בנו קישור wa.me לפתיחת צ'אט בלחיצה אחת.