Форматируйте минифицированный JavaScript или сжимайте его с безопасной обработкой строк, шаблонов и регулярных выражений.
Проверьте, работает ли сайт, и узнайте хостинг, наличие WordPress, SSL, DNS, SEO и производительность.
Сравните скорость выполнения 2+ фрагментов JS в изолированном Web Worker.
Прочитайте карту любого сайта, посмотрите структуру страниц в виде дерева и графа и проверьте заголовки, мета-теги и коды ответа.
Проследите веб-адрес через все перенаправления и узнайте коды статуса, циклы и переходы на HTTPS.
Соберите Info.plist для iOS/macOS из типичных ключей bundle и конфиденциальности.
Преобразуйте список: обрезка, удаление дублей, сортировка, обрамление и объединение любым разделителем.
Соберите JSON-документ политики AWS IAM.
Форматируйте и минифицируйте HTML-разметку.
Проверьте каждую клавишу новой или старой клавиатуры: экранная раскладка, обнаружение двойных нажатий, тест rollover, тепловая карта и скорость печати.
Декодируйте сертификат X.509 или CSR: субъект, издатель, срок действия, SAN, ключ и отпечатки.
Сравните два ответа API и увидьте различия в структурированном виде.
Секундомер в браузере с отсечками кругов.
Показывает IP-адрес, с которого наш сервер видит ваше подключение.
Узнайте регистрационные данные домена.
Создайте сканируемый QR-код с пресетами, цветами, экспортом SVG/PNG и пакетным режимом.
Создавайте надёжные случайные пароли.
Создавайте пароли, API-ключи, ключи AES, UUID и пары ключей RSA/SSH — всё на стороне клиента.
Создавайте UUID v4/v7 пачками.
Классический текст-заполнитель для макетов.
Перерасставьте отступы или минифицируйте CSS.
Создавайте CSS глассморфизма.
Переведите длину CSS между px, rem, em, pt и %.
Минифицируйте и очищайте SVG-разметку.
Преобразуйте между Markdown и HTML.
Создавайте CSS-анимации @keyframes.
Создайте все стандартные размеры favicon.
Создавайте и экспортируйте CSS-градиенты.
Визуально создайте HTML-таблицу.
Создавайте мета-теги head, Open Graph и Twitter Card.
Создавайте многослойные CSS box-shadow.
Преобразуйте файл шрифта между TTF/OTF и WOFF.
Создавайте гармоничные цветовые палитры.
Сравните два снимка HTML.
Кодируйте или декодируйте HTML-сущности.
Создавайте CSS неоморфизма.
Визуально собирайте комбинации классов Tailwind.
Нажмите клавишу, чтобы увидеть её значения key/code/keyCode из KeyboardEvent в реальном времени.
Просмотрите URL в типичных размерах области просмотра устройств.
Показывает размер экрана и области просмотра в реальном времени.
Проверьте, какие функции веб-платформы поддерживает ваш браузер.
AND/OR/XOR/NOT/сдвиги с побитовым представлением.
Двоичная арифметика и конвертер систем счисления.
Преобразуйте форматы MAC-адресов, получите адрес IPv6 link-local и магический пакет Wake-on-LAN.
Переводите размеры данных между байтами/КБ/МБ/ГБ/ТБ, десятичные или двоичные.
Узнайте владельца, AS-источник, анонсируемый префикс и BGP-соседей для IP, префикса, номера AS или имени хоста.
Раскройте блок CIDR или диапазон адресов во все отдельные IP-адреса.
Список распространённых портов TCP и UDP и использующих их служб с поиском.
Преобразуйте CIDR, маску подсети и wildcard-маску и создавайте строки ACL для Cisco.
Добавьте длительность к времени начала и увидьте итоговые дату и время.
Расчёт подсетей: адрес сети и широковещательный адрес, маска, диапазон хостов.
Суммируйте маршруты IPv4 и IPv6 в минимальный список префиксов или один суммарный маршрут.
Четыре распространённых расчёта процентов в одном месте.
Переводите между секундами, ЧЧ:ММ:СС и читаемыми длительностями.
Преобразуйте IPv4 в целое/шестнадцатеричное представление и IPv6, отображённый из IPv4.
Создавайте случайные локально администрируемые MAC-адреса.
Создавайте случайные номера портов TCP/UDP для серверов разработки и конфигураций.
Рассчитайте нужное окно TCP и реальную пропускную способность при заданных пропускной способности, задержке и потерях пакетов.
Переводите бит/с, Мбит/с и т. д. и оценивайте время загрузки.
Преобразуйте время между часовыми поясами с учётом летнего времени и найдите время встречи для всех.
Расшифруйте битовые флаги MAC-адреса и найдите производителя по возможности.
Создайте префикс уникального локального адреса RFC 4193 для частной нумерации IPv6.
Шестнадцатеричная арифметика и битовые операции плюс конвертер систем счисления.
Переводите между градусами Цельсия, Фаренгейта и кельвинами.
Соберите альтернативные теги link hreflang для языковых версий.
Соберите robots.txt из групп правил.
Соберите sitemap.xml из вставленного списка URL.
Соберите канонический тег link.
Создайте структурированные данные JSON-LD для распространённых типов.
Управляйте файлами .env и сравнивайте их.
Отслеживайте доступность сайтов и сервисов.
Найдите коды регионов AWS/GCP/Azure.
Создавайте блоки server для nginx.
Переключайте права доступа Unix, чтобы собрать команду chmod.
Создайте рабочий процесс GitHub Actions для Node, Python, PHP, Go, Java, Rust, .NET, Docker или Pages.
Создайте файл .htaccess для Apache: редиректы, HTTPS, кэширование, сжатие и безопасность, с правилами для Nginx.
Соберите файл переменных Terraform.
Разберите или соберите AWS ARN.
Преобразуйте команду docker run в эквивалентный блок сервиса docker-compose.yml.
Разделите CIDR VPC на равные подсети.
Примеры событий для S3/API Gateway/SNS/SQS/EventBridge.
Перерасставьте отступы в конфигурации Terraform.
Создайте Dockerfile для распространённых стеков.
Преобразуйте файл .env в JSON или YAML и обратно.
Проверьте, какие версии удовлетворяют диапазону семантических версий в стиле npm.
Разбирайте и собирайте URL S3 (virtual-hosted, path-style, s3://).
Преобразуйте между обычным JSON и JSON AttributeValue DynamoDB.
Создавайте и объясняйте cron-выражения.
Разберите строку User-Agent.
Создайте файл docker-compose.yml.
Создавайте манифесты Kubernetes.
Преобразуйте текст в 8-битные двоичные байты и обратно.
Автоматически определяйте и декодируйте Base64, hex, URL-кодирование, gzip и другое, слой за слоем.
Преобразуйте текст в десятичные коды символов и обратно.
Кодируйте процентами или декодируйте текст в режиме компонента или полного URI.
Преобразуйте текст в/из Base58 (алфавит Bitcoin).
Преобразуйте текст в/из Base32 (RFC 4648).
Преобразуйте текст в шестнадцатеричные байты и обратно.
Преобразуйте текст в кодовые точки Unicode (U+XXXX) и обратно.
Преобразуйте любой файл в data URI Base64 прямо в браузере.
Преобразуйте Base64 в строку шестнадцатеричных байтов и обратно.
Преобразуйте query string URL в JSON-объект и обратно.
Кодируйте или декодируйте текст и файлы в Base64.
Покажите отпечатки SHA256 и MD5, тип и размер открытого SSH-ключа и сравните его с другим.
Оценивайте уязвимости по CVSS 3.1: базовая, временная и контекстная оценки и строка вектора.
Ищите идентификатор CVE или продукт: критичность, статус CISA KEV, вероятность эксплуатации, затронутые продукты и ссылки.
Хешируйте или проверяйте текст через bcrypt с помощью встроенных password_hash/password_verify в PHP.
Создавайте пачками сортируемые ULID в кодировке Base32 Крокфорда.
Создайте атрибут integrity и HTML-тег для скриптов и стилей, загружаемых с CDN.
Читайте версию и время создания внутри UUID и генерируйте сортируемые UUID v7.
Проверьте контрольную сумму mod-97 IBAN и разберите его на страну и BBAN.
Проверьте поведение CORS эндпоинта.
Создайте актуальный TOTP-код (RFC 6238) из секрета Base32 или URI otpauth://.
Создайте Content-Security-Policy и найдите слабые места в существующей.
Проверьте, встречается ли пароль в известных утечках, не отправляя его.
Создавайте хеши семейства MD5/SHA.
Извлекайте IP, домены, URL, email, хеши и CVE из текста, обезвреживайте и восстанавливайте ссылки.
Вычислите HMAC по сообщению и секретному ключу (SHA-1/256/384/512).
Шифруйте и расшифровывайте текст распространёнными шифрами.
Создайте файл security.txt по RFC 9116, чтобы исследователи знали, как сообщать об уязвимостях.
Узнайте, каким алгоритмом получен хеш, или вычислите контрольную сумму файла с помощью MD5, SHA-1 и SHA-2.
Создайте мнемоническую seed-фразу BIP39 (12–24 слова) с корректной энтропией и контрольной суммой.
Создавайте безопасные случайные токены и API-ключи.
Замаскируйте середину строки, чтобы скрыть ключи и email на скриншотах.
Отслеживайте даты истечения SSL-сертификатов.
Оцените надёжность пароля и время его взлома, полностью на стороне клиента.
Создайте все необходимые размеры иконки приложения.
Проверьте google-services.json на соответствие ожидаемой структуре конфигурации Firebase.
Соберите примеры payload для APNs и FCM.
Соберите файл .entitlements (связанные домены, группы приложений, push, iCloud и др.).
Создайте политику конфиденциальности для мобильного приложения.
Управляйте строками перевода для разных языков.
Анализируйте конкурентность ключевых слов.
Список файлов и размеров внутри APK.
Найдите ценные ключевые слова для ASO.
Создавайте метаданные для App Store и Play Store.
Создавайте заметки о релизе для магазинов приложений.
Соберите .gitignore из списков по языку, редактору и ОС.
Создайте журнал изменений по истории коммитов.
Поиск по распространённым командам git.
Найдите устаревшие или уже слитые ветки для удаления.
Визуализируйте конфликты слияния и помогайте их разрешать.
Создавайте значки shields.io для версии, сборки, лицензии и загрузок и копируйте их как Markdown или HTML.
Создайте conventional-сообщение коммита.
Создайте заметки о релизе по слитым PR.
Построчное сравнение текста с подсветкой добавленного и удалённого.
Ищите и заменяйте текст с regex и поиском целых слов.
Подсчёт символов, слов, строк и предложений в реальном времени.
Превратите текст в ASCII-арт, сэмплируя настоящий шрифт, а не фиксированный набор глифов.
Проверяйте шаблон на тексте с подсветкой совпадений в реальном времени и группами захвата.
Удаляйте повторы, сохраняя первое вхождение.
Поиск по токенам, квантификаторам и распространённым шаблонам regex.
Вычислите математическое выражение настоящим парсером (без eval): операторы, функции, константы.
Приведите email к канонической форме провайдера для удаления дублей.
Случайно перемешайте порядок строк.
Преобразуйте текст в slug, безопасный для URL.
Удаляйте пустые строки и строки только из пробелов.
Сокращайте слова как «i18n»: первая буква, число букв между ними, последняя буква.
Произнесите текст по фонетическому алфавиту НАТО.
Преобразуйте между арабскими и римскими числами.
Случайный текст-заполнитель из распространённых английских слов.
Ищите и копируйте из подобранного набора распространённых эмодзи по категориям.
Сортируйте строки по алфавиту: А-Я или Я-А.
Преобразуйте между ВЕРХНИМ/нижним/Заглавным/camelCase/snake_case и др.
Разберите номер телефона на код страны E.164, страну и национальный номер.
Коэффициент контрастности текста и фона по WCAG, результат AA/AAA.
Преобразуйте между RGB и HSV/HSB — моделью выбора цвета в Photoshop и Figma.
Преобразуйте между шестнадцатеричными кодами и значениями RGB.
Преобразуйте между RGB и HSL.
Преобразуйте между значениями CMYK (печать) и RGB (экран).
Выберите цвет и увидьте его в HEX/RGB/HSL.
Создавайте случайные HEX-цвета (пастельные/яркие/тёмные).
Просматривайте стандартную палитру цветов Tailwind CSS.
Преобразуйте между стандартными именами цветов CSS и HEX-кодами.
Просматривайте палитру цветов Material Design от Google.
Создавайте и отправляйте HTTP-запросы, изучайте ответы и сохраняйте историю.
Справочник всех стандартных кодов состояния HTTP с поиском.
Fill in {{variable}} prompt templates and preview the resolved prompt.
Преобразуйте команды curl в fetch, Python, PHP или HTTPie и обратно.
Поиск по соответствию расширение файла <-> MIME-тип.
Отправьте серию запросов к эндпоинту, чтобы найти его реальный лимит.
Соберите или декодируйте HTTP-заголовок Authorization: Basic.
Проверьте запрос chat completions или структуру схемы функции/инструмента.
Пройдите поток OAuth2 с кодом авторизации и изучите токены.
Декодируйте и изучайте заголовок и полезную нагрузку JWT, проверяйте подписи.
Оцените количество токенов в промпте для LLM.
Получает URL и объясняет заголовки ответа, с оценкой безопасности.
Проектируйте спецификации REST-эндпоинтов и создавайте по ним документацию и моки.
Выполняйте запросы к любому GraphQL-эндпоинту и изучайте его схему.
Преобразуйте спецификацию OpenAPI/Swagger в коллекцию Postman и обратно.
Получите уникальный адрес почтового ящика и просматривайте входящие вебхук-запросы в реальном времени.
Постоянно отслеживайте доступность и задержку эндпоинта через cron.
Преобразуйте между временными метками Unix и датами.
Восстановите исходный URL из ссылки, обёрнутой Microsoft Safe Links.
Проследите перенаправления до конечного адреса.
Соберите deep link с собственной схемой URI.
Разберите URL на протокол, хост, путь, параметры запроса и хеш.
Соберите ссылку Google Play Store по имени пакета.
Соберите ссылку mailto: с темой, текстом, копией и скрытой копией.
Соберите кроссплатформенную ссылку sms: с готовым сообщением.
Соберите ссылку Apple App Store по ID приложения.
Соберите ссылку wa.me для чата в один клик.
Создавайте короткие ссылки-перенаправления.
Проверяйте и форматируйте YAML-документы.
Визуально постройте JSON Schema по примерам данных.
Преобразуйте XML-документы в JSON.
Форматируйте и проверяйте XML.
Проверяйте, форматируйте и минифицируйте JSON.
Сравните два JSON-документа.
Преобразуйте JSON в CSV с разворачиванием вложенности, разделителями и совместимостью с Excel.
Перерасставьте отступы в правилах безопасности Firestore.
Создавайте реалистичный пример JSON по JSON Schema с воспроизводимым seed.
Создавайте типы TypeScript, Go, Java, C# или Python из примера JSON.
Преобразуйте JSON в XML по соглашениям нашего конвертера XML в JSON.
Преобразуйте между TOML и JSON/YAML.
Проверяйте выражения JSONPath на примере JSON.
Проверяйте TOML и просматривайте его как JSON.
Преобразуйте файл Java .properties в JSON или YAML и обратно.
Преобразуйте между CSV и JSON.
Преобразуйте распространённое подмножество YAML в JSON и обратно.
Преобразуйте CSV в настоящий файл .xlsx и обратно.
Создавайте тестовые адреса email в доменах, зарезервированных RFC 2606.
Создавайте поддельные номера телефонов (американский обменный код 555 и т. д.).
Создавайте фиктивные номера карт, корректные по Луну, для тестов в песочнице.
Создавайте поддельные имена, email и логины для тестирования.
Создавайте поддельные почтовые адреса для тестирования.
Превратите фрагмент кода в стильный PNG с темами, рамками окна и номерами строк.
Уменьшайте изображение с настраиваемым качеством JPEG/WebP.
Измените размер изображения до точных значений.
Выделите область перетаскиванием и обрежьте изображение.
Безопасно просматривайте SVG-разметку (отображается как изображение, без внедрения).
Преобразуйте изображение в data URI base64 и обратно.
Преобразуйте изображение между форматами.
Растеризуйте SVG-разметку в PNG или JPEG любого размера.
Создайте лёгкое встроенное SVG-изображение-заглушку без сетевого запроса.
Превращайте скриншоты в аккуратные изображения с рамками устройств, градиентами, тенями и текстом.
Форматируйте и украшайте SQL-запросы.
Стройте запросы MongoDB визуально.
Преобразуйте строки CSV в операторы INSERT.
Проанализируйте запрос на возможные проблемы с производительностью.
Преобразуйте операторы INSERT в массив JSON.
Визуализируйте связи между таблицами.
Сравните два снимка схемы или запросов.
Создайте ER-диаграмму по схеме.
Отформатируйте запрос или документ MongoDB.
Визуализируйте план EXPLAIN.
Приведите необработанные стек-трейсы к читаемому виду.
Разбирайте и обобщайте отчёты о сбоях.
Добавляйте пометки к скриншотам для сообщений об ошибках.
Сводка по частоте и шаблонам ошибок в логах.
Ищите и следите в реальном времени за загруженными лог-файлами.
Создайте штрихкод EAN-13.