Sprawdź, czy witryna działa, i zobacz hosting, wykrywanie WordPressa, SSL, DNS, SEO i wydajność.
Naciśnij klawisz, aby zobaczyć na żywo jego wartości key/code/keyCode z KeyboardEvent.
Zbuduj Info.plist iOS/macOS z typowych kluczy bundle i prywatności.
Porównaj szybkość wykonania 2+ fragmentów JS w izolowanym Web Workerze.
Wyświetl podgląd adresu URL w typowych rozmiarach viewportu urządzeń.
Odczytaj mapę witryny dowolnej strony, zobacz strukturę podstron jako drzewo i graf oraz sprawdź tytuły, tagi meta i kody stanu.
Koduj procentowo lub dekoduj tekst w trybie komponentu lub pełnego URI.
Stoper w przeglądarce z czasami okrążeń.
Konwertuj między CSV a JSON.
Analizuj konkurencyjność słów kluczowych.
Analizuj ciąg User-Agent.
Konwertuj popularny podzbiór YAML na JSON i z powrotem.
Pokazuje adres IP, z którego widzi Cię nasz serwer.
Sprawdź dane rejestracyjne domeny.
Generuj skanowalny kod QR z ustawieniami, kolorami, eksportem SVG/PNG i trybem wsadowym.
Generuj silne losowe hasła.
Generuj hasła, klucze API, klucze AES, UUID i pary kluczy RSA/SSH — wszystko po stronie klienta.
Generuj UUID v4/v7 hurtowo.
Klasyczny tekst zastępczy do makiet.
Sprawdź, które funkcje platformy webowej obsługuje Twoja przeglądarka.
Pokazuje na żywo rozmiar ekranu i viewportu.
Przetestuj każdy klawisz nowej lub starej klawiatury: układ na ekranie, wykrywanie podwójnych naciśnięć, test rollover, mapa cieplna i szybkość pisania.
Konwertuj tekst na 8-bitowe bajty binarne i z powrotem.
Konwertuj tekst na dziesiętne kody znaków i z powrotem.
Konwertuj tekst na bajty szesnastkowe i z powrotem.
Konwertuj tekst na punkty kodowe Unicode (U+XXXX) i z powrotem.
Konwertuj tekst do/z Base58 (alfabet Bitcoina).
Konwertuj tekst do/z Base32 (RFC 4648).
Zamień dowolny plik na data URI Base64, w całości w przeglądarce.
Automatycznie wykrywaj i dekoduj Base64, szesnastkowy, kodowanie URL, gzip i inne, warstwa po warstwie.
Konwertuj Base64 na ciąg bajtów szesnastkowych i z powrotem.
Konwertuj query string adresu URL na obiekt JSON i z powrotem.
Testuj wzorzec na tekście z podświetlaniem dopasowań na żywo i grupami przechwytującymi.
Oblicz wyrażenie matematyczne prawdziwym parserem (bez eval): operatory, funkcje, stałe.
Losowo zmień kolejność linii.
Usuń puste lub zawierające tylko białe znaki linie.
Znajduj i zamieniaj tekst z opcjami regex i całych słów.
Znormalizuj e-mail do postaci kanonicznej dla dostawcy, aby usuwać duplikaty.
Sortuj linie alfabetycznie, A-Z lub Z-A.
Konwertuj między WIELKIMI/małymi/Tytułowymi/camelCase/snake_case itd.
Liczba znaków, słów, linii i zdań na żywo.
Przeszukiwalny zbiór tokenów, kwantyfikatorów i popularnych wzorców regex.
Przekształć listę: przytnij, usuń duplikaty, posortuj, ujmij w cudzysłowy i połącz dowolnym separatorem.
Porównanie tekstu linia po linii z wyróżnieniem dodanych i usuniętych.
Zamień tekst na slug bezpieczny dla adresów URL.
Szukaj i kopiuj z wyselekcjonowanego zestawu popularnych emoji, pogrupowanych według kategorii.
Losowy tekst wypełniający z popularnych angielskich słów.
Skracaj słowa jak „i18n”: pierwsza litera, liczba liter w środku, ostatnia litera.
Zamień tekst na ASCII art, próbkując prawdziwą czcionkę, a nie stały zestaw glifów.
Przeliteruj tekst alfabetem fonetycznym NATO.
Konwertuj między liczbami arabskimi a rzymskimi.
Usuń powtórzone linie, zachowując pierwsze wystąpienie.
Rozbij numer telefonu na kod kraju E.164, kraj i numer krajowy.
Dodaj czas trwania do godziny startu i zobacz wynikową datę/godzinę.
Arytmetyka binarna i konwerter systemów liczbowych.
Przeliczaj rozmiary danych między bajtami/KB/MB/GB/TB, dziesiętnie lub binarnie.
Obliczenia podsieci: adres sieci i rozgłoszeniowy, maska, zakres hostów.
AND/OR/XOR/NOT/przesunięcia z widokiem na poziomie bitów.
Zdekoduj flagi bitowe adresu MAC oraz najlepsze możliwe wyszukanie producenta.
Rozwiń blok CIDR lub zakres adresów do wszystkich pojedynczych adresów IP.
Przeliczaj między sekundami, GG:MM:SS i czytelnymi czasami trwania.
Wygeneruj prefiks Unique Local Address RFC 4193 do prywatnej numeracji IPv6.
Cztery popularne obliczenia procentowe w jednym miejscu.
Przeliczaj między Celsjuszem, Fahrenheitem i Kelwinem.
Arytmetyka i operacje bitowe w systemie szesnastkowym oraz konwerter systemów.
Generuj losowe, lokalnie administrowane adresy MAC.
Śledź adres internetowy przez każde przekierowanie i sprawdź kody stanu, pętle i przejścia na HTTPS.
Konwertuj IPv4 na postać całkowitą/szesnastkową i IPv6 mapowany z IPv4.
Generuj losowe numery portów TCP/UDP dla serwerów deweloperskich i konfiguracji.
Znajdź właściciela, AS pochodzenia, ogłaszany prefiks i sąsiadów BGP dla IP, prefiksu, numeru AS lub nazwy hosta.
Przeliczaj CIDR, maskę podsieci i maskę wildcard oraz generuj linie ACL Cisco.
Konwertuj formaty adresów MAC i uzyskaj adres IPv6 link-local oraz pakiet magiczny Wake-on-LAN.
Przeliczaj bps/Mbps itd. i szacuj czas pobierania.
Przeliczaj czas między strefami z uwzględnieniem czasu letniego i znajdź godzinę spotkania dla wszystkich.
Przeszukiwalna lista popularnych portów TCP i UDP oraz usług, które z nich korzystają.
Oblicz potrzebne okno TCP i rzeczywistą przepustowość przy danej przepustowości łącza, opóźnieniu i utracie pakietów.
Agreguj trasy IPv4 i IPv6 do najmniejszej listy prefiksów lub jednej trasy zbiorczej.
Konwertuj polecenia curl na fetch, Python, PHP lub HTTPie i z powrotem.
Przeszukiwalny wykaz rozszerzenie pliku <-> typ MIME.
Twórz i wysyłaj żądania HTTP, sprawdzaj odpowiedzi i zapisuj historię.
Przeszukiwalny wykaz wszystkich standardowych kodów statusu odpowiedzi HTTP.
Wyślij serię żądań do endpointu, aby znaleźć jego rzeczywisty limit.
Fill in {{variable}} prompt templates and preview the resolved prompt.
Zbuduj lub zdekoduj nagłówek HTTP Authorization: Basic.
Zwaliduj żądanie chat completions lub kształt schematu funkcji/narzędzia.
Pobiera adres URL i wyjaśnia jego nagłówki odpowiedzi, z oceną bezpieczeństwa.
Przejdź przez przepływ OAuth2 z kodem autoryzacji i sprawdź tokeny.
Projektuj specyfikacje endpointów REST i generuj z nich dokumentację oraz makiety.
Dekoduj i sprawdzaj nagłówek oraz payload JWT, weryfikuj podpisy.
Oszacuj liczbę tokenów promptu dla LLM.
Porównaj dwie odpowiedzi API i zobacz różnice w uporządkowanej formie.
Wykonuj zapytania do dowolnego endpointu GraphQL i przeglądaj jego schemat.
Konwertuj specyfikację OpenAPI/Swagger na kolekcję Postman i z powrotem.
Uzyskaj unikalny adres skrzynki i na żywo sprawdzaj przychodzące żądania webhook.
Stale monitoruj dostępność i opóźnienia endpointu przez cron.
Zbuduj dokument JSON polityki AWS IAM.
Podziel CIDR VPC na równe podsieci.
Zbuduj plik zmiennych Terraform.
Przełączaj uprawnienia plików Unix, aby zbudować polecenie chmod.
Analizuj lub buduj ARN AWS.
Analizuj i buduj adresy S3 (virtual-hosted, path-style, s3://).
Przykładowe zdarzenia dla S3/API Gateway/SNS/SQS/EventBridge.
Sprawdź kody regionów AWS/GCP/Azure.
Zamień polecenie docker run na równoważny blok usługi docker-compose.yml.
Ponownie wcinaj konfigurację Terraform.
Konwertuj plik .env na JSON lub YAML i z powrotem.
Wygeneruj przepływ pracy GitHub Actions dla Node, Python, PHP, Go, Java, Rust, .NET, Docker lub Pages.
Konwertuj między zwykłym JSON a JSON AttributeValue DynamoDB.
Sprawdź, które wersje spełniają zakres wersji semantycznych w stylu npm.
Zbuduj plik .htaccess dla Apache: przekierowania, HTTPS, cache, kompresja i bezpieczeństwo, z regułami Nginx.
Zarządzaj plikami .env i porównuj je.
Wygeneruj Dockerfile dla popularnych stosów.
Generuj bloki server nginx.
Wygeneruj plik docker-compose.yml.
Monitoruj dostępność stron i usług.
Buduj i objaśniaj wyrażenia cron.
Generuj manifesty Kubernetes.
Generuj bezpieczne losowe tokeny i klucze API.
Koduj lub dekoduj tekst i pliki w Base64.
Testuj zachowanie CORS endpointu.
Generuj skróty z rodziny MD5/SHA.
Generuj hurtowo sortowalne ULID kodowane Base32 Crockforda.
Haszuj lub weryfikuj tekst bcryptem, używając natywnych password_hash/password_verify w PHP.
Oblicz HMAC z wiadomości i tajnego klucza (SHA-1/256/384/512).
Generuj na żywo kod TOTP (RFC 6238) z sekretu Base32 lub URI otpauth://.
Zamaskuj środek ciągu, aby ukryć klucze/e-maile na zrzutach ekranu.
Szyfruj i odszyfrowuj tekst popularnymi szyframi.
Zwaliduj sumę kontrolną mod-97 numeru IBAN i rozbij go na kraj i BBAN.
Wyszukaj identyfikator CVE lub produkt: ważność, status CISA KEV, prawdopodobieństwo wykorzystania, dotknięte produkty i odnośniki.
Wygeneruj frazę seed BIP39 (12-24 słowa) z poprawną entropią i sumą kontrolną.
Oceń siłę hasła i oszacuj czas jego złamania, w całości po stronie klienta.
Oceniaj podatności według CVSS 3.1: wyniki bazowy, czasowy i środowiskowy oraz ciąg wektora.
Odczytaj wersję i czas utworzenia zapisane w UUID i generuj sortowalne UUID v7.
Sprawdź, jaki algorytm utworzył skrót, lub oblicz sumę kontrolną pliku za pomocą MD5, SHA-1 i SHA-2.
Sprawdź, czy hasło występuje w znanych wyciekach, bez jego wysyłania.
Zbuduj Content-Security-Policy i znajdź słabe punkty w istniejącej.
Pokaż odcisk SHA256 i MD5, typ oraz rozmiar publicznego klucza SSH i porównaj go z innym.
Wyodrębnij IP, domeny, URL, e-maile, skróty i CVE z tekstu oraz zneutralizuj lub przywróć linki.
Utwórz atrybut integrity i znacznik HTML dla skryptów i arkuszy stylów ładowanych z CDN.
Zdekoduj certyfikat X.509 lub CSR: podmiot, wystawca, ważność, SAN, klucz i odciski.
Utwórz plik security.txt zgodny z RFC 9116, aby badacze wiedzieli, jak zgłaszać luki.
Monitoruj daty wygaśnięcia certyfikatów SSL.
Generuj testowe adresy e-mail w domenach zarezerwowanych przez RFC 2606.
Generuj fałszywe numery telefonów (centrala 555 w USA itd.).
Generuj fałszywe imiona, e-maile i nazwy użytkowników do testów.
Generuj poprawne wg Luhna fikcyjne numery kart do testów w sandboxie.
Generuj fałszywe adresy pocztowe do testów.
Współczynnik kontrastu WCAG tekstu do tła, wynik AA/AAA.
Konwertuj między RGB a HSV/HSB, modelem używanym w próbnikach Photoshopa i Figmy.
Wybierz kolor i zobacz go jako HEX/RGB/HSL.
Konwertuj między kodami szesnastkowymi a wartościami RGB.
Konwertuj między RGB a HSL.
Generuj losowe kolory szesnastkowe (pastelowe/żywe/ciemne).
Konwertuj między wartościami CMYK (druk) a RGB (ekran).
Przeglądaj domyślną paletę kolorów Tailwind CSS.
Konwertuj między standardowymi nazwami kolorów CSS a kodami szesnastkowymi.
Przeglądaj paletę kolorów Material Design Google.
Porównaj dwa dokumenty JSON.
Waliduj i formatuj dokumenty YAML.
Konwertuj między TOML a JSON/YAML.
Formatuj i waliduj XML.
Waliduj, formatuj i minifikuj JSON.
Konwertuj JSON na XML, zgodnie z konwencjami naszego konwertera XML na JSON.
Generuj realistyczny przykładowy JSON zgodny z JSON Schema, z powtarzalnym ziarnem.
Konwertuj JSON na CSV ze spłaszczaniem, separatorami i wynikiem przyjaznym dla Excela.
Generuj typy TypeScript, Go, Java, C# lub Python z przykładowego JSON.
Zbuduj schemat JSON wizualnie na podstawie przykładowych danych.
Konwertuj dokumenty XML na JSON.
Testuj wyrażenia JSONPath na przykładowym JSON-ie.
Waliduj TOML i wyświetl podgląd jako JSON.
Konwertuj plik .properties Javy na JSON lub YAML i z powrotem.
Ponownie wcinaj reguły bezpieczeństwa Firestore.
Konwertuj CSV na prawdziwy plik .xlsx i z powrotem.
Zmniejsz obraz dzięki regulowanej jakości JPEG/WebP.
Zaznacz przeciągnięciem i przytnij obraz.
Zmień rozmiar obrazu na dokładne wymiary.
Bezpiecznie wyświetl podgląd kodu SVG (renderowany jako obraz, niewstrzykiwany).
Konwertuj obraz na data URI base64 i z powrotem.
Konwertuj obraz między formatami.
Rasteryzuj kod SVG do PNG lub JPEG w dowolnym rozmiarze.
Zamień zrzuty ekranu w dopracowane obrazy z ramkami urządzeń, gradientami, cieniami i tekstem.
Zamień fragment kodu w stylowy PNG z motywami, ramkami okna i numerami wierszy.
Generuj lekki zastępczy obraz inline SVG bez żądania sieciowego.
Zbuduj .gitignore z list kontrolnych dla języka, edytora i systemu.
Przeszukiwalny zbiór popularnych poleceń git.
Wygeneruj konwencjonalny komunikat commit.
Wizualizuj konflikty scalania i pomagaj je rozwiązywać.
Znajdź nieaktualne lub scalone gałęzie do usunięcia.
Twórz plakietki shields.io dla wersji, budowania, licencji i pobrań i kopiuj je jako Markdown lub HTML.
Wygeneruj changelog z historii commitów.
Wygeneruj notatki o wydaniu ze scalonych PR-ów.
Zbuduj alternatywne tagi link hreflang dla wersji językowych.
Zbuduj sitemap.xml z wklejonej listy adresów URL.
Zbuduj robots.txt z grup reguł.
Zbuduj kanoniczny tag link.
Zbuduj dane strukturalne JSON-LD dla popularnych typów.
Formatuj zminifikowany JavaScript lub go kompaktuj, z bezpieczną obsługą ciągów, szablonów i regex.
Przelicz długość CSS między px, rem, em, pt i %.
Ponownie wcinaj lub minifikuj CSS.
Generuj wszystkie standardowe rozmiary favicon.
Generuj CSS glassmorphism.
Porównaj dwie migawki HTML.
Wizualnie zbuduj tabelę HTML.
Generuj harmonijne palety kolorów.
Projektuj animacje CSS @keyframes.
Koduj lub dekoduj encje HTML.
Projektuj i eksportuj gradienty CSS.
Generuj tagi meta head, Open Graph i Twitter Card.
Minifikuj i czyść kod SVG.
Projektuj warstwowe box-shadow w CSS.
Konwertuj między Markdown a HTML.
Generuj CSS neumorfizmu.
Formatuj i minifikuj kod HTML.
Konwertuj plik czcionki między TTF/OTF a WOFF.
Wizualnie buduj kombinacje klas Tailwind.
Konwertuj między znacznikami czasu Unix a datami.
Odzyskaj oryginalny adres z linku opakowanego przez Microsoft Safe Links.
Rozbij URL na protokół, host, ścieżkę, parametry zapytania i hash.
Zbuduj deep link z własnym schematem URI.
Zbuduj wieloplatformowy link sms: z wypełnioną wiadomością.
Zbuduj link do Google Play Store z nazwy pakietu.
Zbuduj link do Apple App Store z identyfikatora aplikacji.
Zbuduj link mailto: z tematem/treścią/DW/UDW.
Zbuduj link wa.me do rozpoczęcia czatu jednym kliknięciem.
Śledź przekierowania do ostatecznego celu.
Twórz krótkie linki przekierowujące.
Buduj przykładowe payloady APNs i FCM.
Zwaliduj google-services.json względem oczekiwanej struktury konfiguracji Firebase.
Zbuduj plik .entitlements (powiązane domeny, grupy aplikacji, push, iCloud itd.).
Generuj wszystkie wymagane rozmiary ikon aplikacji.
Znajdź cenne słowa kluczowe ASO.
Wygeneruj politykę prywatności aplikacji mobilnej.
Zarządzaj ciągami tłumaczeń w wielu językach.
Wyświetl pliki i rozmiary wewnątrz APK.
Generuj metadane dla App Store i Play Store.
Generuj notatki o wydaniu dla sklepów z aplikacjami.
Generuj kod kreskowy EAN-13.
Konwertuj wiersze CSV na instrukcje INSERT.
Formatuj i upiększaj zapytania SQL.
Buduj zapytania MongoDB wizualnie.
Wygeneruj diagram ER ze schematu.
Przeanalizuj zapytanie pod kątem potencjalnych problemów z wydajnością.
Sformatuj czytelnie zapytanie/dokument MongoDB.
Przetwórz instrukcje INSERT na tablicę JSON.
Wizualizuj relacje między tabelami.
Porównaj dwie migawki schematu lub zapytań.
Wizualizuj plan EXPLAIN.
Podsumuj wskaźniki i wzorce błędów w logach.
Formatuj surowe stack trace do czytelnej postaci.
Przeszukuj i śledź na żywo wgrane pliki logów.
Analizuj i podsumowuj raporty awarii.
Dodawaj adnotacje do zrzutów ekranu, aby zgłaszać błędy.