בדיקות API, כלי JSON/מסדי נתונים/Git, מחוללי ענן, כלי בינה מלאכותית למפתחים ועוד — בחינם, ובלי הרשמה לשימוש בסיסי.
לחצו על מקש כדי לראות בזמן אמת את ערכי key, code ו-keyCode של KeyboardEvent.
השוו את מהירות הריצה של 2 קטעי JS או יותר ב-Web Worker מבודד.
המירו פקודות curl ל-fetch, Python, PHP או HTTPie ובחזרה.
בדוק אם אתר מקוון וראה את האחסון, זיהוי וורדפרס, SSL, DNS, SEO וביצועים.
בדקו אילו יכולות של פלטפורמת האינטרנט הדפדפן שלכם תומך בהן.
אריתמטיקה בינארית וממיר בסיסים.
בנו קובץ משתנים של Terraform.
קודדו באחוזים או פענחו טקסט, במצב רכיב או URI מלא.
צרו ושלחו בקשות HTTP, בדקו תגובות ושמרו היסטוריה.
הוסיפו משך זמן לשעת התחלה וראו את התאריך והשעה שיתקבלו.
עברו על זרימת קוד האימות של OAuth2 ובדקו את האסימונים.
העריכו את מספר האסימונים בהנחיית LLM.
נהלו מחרוזות תרגום בין שפות.
בנו טבלת HTML באופן חזותי.
המירו בין Markdown ל-HTML.
שעון עצר בדפדפן עם זמני הקפות.
מציג את כתובת ה-IP שממנה השרת שלנו רואה אתכם מתחברים.
חפשו פרטי רישום של דומיין.
צרו קוד QR הניתן לסריקה עם הגדרות מוכנות, צבעים, ייצוא SVG/PNG ומצב אצווה.
צרו סיסמאות אקראיות חזקות.
צרו סיסמאות, מפתחות API, מפתחות AES, UUID וזוגות מפתחות RSA/SSH — הכול בצד הלקוח.
צרו UUID מגרסאות v4/v7 בכמות גדולה.
טקסט מילוי קלאסי לדגמים.
הסירו שורות ריקות או שורות של רווחים בלבד.
ספירה חיה של תווים, מילים, שורות ומשפטים.
שלחו התפרצות בקשות לנקודת קצה כדי למצוא את מגבלת הקצב בפועל.
מדריך חיפוש להתאמות בין סיומת קובץ <-> סוג MIME.
בנו או פענחו כותרת HTTP Authorization: Basic.
מדריך חיפוש לכל קודי הסטטוס הסטנדרטיים של תגובות HTTP.
Fill in {{variable}} prompt templates and preview the resolved prompt.
אמתו בקשת chat completions או את מבנה סכמת הפונקציה/הכלי.
מושך כתובת URL ומסביר את כותרות התגובה שלה, עם ציון אבטחה.
פענחו ובדקו את הכותרת והמטען של JWT ואמתו חתימות.
המירו מפרט OpenAPI/Swagger לאוסף Postman ובחזרה.
הריצו שאילתות מול כל נקודת קצה של GraphQL וסיירו בסכמה שלה.
קבלו כתובת תיבת דואר ייחודית ובדקו בקשות webhook נכנסות בזמן אמת.
תכננו מפרטי נקודות קצה של REST והפיקו מהם תיעוד ודמיות.
נטרו באופן רציף את זמינות נקודת הקצה ואת זמן התגובה שלה באמצעות cron.
השוו בין שתי תגובות API וראו את ההבדלים בצורה מובנית.
הציגו תצוגה מקדימה של URL בגדלי אזור תצוגה של מכשירים נפוצים.
מציג בזמן אמת את גודל המסך ואזור התצוגה.
המירו גדלי נתונים בין בתים/KB/MB/GB/TB, בשיטה עשרונית או בינארית.
חישובי רשתות משנה: כתובת רשת ושידור, מסכת רשת, טווח מארחים.
AND/OR/XOR/NOT/הזזה עם תצוגה ברמת הסיבית.
המירו בין צלזיוס, פרנהייט וקלווין.
הרחיבו בלוק CIDR או טווח כתובות לכל כתובות ה-IP הבודדות.
ארבעה חישובי אחוזים נפוצים במקום אחד.
צרו קידומת כתובת מקומית ייחודית לפי RFC 4193 למספור IPv6 פרטי.
המירו בין שניות, HH:MM:SS ומשכי זמן קריאים.
פענחו את דגלי הסיביות של כתובת MAC וחפשו יצרן בכמיטב היכולת.
אריתמטיקה ופעולות סיביות בהקסדצימלי וממיר בסיסים.
צרו מספרי פורט TCP/UDP אקראיים לשרתי פיתוח ולתצורות.
המירו bps/Mbps ועוד והעריכו זמן הורדה.
המירו IPv4 לצורת מספר שלם/הקסדצימלי ול-IPv6 ממופה מ-IPv4.
צרו כתובות MAC אקראיות בניהול מקומי.
רשימה הניתנת לחיפוש של יציאות TCP ו-UDP נפוצות והשירותים שמשתמשים בהן.
עקבו אחרי כתובת אתר דרך כל הפניה וראו קודי מצב, לולאות ושדרוגים ל-HTTPS.
המירו שעה בין אזורי זמן כולל שעון קיץ ומצאו שעת פגישה לכולם.
המירו בין CIDR, מסכת רשת משנה ומסכת wildcard וצרו שורות ACL של Cisco.
מצאו את הבעלים, ה-AS המקור, הקידומת המוכרזת והשכנים ב-BGP עבור IP, קידומת, מספר AS או שם מארח.
המירו פורמטים של כתובות MAC וקבלו את כתובת ה-IPv6 מקומית-הקישור ואת חבילת הקסם של Wake-on-LAN.
חשבו את חלון ה-TCP הדרוש ואת התפוקה בפועל לפי רוחב פס, השהיה ואובדן חבילות.
סכמו נתיבי IPv4 ו-IPv6 לרשימת הקידומות הקטנה ביותר או לנתיב מסכם יחיד.
המירו טקסט לקודי תווים עשרוניים ובחזרה.
המירו טקסט לנקודות קוד של Unicode (U+XXXX) ובחזרה.
המירו טקסט לבתים בינאריים של 8 סיביות ובחזרה.
המירו טקסט אל/מ-Base32 (RFC 4648).
המירו טקסט לבתים הקסדצימליים ובחזרה.
המירו טקסט אל/מ-Base58 (האלפבית של ביטקוין).
המירו Base64 למחרוזת בתים הקסדצימלית ובחזרה.
המירו כל קובץ ל-data URI של Base64 בתוך הדפדפן שלכם.
המירו מחרוזת שאילתה של URL לאובייקט JSON ובחזרה.
זהו ופענחו אוטומטית Base64, הקסדצימלי, קידוד URL, gzip ועוד, שכבה אחר שכבה.
בדקו תבנית על טקסט עם הדגשה חיה של התאמות וקבוצות לכידה.
חשבו ביטוי מתמטי באמצעות מנתח אמיתי (ללא eval) — אופרטורים, פונקציות וקבועים.
המירו בין UPPER/lower/Title/camelCase/snake_case ועוד.
מדריך חיפוש לאסימוני regex, כמתים ותבניות נפוצות.
מיינו שורות לפי סדר אלפביתי, A-Z או Z-A.
חפשו והחליפו טקסט עם regex ואפשרויות של מילה שלמה.
השוואת שורות בטקסט רגיל עם הדגשת תוספות והסרות.
סדרו את השורות בסדר אקראי.
נרמלו כתובת אימייל לצורה הקנונית של הספק כדי להסיר כפילויות.
עצבו רשימה מחדש: חיתוך רווחים, הסרת כפילויות, מיון, עטיפה וחיבור בכל מפריד.
חפשו והעתיקו מתוך מבחר אמוג'י נפוצים, מקובצים לפי קטגוריה.
המירו טקסט ל-slug בטוח לשימוש ב-URL.
טקסט מילוי אקראי ממילים נפוצות באנגלית.
קצרו מילים כמו "i18n": האות הראשונה, מספר האותיות שבאמצע והאות האחרונה.
המירו בין מספרים ערביים לספרות רומיות.
אייתו טקסט באמצעות האלפבית הפונטי של נאט"ו.
הסירו שורות חוזרות ושמרו את המופע הראשון.
הפכו טקסט לאמנות ASCII על ידי דגימת גופן אמיתי ולא קבוצת גליפים קבועה.
פרקו מספר טלפון לקידומת E.164, מדינה ומספר מקומי.
צרו אסימונים ומפתחות API אקראיים ובטוחים.
קודדו או פענחו טקסט וקבצים ב-Base64.
צרו קוד TOTP חי (RFC 6238) מסוד Base32 או מ-URI בפורמט otpauth://.
צרו גיבובים ממשפחת MD5/SHA.
בדקו את התנהגות ה-CORS של נקודת קצה.
חשבו HMAC מהודעה ומפתח סודי (SHA-1/256/384/512).
גבבו או אמתו טקסט באמצעות bcrypt, בעזרת password_hash/password_verify המובנות של PHP.
הסתירו את אמצע המחרוזת כדי להסתיר מפתחות/אימיילים בצילומי מסך.
צרו ULID ניתנים למיון בקידוד Crockford Base32 בכמות גדולה.
הצפינו ופענחו טקסט בצפנים נפוצים.
דרגו את חוזק הסיסמה והעריכו כמה זמן ייקח לפצח אותה, הכול בצד הלקוח.
אמתו את סכום הביקורת mod-97 של IBAN ופרקו אותו למדינה ו-BBAN.
צרו ביטוי זרע BIP39 (12-24 מילים) עם אנטרופיה וסכום ביקורת תקינים.
חפשו מזהה CVE או מוצר: חומרה, מצב CISA KEV, הסתברות לניצול, מוצרים מושפעים והפניות.
גלו איזה אלגוריתם יצר גיבוב, או חשבו סכום ביקורת לקובץ עם MD5, SHA-1 ו-SHA-2.
בדקו אם סיסמה מופיעה בדליפות ידועות מבלי לשלוח אותה.
קראו את הגרסה וזמן היצירה בתוך UUID וצרו ערכי UUID v7 הניתנים למיון.
דרגו פגיעויות לפי CVSS 3.1: ציון בסיס, זמני וסביבתי ומחרוזת הווקטור.
חלצו כתובות IP, דומיינים, URL, דוא״ל, גיבובים ו-CVE מטקסט, ונטרלו או שחזרו קישורים.
הציגו את טביעת האצבע SHA256 ו-MD5, הסוג והגודל של מפתח SSH ציבורי והשוו אותו למפתח אחר.
פענחו תעודת X.509 או CSR: נושא, מנפיק, תוקף, SAN, מפתח וטביעות אצבע.
צרו את מאפיין integrity ואת תג ה-HTML לסקריפטים וגיליונות סגנונות שנטענים מ-CDN.
צרו קובץ security.txt לפי RFC 9116 כדי שחוקרים ידעו איך לדווח על פגיעויות.
בנו Content-Security-Policy ומצאו חולשות במדיניות קיימת.
נטרו תאריכי תפוגה של אישורי SSL.
בנו מסמך JSON של מדיניות AWS IAM.
החליפו הרשאות קבצים ב-Unix כדי לבנות פקודת chmod.
נתחו או בנו ARN של AWS.
חלקו CIDR של VPC לרשתות משנה שוות בגודלן.
נתחו/בנו כתובות S3 (virtual-hosted, path-style, s3://).
סדרו מחדש את ההזחה של תצורת Terraform.
מטענים לדוגמה לאירועי S3/API Gateway/SNS/SQS/EventBridge.
חפשו קודי אזורים של AWS/GCP/Azure.
המירו קובץ .env ל-JSON או YAML ובחזרה.
המירו פקודת docker run לבלוק שירות מקביל ב-docker-compose.yml.
המירו בין JSON רגיל ל-JSON בפורמט AttributeValue של DynamoDB.
צרו workflow של GitHub Actions עבור Node, Python, PHP, Go, Java, Rust, .NET, Docker או Pages.
בנו קובץ .htaccess של Apache להפניות, HTTPS, מטמון, דחיסה ואבטחה, עם כללי Nginx.
בדקו אילו גרסאות עומדות בטווח גרסאות סמנטי בסגנון npm.
בנו והסבירו ביטויי cron.
צרו קובץ docker-compose.yml.
נתחו מחרוזת User-Agent.
צרו מניפסטים של Kubernetes.
צרו Dockerfile למחסניות נפוצות.
צרו בלוקי server של nginx.
נטרו את זמינות האתרים והשירותים.
נהלו והשוו קובצי .env.
עצבו ואמתו XML.
המירו בין TOML ל-JSON/YAML.
השוו בין שני מסמכי JSON.
אמתו ועצבו מסמכי YAML.
אמתו, עצבו וצמצמו JSON.
המירו JSON ל-XML לפי המוסכמות של ממיר ה-XML ל-JSON שלנו.
צרו JSON לדוגמה ריאליסטי שעומד ב-JSON Schema, עם seed שניתן לחזור עליו.
המירו JSON ל-CSV עם שיטוח, מפרידים ופלט ידידותי ל-Excel.
צרו טיפוסי TypeScript, Go, Java, C# או Python מ-JSON לדוגמה.
המירו בין CSV ל-JSON.
המירו תת-קבוצה נפוצה של YAML ל-JSON ובחזרה.
המירו מסמכי XML ל-JSON.
בדקו ביטויי JSONPath על JSON לדוגמה.
בנו סכמת JSON באופן חזותי מנתוני דוגמה.
אמתו TOML והציגו אותו כ-JSON.
המירו CSV לקובץ .xlsx אמיתי ובחזרה.
המירו קובץ Java .properties ל-JSON או YAML ובחזרה.
סדרו מחדש את ההזחה של כללי האבטחה של Firestore.
צרו שמות, אימיילים ושמות משתמש מדומים לבדיקות.
צרו כתובות אימייל לבדיקות בדומיינים השמורים לפי RFC 2606.
צרו מספרי טלפון מדומים (מרכזיית 555 האמריקאית ועוד).
צרו מספרי כרטיס פיקטיביים תקינים לפי Luhn לבדיקות בסביבת ארגז חול.
צרו כתובות דואר מדומות לבדיקות.
המירו בין חותמות זמן של Unix לתאריכים.
פרקו כתובת URL לפרוטוקול, מארח, נתיב, פרמטרי שאילתה ו-hash.
שחזרו את כתובת ה-URL המקורית מקישור שעטף Microsoft Safe Links.
בנו קישור sms: חוצה פלטפורמות עם הודעה שמולאה מראש.
בנו קישור עמוק עם סכמת URI מותאמת.
בנו קישור ל-Google Play Store משם חבילה.
בנו קישור wa.me לפתיחת צ'אט בלחיצה אחת.
בנו קישור mailto: עם נושא, גוף, העתק והעתק מוסתר.
בנו קישור ל-Apple App Store ממזהה אפליקציה.
צרו קישורי הפניה קצרים.
עקבו אחר הפניות עד היעד הסופי.
יחס ניגודיות WCAG בין טקסט לרקע, עם עובר/נכשל ל-AA/AAA.
בחרו צבע וראו אותו כ-HEX/RGB/HSL.
צרו צבעים הקסדצימליים אקראיים (פסטל/חיוניים/כהים).
המירו בין קודי צבע הקסדצימליים לערכי RGB.
המירו בין RGB ל-HSL.
המירו בין שמות צבעים סטנדרטיים ב-CSS לקודים הקסדצימליים.
המירו בין RGB ל-HSV/HSB, המודל שבו משתמשים בוררי הצבעים של Photoshop ו-Figma.
עיינו בפלטת הצבעים המובנית של Tailwind CSS.
המירו בין ערכי צבע CMYK (הדפסה) ל-RGB (מסך).
עיינו בפלטת הצבעים של Material Design מבית Google.
בנו קובץ .gitignore מרשימות סימון לפי שפה, עורך ומערכת הפעלה.
הציגו קונפליקטים במיזוג וסייעו בפתרונם.
מדריך חיפוש לפקודות git נפוצות.
צרו הודעת commit בפורמט Conventional Commits.
מצאו ענפים ישנים או ממוזגים לניקוי.
צרו תגי shields.io לגרסה, בנייה, רישיון והורדות והעתיקו אותם כ-Markdown או HTML.
צרו יומן שינויים מהיסטוריית commit.
צרו הערות גרסה מ-PR שמוזגו.
הקטינו תמונה בעזרת איכות JPEG/WebP מתכווננת.
סמנו בגרירה וחתכו תמונה.
שנו גודל של תמונה למידות מדויקות.
הציגו קוד SVG בבטחה (מוצג כתמונה ולא מוזרק לדף).
המירו תמונה בין פורמטים.
המירו תמונה ל-data URI של base64 ובחזרה.
הפכו קוד SVG ל-PNG או JPEG בכל גודל.
צרו תמונה זמנית קלת משקל בפורמט SVG מוטבע ללא בקשת רשת.
הפכו צילומי מסך לתמונות מלוטשות עם מסגרות מכשיר, גרדיאנטים, צללים וטקסט.
הפכו קטע קוד ל-PNG מעוצב עם ערכות נושא, מסגרות חלון ומספרי שורות.
בנו sitemap.xml מרשימת כתובות URL שהדבקתם.
בנו תגי link חלופיים של hreflang לגרסאות שפה.
בנו קובץ robots.txt מקבוצות כללים.
בנו תג link קנוני.
בנו נתונים מובנים בפורמט JSON-LD לסוגים נפוצים.
קראו את מפת האתר של כל אתר, ראו את מבנה הדפים כעץ וכגרף ובדקו כותרות, תגי מטא וקודי מצב.
בנו Info.plist ל-iOS/macOS ממפתחות נפוצים של חבילה ופרטיות.
בנו מטענים לדוגמה להתראות APNs ו-FCM.
אמתו קובץ google-services.json מול מבנה התצורה הצפוי של Firebase.
בנו קובץ .entitlements (דומיינים משויכים, קבוצות אפליקציות, דחיפה, iCloud ועוד).
צרו את כל גדלי סמל האפליקציה הנדרשים.
הציגו רשימת קבצים וגדלים בתוך APK.
צרו מטא-נתונים עבור App Store/Play Store.
מצאו מילות מפתח ל-ASO בעלות ערך גבוה.
צרו מדיניות פרטיות לאפליקציה לנייד.
נתחו את רמת התחרותיות של מילות מפתח.
צרו הערות גרסה לחנויות האפליקציות.
המירו אורך CSS בין px, rem, em, pt ו-%.
סדרו מחדש את ההזחה של CSS או צמצמו אותו.
עצבו JavaScript מכווץ או כווצו אותו, עם טיפול בטוח במחרוזות, תבניות וביטויים רגולריים.
עצבו וייצאו גרדיאנטים ב-CSS.
עצבו וצמצמו קוד HTML.
צרו תגי meta, Open Graph ו-Twitter Card לראש הדף.
צרו פלטות צבעים הרמוניות.
עצבו box-shadow רב-שכבתי ב-CSS.
צרו את כל גדלי ה-favicon הסטנדרטיים.
צמצמו ונקו קוד SVG.
קודדו או פענחו ישויות HTML.
צרו CSS בסגנון Glassmorphism.
צרו CSS בסגנון Neumorphism.
עצבו אנימציות CSS עם @keyframes.
בנו שילובי מחלקות Tailwind באופן חזותי.
השוו בין שני צילומי מצב של HTML.
המירו קובץ גופן בין TTF/OTF ל-WOFF.
צרו ברקוד EAN-13.
עצבו ויפו שאילתות SQL.
צרו דיאגרמת ER מסכמה.
בנו שאילתות MongoDB באופן חזותי.
המירו שורות CSV להצהרות INSERT.
נתחו הצהרות INSERT למערך JSON.
נתחו שאילתה לאיתור בעיות ביצועים אפשריות.
השוו בין שני צילומי מצב של סכמה או שאילתות.
הציגו חזותית את הקשרים בין טבלאות.
הציגו חזותית תוכנית EXPLAIN.
עצבו שאילתה/מסמך של MongoDB בצורה קריאה.
חפשו ועקבו בזמן אמת אחרי קובצי יומן שהועלו.
סכמו שיעורי שגיאות ודפוסים ביומנים.
עצבו Stack Trace גולמיים לצורה קריאה.
נתחו וסכמו דוחות קריסה.
הוסיפו הערות לצילומי מסך כדי לדווח על באגים.