Testowanie API, narzędzia JSON/baz danych/Git, generatory chmurowe, narzędzia AI dla programistów i więcej — za darmo, podstawy bez rejestracji.
Naciśnij klawisz, aby zobaczyć na żywo jego wartości key/code/keyCode z KeyboardEvent.
Konwertuj polecenia curl na fetch, Python, PHP lub HTTPie i z powrotem.
Porównaj szybkość wykonania 2+ fragmentów JS w izolowanym Web Workerze.
Sprawdź, które funkcje platformy webowej obsługuje Twoja przeglądarka.
Zbuduj plik zmiennych Terraform.
Twórz i wysyłaj żądania HTTP, sprawdzaj odpowiedzi i zapisuj historię.
Arytmetyka binarna i konwerter systemów liczbowych.
Koduj procentowo lub dekoduj tekst w trybie komponentu lub pełnego URI.
Testuj wzorzec na tekście z podświetlaniem dopasowań na żywo i grupami przechwytującymi.
Konwertuj tekst na dziesiętne kody znaków i z powrotem.
Zamień zrzuty ekranu w dopracowane obrazy z ramkami urządzeń, gradientami, cieniami i tekstem.
Generuj wszystkie wymagane rozmiary ikon aplikacji.
Konwertuj między zwykłym JSON a JSON AttributeValue DynamoDB.
Analizuj i podsumowuj raporty awarii.
Stale monitoruj dostępność i opóźnienia endpointu przez cron.
Stoper w przeglądarce z czasami okrążeń.
Pokazuje adres IP, z którego widzi Cię nasz serwer.
Sprawdź dane rejestracyjne domeny.
Generuj skanowalny kod QR z ustawieniami, kolorami, eksportem SVG/PNG i trybem wsadowym.
Generuj silne losowe hasła.
Generuj hasła, klucze API, klucze AES, UUID i pary kluczy RSA/SSH — wszystko po stronie klienta.
Generuj UUID v4/v7 hurtowo.
Klasyczny tekst zastępczy do makiet.
Usuń puste lub zawierające tylko białe znaki linie.
Liczba znaków, słów, linii i zdań na żywo.
Przeszukiwalny wykaz wszystkich standardowych kodów statusu odpowiedzi HTTP.
Przeszukiwalny wykaz rozszerzenie pliku <-> typ MIME.
Zbuduj lub zdekoduj nagłówek HTTP Authorization: Basic.
Wyślij serię żądań do endpointu, aby znaleźć jego rzeczywisty limit.
Pobiera adres URL i wyjaśnia jego nagłówki odpowiedzi, z oceną bezpieczeństwa.
Fill in {{variable}} prompt templates and preview the resolved prompt.
Zwaliduj żądanie chat completions lub kształt schematu funkcji/narzędzia.
Dekoduj i sprawdzaj nagłówek oraz payload JWT, weryfikuj podpisy.
Wykonuj zapytania do dowolnego endpointu GraphQL i przeglądaj jego schemat.
Uzyskaj unikalny adres skrzynki i na żywo sprawdzaj przychodzące żądania webhook.
Konwertuj specyfikację OpenAPI/Swagger na kolekcję Postman i z powrotem.
Przejdź przez przepływ OAuth2 z kodem autoryzacji i sprawdź tokeny.
Oszacuj liczbę tokenów promptu dla LLM.
Projektuj specyfikacje endpointów REST i generuj z nich dokumentację oraz makiety.
Porównaj dwie odpowiedzi API i zobacz różnice w uporządkowanej formie.
Wyświetl podgląd adresu URL w typowych rozmiarach viewportu urządzeń.
Pokazuje na żywo rozmiar ekranu i viewportu.
Konwertuj tekst na punkty kodowe Unicode (U+XXXX) i z powrotem.
Konwertuj tekst na 8-bitowe bajty binarne i z powrotem.
Konwertuj tekst na bajty szesnastkowe i z powrotem.
Konwertuj tekst do/z Base32 (RFC 4648).
Konwertuj tekst do/z Base58 (alfabet Bitcoina).
Zamień dowolny plik na data URI Base64, w całości w przeglądarce.
Konwertuj query string adresu URL na obiekt JSON i z powrotem.
Konwertuj Base64 na ciąg bajtów szesnastkowych i z powrotem.
Sortuj linie alfabetycznie, A-Z lub Z-A.
Konwertuj między WIELKIMI/małymi/Tytułowymi/camelCase/snake_case itd.
Oblicz wyrażenie matematyczne prawdziwym parserem (bez eval): operatory, funkcje, stałe.
Losowo zmień kolejność linii.
Znajduj i zamieniaj tekst z opcjami regex i całych słów.
Przeszukiwalny zbiór tokenów, kwantyfikatorów i popularnych wzorców regex.
Porównanie tekstu linia po linii z wyróżnieniem dodanych i usuniętych.
Znormalizuj e-mail do postaci kanonicznej dla dostawcy, aby usuwać duplikaty.
Zamień tekst na slug bezpieczny dla adresów URL.
Przekształć listę: przytnij, usuń duplikaty, posortuj, ujmij w cudzysłowy i połącz dowolnym separatorem.
Szukaj i kopiuj z wyselekcjonowanego zestawu popularnych emoji, pogrupowanych według kategorii.
Skracaj słowa jak „i18n”: pierwsza litera, liczba liter w środku, ostatnia litera.
Losowy tekst wypełniający z popularnych angielskich słów.
Konwertuj między liczbami arabskimi a rzymskimi.
Usuń powtórzone linie, zachowując pierwsze wystąpienie.
Przeliteruj tekst alfabetem fonetycznym NATO.
Rozbij numer telefonu na kod kraju E.164, kraj i numer krajowy.
Zamień tekst na ASCII art, próbkując prawdziwą czcionkę, a nie stały zestaw glifów.
Generuj bezpieczne losowe tokeny i klucze API.
Oblicz HMAC z wiadomości i tajnego klucza (SHA-1/256/384/512).
Koduj lub dekoduj tekst i pliki w Base64.
Generuj skróty z rodziny MD5/SHA.
Generuj na żywo kod TOTP (RFC 6238) z sekretu Base32 lub URI otpauth://.
Generuj hurtowo sortowalne ULID kodowane Base32 Crockforda.
Testuj zachowanie CORS endpointu.
Haszuj lub weryfikuj tekst bcryptem, używając natywnych password_hash/password_verify w PHP.
Szyfruj i odszyfrowuj tekst popularnymi szyframi.
Zamaskuj środek ciągu, aby ukryć klucze/e-maile na zrzutach ekranu.
Oceń siłę hasła i oszacuj czas jego złamania, w całości po stronie klienta.
Zwaliduj sumę kontrolną mod-97 numeru IBAN i rozbij go na kraj i BBAN.
Wygeneruj frazę seed BIP39 (12-24 słowa) z poprawną entropią i sumą kontrolną.
Monitoruj daty wygaśnięcia certyfikatów SSL.
Obliczenia podsieci: adres sieci i rozgłoszeniowy, maska, zakres hostów.
Dodaj czas trwania do godziny startu i zobacz wynikową datę/godzinę.
Przeliczaj rozmiary danych między bajtami/KB/MB/GB/TB, dziesiętnie lub binarnie.
Zdekoduj flagi bitowe adresu MAC oraz najlepsze możliwe wyszukanie producenta.
Cztery popularne obliczenia procentowe w jednym miejscu.
Przeliczaj między Celsjuszem, Fahrenheitem i Kelwinem.
AND/OR/XOR/NOT/przesunięcia z widokiem na poziomie bitów.
Przeliczaj między sekundami, GG:MM:SS i czytelnymi czasami trwania.
Wygeneruj prefiks Unique Local Address RFC 4193 do prywatnej numeracji IPv6.
Rozwiń blok CIDR lub zakres adresów do wszystkich pojedynczych adresów IP.
Arytmetyka i operacje bitowe w systemie szesnastkowym oraz konwerter systemów.
Generuj losowe numery portów TCP/UDP dla serwerów deweloperskich i konfiguracji.
Przeliczaj bps/Mbps itd. i szacuj czas pobierania.
Konwertuj IPv4 na postać całkowitą/szesnastkową i IPv6 mapowany z IPv4.
Generuj losowe, lokalnie administrowane adresy MAC.
Sprawdź, czy witryna działa, i zobacz hosting, wykrywanie WordPressa, SSL, DNS, SEO i wydajność.
Przełączaj uprawnienia plików Unix, aby zbudować polecenie chmod.
Podziel CIDR VPC na równe podsieci.
Zbuduj dokument JSON polityki AWS IAM.
Analizuj lub buduj ARN AWS.
Analizuj i buduj adresy S3 (virtual-hosted, path-style, s3://).
Konwertuj plik .env na JSON lub YAML i z powrotem.
Ponownie wcinaj konfigurację Terraform.
Sprawdź kody regionów AWS/GCP/Azure.
Przykładowe zdarzenia dla S3/API Gateway/SNS/SQS/EventBridge.
Zamień polecenie docker run na równoważny blok usługi docker-compose.yml.
Buduj i objaśniaj wyrażenia cron.
Wygeneruj plik docker-compose.yml.
Analizuj ciąg User-Agent.
Wygeneruj Dockerfile dla popularnych stosów.
Generuj manifesty Kubernetes.
Generuj bloki server nginx.
Monitoruj dostępność stron i usług.
Zarządzaj plikami .env i porównuj je.
Konwertuj między TOML a JSON/YAML.
Formatuj i waliduj XML.
Porównaj dwa dokumenty JSON.
Waliduj i formatuj dokumenty YAML.
Waliduj, formatuj i minifikuj JSON.
Konwertuj JSON na XML, zgodnie z konwencjami naszego konwertera XML na JSON.
Konwertuj między CSV a JSON.
Konwertuj popularny podzbiór YAML na JSON i z powrotem.
Konwertuj dokumenty XML na JSON.
Testuj wyrażenia JSONPath na przykładowym JSON-ie.
Zbuduj schemat JSON wizualnie na podstawie przykładowych danych.
Konwertuj plik .properties Javy na JSON lub YAML i z powrotem.
Waliduj TOML i wyświetl podgląd jako JSON.
Konwertuj CSV na prawdziwy plik .xlsx i z powrotem.
Ponownie wcinaj reguły bezpieczeństwa Firestore.
Zmień rozmiar obrazu na dokładne wymiary.
Zmniejsz obraz dzięki regulowanej jakości JPEG/WebP.
Zaznacz przeciągnięciem i przytnij obraz.
Bezpiecznie wyświetl podgląd kodu SVG (renderowany jako obraz, niewstrzykiwany).
Konwertuj obraz na data URI base64 i z powrotem.
Konwertuj obraz między formatami.
Rasteryzuj kod SVG do PNG lub JPEG w dowolnym rozmiarze.
Generuj lekki zastępczy obraz inline SVG bez żądania sieciowego.
Zbuduj .gitignore z list kontrolnych dla języka, edytora i systemu.
Przeszukiwalny zbiór popularnych poleceń git.
Wizualizuj konflikty scalania i pomagaj je rozwiązywać.
Wygeneruj konwencjonalny komunikat commit.
Znajdź nieaktualne lub scalone gałęzie do usunięcia.
Wygeneruj changelog z historii commitów.
Wygeneruj notatki o wydaniu ze scalonych PR-ów.
Generuj fałszywe imiona, e-maile i nazwy użytkowników do testów.
Generuj testowe adresy e-mail w domenach zarezerwowanych przez RFC 2606.
Generuj fałszywe numery telefonów (centrala 555 w USA itd.).
Generuj poprawne wg Luhna fikcyjne numery kart do testów w sandboxie.
Generuj fałszywe adresy pocztowe do testów.
Konwertuj między znacznikami czasu Unix a datami.
Rozbij URL na protokół, host, ścieżkę, parametry zapytania i hash.
Zbuduj wieloplatformowy link sms: z wypełnioną wiadomością.
Zbuduj deep link z własnym schematem URI.
Odzyskaj oryginalny adres z linku opakowanego przez Microsoft Safe Links.
Zbuduj link do Google Play Store z nazwy pakietu.
Zbuduj link do Apple App Store z identyfikatora aplikacji.
Zbuduj link wa.me do rozpoczęcia czatu jednym kliknięciem.
Zbuduj link mailto: z tematem/treścią/DW/UDW.
Twórz krótkie linki przekierowujące.
Śledź przekierowania do ostatecznego celu.
Współczynnik kontrastu WCAG tekstu do tła, wynik AA/AAA.
Wybierz kolor i zobacz go jako HEX/RGB/HSL.
Generuj losowe kolory szesnastkowe (pastelowe/żywe/ciemne).
Konwertuj między kodami szesnastkowymi a wartościami RGB.
Konwertuj między RGB a HSL.
Konwertuj między standardowymi nazwami kolorów CSS a kodami szesnastkowymi.
Konwertuj między RGB a HSV/HSB, modelem używanym w próbnikach Photoshopa i Figmy.
Przeglądaj paletę kolorów Material Design Google.
Konwertuj między wartościami CMYK (druk) a RGB (ekran).
Przeglądaj domyślną paletę kolorów Tailwind CSS.
Zbuduj robots.txt z grup reguł.
Zbuduj sitemap.xml z wklejonej listy adresów URL.
Zbuduj alternatywne tagi link hreflang dla wersji językowych.
Zbuduj kanoniczny tag link.
Zbuduj dane strukturalne JSON-LD dla popularnych typów.
Zbuduj Info.plist iOS/macOS z typowych kluczy bundle i prywatności.
Buduj przykładowe payloady APNs i FCM.
Zwaliduj google-services.json względem oczekiwanej struktury konfiguracji Firebase.
Zbuduj plik .entitlements (powiązane domeny, grupy aplikacji, push, iCloud itd.).
Wyświetl pliki i rozmiary wewnątrz APK.
Generuj metadane dla App Store i Play Store.
Wygeneruj politykę prywatności aplikacji mobilnej.
Analizuj konkurencyjność słów kluczowych.
Znajdź cenne słowa kluczowe ASO.
Generuj notatki o wydaniu dla sklepów z aplikacjami.
Zarządzaj ciągami tłumaczeń w wielu językach.
Przelicz długość CSS między px, rem, em, pt i %.
Ponownie wcinaj lub minifikuj CSS.
Formatuj i minifikuj kod HTML.
Projektuj i eksportuj gradienty CSS.
Konwertuj między Markdown a HTML.
Projektuj warstwowe box-shadow w CSS.
Generuj tagi meta head, Open Graph i Twitter Card.
Generuj harmonijne palety kolorów.
Generuj wszystkie standardowe rozmiary favicon.
Minifikuj i czyść kod SVG.
Koduj lub dekoduj encje HTML.
Wizualnie zbuduj tabelę HTML.
Generuj CSS glassmorphism.
Generuj CSS neumorfizmu.
Wizualnie buduj kombinacje klas Tailwind.
Projektuj animacje CSS @keyframes.
Porównaj dwie migawki HTML.
Konwertuj plik czcionki między TTF/OTF a WOFF.
Generuj kod kreskowy EAN-13.
Formatuj i upiększaj zapytania SQL.
Buduj zapytania MongoDB wizualnie.
Przetwórz instrukcje INSERT na tablicę JSON.
Konwertuj wiersze CSV na instrukcje INSERT.
Wygeneruj diagram ER ze schematu.
Wizualizuj relacje między tabelami.
Przeanalizuj zapytanie pod kątem potencjalnych problemów z wydajnością.
Porównaj dwie migawki schematu lub zapytań.
Wizualizuj plan EXPLAIN.
Sformatuj czytelnie zapytanie/dokument MongoDB.
Przeszukuj i śledź na żywo wgrane pliki logów.
Dodawaj adnotacje do zrzutów ekranu, aby zgłaszać błędy.
Podsumuj wskaźniki i wzorce błędów w logach.
Formatuj surowe stack trace do czytelnej postaci.