Da formato a JavaScript minificado o compáctalo, con manejo seguro de cadenas, plantillas y regex.
Comprueba si un sitio web está en línea y consulta su alojamiento, detección de WordPress, SSL, DNS, SEO y rendimiento.
Compara la velocidad de ejecución de 2 o más fragmentos de JS, ejecutados en un Web Worker aislado.
Lee el sitemap de cualquier sitio, mira la estructura de sus páginas como árbol y grafo y comprueba títulos, metaetiquetas y códigos de estado.
Crea un Info.plist de iOS/macOS a partir de claves comunes de bundle y privacidad.
Pulsa una tecla para ver en vivo sus valores key, code y keyCode de KeyboardEvent.
Previsualiza una URL con los tamaños de viewport de dispositivos habituales.
Convierte capturas de pantalla en imágenes pulidas con marcos de dispositivo, degradados, sombras y texto.
Crea combinaciones de clases de Tailwind de forma visual.
Da formato y minimiza código HTML.
Genera paletas de colores armoniosas.
Genera metadatos para App Store y Play Store.
Un cronómetro en el navegador con tiempos de vuelta.
Muestra la dirección IP con la que nuestro servidor te ve conectarte.
Consulta la información de registro de un dominio.
Genera un código QR escaneable con preajustes, colores, exportación SVG/PNG y modo por lotes.
Genera contraseñas aleatorias seguras.
Genera contraseñas, claves de API, claves AES, UUID y pares de claves RSA/SSH, todo en el navegador.
Genera UUID v4/v7 en lote.
El clásico texto de relleno para maquetas.
Reindenta o minimiza CSS.
Convierte una longitud CSS entre px, rem, em, pt y %.
Genera CSS de glassmorphism.
Convierte entre Markdown y HTML.
Diseña animaciones CSS con @keyframes.
Genera todos los tamaños de favicon estándar.
Minimiza y limpia código SVG.
Diseña y exporta degradados CSS.
Crea una tabla HTML de forma visual.
Diseña box-shadows CSS en capas.
Compara dos instantáneas de HTML.
Codifica o decodifica entidades HTML.
Genera etiquetas meta del head, Open Graph y Twitter Card.
Convierte un archivo de fuente entre TTF/OTF y WOFF.
Genera CSS de neumorfismo.
Comprueba qué funciones de la plataforma web admite tu navegador.
Muestra en vivo el tamaño de tu pantalla y de tu viewport.
Prueba cada tecla de un teclado nuevo o antiguo: distribución en pantalla, detección de doble pulsación, prueba de rollover, mapa de calor y velocidad de escritura.
Sigue una dirección web a través de cada redirección y ve códigos de estado, bucles y actualizaciones a HTTPS.
Suma una duración a una hora de inicio y consulta la fecha y hora resultantes.
Aritmética binaria y conversor de bases.
Convierte tamaños de datos entre bytes, KB, MB, GB y TB, en decimal o binario.
Expande un bloque CIDR o un rango de direcciones en todas sus direcciones IP.
AND, OR, XOR, NOT y desplazamientos con vista a nivel de bit.
Cálculo de subredes: dirección de red y de broadcast, máscara y rango de hosts.
Convierte entre segundos, HH:MM:SS y duraciones en texto legible.
Cuatro cálculos de porcentaje habituales en un solo lugar.
Convierte IPv4 a su forma entera, hexadecimal e IPv6 mapeada a IPv4.
Convierte formatos de direcciones MAC y obtén la dirección IPv6 link-local y el paquete mágico de Wake-on-LAN.
Decodifica los indicadores de bits de una dirección MAC y busca el fabricante lo mejor posible.
Genera direcciones MAC aleatorias de administración local.
Convierte entre CIDR, máscara de subred y máscara wildcard y genera líneas de ACL de Cisco.
Genera un prefijo de dirección local única (RFC 4193) para numeración IPv6 privada.
Encuentra el titular, el AS de origen, el prefijo anunciado y los vecinos BGP de una IP, prefijo, número de AS o nombre de host.
Convierte entre grados Celsius, Fahrenheit y Kelvin.
Lista con búsqueda de puertos TCP y UDP comunes y los servicios que los usan.
Genera números de puerto TCP/UDP aleatorios para servidores de desarrollo y configuraciones.
Aritmética y operaciones bit a bit en hexadecimal, más un conversor de bases.
Convierte bps, Mbps, etc. y estima el tiempo de descarga.
Calcula la ventana TCP necesaria y el rendimiento real según el ancho de banda, la latencia y la pérdida de paquetes.
Convierte la hora entre zonas horarias con horario de verano y encuentra una hora de reunión para todos.
Resume rutas IPv4 e IPv6 en la lista de prefijos más pequeña o en una única ruta resumen.
Convierte texto a bytes binarios de 8 bits y viceversa.
Convierte texto a códigos de caracteres decimales y viceversa.
Codifica o decodifica texto con porcentaje, en modo componente o URI completa.
Detecta y decodifica automáticamente Base64, hex, codificación URL, gzip y más, capa por capa.
Convierte texto a bytes hexadecimales y viceversa.
Convierte texto a puntos de código Unicode (U+XXXX) y viceversa.
Convierte texto a Base58 (alfabeto de Bitcoin) y viceversa.
Convierte texto a Base32 (RFC 4648) y viceversa.
Convierte cualquier archivo en un data URI Base64, todo en tu navegador.
Convierte Base64 a una cadena de bytes hexadecimales y viceversa.
Convierte una query string de URL en un objeto JSON y viceversa.
Crea etiquetas link alternativas de hreflang para idiomas.
Crea un robots.txt a partir de grupos de reglas.
Crea un sitemap.xml a partir de una lista de URL pegada.
Crea una etiqueta link canónica.
Crea datos estructurados JSON-LD para los tipos más comunes.
Prueba un patrón sobre un texto con resaltado de coincidencias en vivo y grupos de captura.
Reorganiza una lista: recorta, elimina duplicados, ordena, envuelve y une con cualquier separador.
Evalúa una expresión matemática con un analizador real (sin eval): operadores, funciones y constantes.
Quita las líneas vacías o con solo espacios.
Recuento en vivo de caracteres, palabras, líneas y oraciones.
Convierte texto en arte ASCII muestreando una fuente real, no un conjunto fijo de glifos.
Referencia con búsqueda de tokens, cuantificadores y patrones comunes de regex.
Comparación línea a línea de texto plano con resaltado de añadidos y eliminados.
Aleatoriza el orden de las líneas.
Busca y reemplaza texto con regex y opciones de palabra completa.
Normaliza un correo a su forma canónica según el proveedor para eliminar duplicados.
Convierte texto en un slug seguro para URL.
Convierte entre MAYÚSCULAS, minúsculas, Título, camelCase, snake_case, etc.
Texto de relleno aleatorio con palabras comunes en inglés.
Elimina líneas repetidas y conserva la primera aparición.
Abrevia palabras como "i18n": primera letra, número de letras intermedias y última letra.
Deletrea texto con el alfabeto fonético de la OTAN.
Ordena líneas alfabéticamente, de A a Z o de Z a A.
Busca y copia emojis de un conjunto selecto de uso común, agrupados por categoría.
Convierte entre números arábigos y números romanos.
Analiza un número de teléfono y obtiene su prefijo E.164, país y número nacional.
Crea un documento JSON de política IAM de AWS.
Divide un CIDR de VPC en subredes iguales.
Crea un archivo de variables de Terraform.
Activa y desactiva permisos de archivo Unix para construir un comando chmod.
Consulta los códigos de región de AWS, GCP y Azure.
Analiza o construye un ARN de AWS.
Eventos de ejemplo para S3, API Gateway, SNS, SQS y EventBridge.
Gestiona y compara archivos .env.
Reindenta la configuración de Terraform.
Genera un flujo de trabajo de GitHub Actions para Node, Python, PHP, Go, Java, Rust, .NET, Docker o Pages.
Convierte un comando docker run en el bloque de servicio equivalente de docker-compose.yml.
Supervisa la disponibilidad de sitios y servicios.
Analiza y construye URL de S3 (virtual-hosted, path-style, s3://).
Crea un archivo .htaccess de Apache para redirecciones, HTTPS, caché, compresión y seguridad, con reglas de Nginx.
Convierte un archivo .env a JSON o YAML y viceversa.
Convierte entre JSON normal y JSON AttributeValue de DynamoDB.
Prueba qué versiones cumplen un rango de versión semántica al estilo npm.
Genera bloques server de nginx.
Genera un Dockerfile para pilas tecnológicas habituales.
Crea y explica expresiones cron.
Analiza una cadena User-Agent.
Genera un docker-compose.yml.
Genera manifiestos de Kubernetes.
Crea payloads de ejemplo para APNs y FCM.
Valida un google-services.json frente a la estructura de configuración esperada de Firebase.
Crea un archivo .entitlements (dominios asociados, grupos de apps, push, iCloud, etc.).
Genera todos los tamaños de icono de app necesarios.
Genera una política de privacidad para una app móvil.
Gestiona cadenas de traducción en varios idiomas.
Analiza la competitividad de las palabras clave.
Lista los archivos y tamaños dentro de un APK.
Encuentra palabras clave ASO de alto valor.
Genera notas de versión para las tiendas de apps.
Convierte entre RGB y HSV/HSB, el modelo de los selectores de color de Photoshop y Figma.
Relación de contraste WCAG entre texto y fondo, con aprobado o suspenso AA/AAA.
Convierte entre RGB y HSL.
Convierte entre códigos hexadecimales y valores RGB.
Elige un color y consúltalo en HEX, RGB y HSL.
Convierte entre valores de color CMYK (impresión) y RGB (pantalla).
Genera colores hexadecimales aleatorios (pastel, vivos u oscuros).
Explora la paleta de colores predeterminada de Tailwind CSS.
Convierte entre los colores con nombre estándar de CSS y códigos hexadecimales.
Explora la paleta de colores de Material Design de Google.
Codifica o decodifica texto y archivos en Base64.
Calcula o verifica hashes bcrypt con password_hash y password_verify nativos de PHP.
Genera ULID ordenables en Base32 de Crockford, en lote.
Prueba el comportamiento CORS de un endpoint.
Genera un código TOTP (RFC 6238) en vivo a partir de un secreto Base32 o una URI otpauth://.
Genera hashes de la familia MD5/SHA.
Busca un ID de CVE o un producto: gravedad, estado CISA KEV, probabilidad de explotación, productos afectados y referencias.
Muestra la huella SHA256 y MD5, el tipo y el tamaño de una clave pública SSH y compárala con otra.
Genera tokens y claves de API aleatorios y seguros.
Puntúa vulnerabilidades con CVSS 3.1: puntuaciones base, temporal y de entorno y la cadena de vector.
Valida la suma de comprobación mod-97 de un IBAN y lo desglosa en país y BBAN.
Lee la versión y la hora de creación dentro de un UUID y genera UUID v7 ordenables.
Calcula un HMAC a partir de un mensaje y una clave secreta (SHA-1/256/384/512).
Oculta la parte central de una cadena para censurar claves y correos en capturas de pantalla.
Cifra y descifra texto con cifrados comunes.
Crea el atributo integrity y la etiqueta HTML para scripts y hojas de estilo cargados desde un CDN.
Genera una frase semilla BIP39 (12 a 24 palabras) con la entropía y la suma de comprobación correctas.
Crea una Content-Security-Policy y encuentra debilidades en una existente.
Comprueba si una contraseña aparece en filtraciones conocidas sin enviarla.
Extrae IP, dominios, URL, correos, hashes y CVE de un texto, y neutraliza o restaura enlaces.
Puntúa la fortaleza de una contraseña y estima el tiempo para descifrarla, todo en el navegador.
Decodifica un certificado X.509 o CSR: sujeto, emisor, validez, SAN, clave y huellas.
Crea un archivo security.txt según RFC 9116 para que los investigadores sepan cómo informar de vulnerabilidades.
Averigua qué algoritmo generó un hash o calcula la suma de verificación de un archivo con MD5, SHA-1 y SHA-2.
Supervisa las fechas de caducidad de certificados SSL.
Fill in {{variable}} prompt templates and preview the resolved prompt.
Lanza ráfagas de solicitudes a un endpoint para descubrir su límite de tasa real.
Referencia con búsqueda de todos los códigos de estado de respuesta HTTP estándar.
Referencia con búsqueda de extensión de archivo <-> tipo MIME.
Crea y envía solicitudes HTTP, inspecciona respuestas y guarda el historial.
Crea o decodifica una cabecera HTTP Authorization: Basic.
Valida una solicitud de chat completions o la forma de un esquema de función/herramienta.
Convierte comandos curl a fetch, Python, PHP o HTTPie, y viceversa.
Obtiene una URL y explica sus cabeceras de respuesta, con una calificación de seguridad.
Diseña especificaciones de endpoints REST y genera documentación y mocks a partir de ellas.
Recorre un flujo OAuth2 de código de autorización e inspecciona los tokens.
Decodifica e inspecciona el encabezado y el payload de un JWT y verifica firmas.
Ejecuta consultas en cualquier endpoint GraphQL y explora su esquema.
Compara dos respuestas de API y ve las diferencias de forma estructurada.
Estima el número de tokens de un prompt para LLM.
Convierte una especificación OpenAPI/Swagger en una colección de Postman y viceversa.
Obtén una URL de bandeja única e inspecciona en vivo las solicitudes de webhook entrantes.
Supervisa de forma continua la disponibilidad y la latencia de un endpoint mediante cron.
Crea un .gitignore con listas de verificación por lenguaje, editor y sistema operativo.
Referencia con búsqueda de los comandos de git más comunes.
Visualiza y ayuda a resolver conflictos de merge.
Genera un mensaje de commit convencional.
Encuentra ramas obsoletas o ya fusionadas para limpiar.
Crea insignias de shields.io para versión, compilación, licencia y descargas y cópialas como Markdown o HTML.
Genera un registro de cambios a partir del historial de commits.
Genera notas de versión a partir de los PR fusionados.
Valida y da formato a documentos YAML.
Compara las diferencias entre dos documentos JSON.
Valida, formatea y minimiza JSON.
Da formato y valida XML.
Convierte JSON a XML, siguiendo las convenciones de nuestro conversor de XML a JSON.
Convierte entre TOML y JSON/YAML.
Convierte JSON a CSV con aplanado, delimitadores y salida compatible con Excel.
Crea un esquema JSON de forma visual a partir de datos de ejemplo.
Genera JSON de ejemplo realista que sigue un JSON Schema, con semilla repetible.
Genera tipos de TypeScript, Go, Java, C# o Python a partir de JSON de ejemplo.
Convierte documentos XML a JSON.
Reindenta las reglas de seguridad de Firestore.
Valida TOML y previsualízalo como JSON.
Prueba expresiones JSONPath sobre un JSON de ejemplo.
Convierte un archivo .properties de Java a JSON o YAML y viceversa.
Convierte entre CSV y JSON.
Convierte un subconjunto común de YAML a JSON y viceversa.
Convierte CSV en un archivo .xlsx real y viceversa.
Convierte entre timestamps Unix y fechas.
Recupera la URL original de un enlace envuelto por Microsoft Safe Links.
Crea un deep link con esquema URI personalizado.
Crea un enlace sms: multiplataforma con un mensaje predefinido.
Desglosa una URL en protocolo, host, ruta, parámetros de consulta y hash.
Crea un enlace de Google Play Store a partir del nombre de un paquete.
Crea un enlace de la App Store de Apple a partir del ID de una app.
Crea un enlace mailto: con asunto, cuerpo, cc y cco.
Crea un enlace wa.me para iniciar un chat con un clic.
Sigue las redirecciones hasta el destino final.
Crea enlaces cortos de redirección.
Genera direcciones de correo de prueba en dominios reservados por la RFC 2606.
Genera números de teléfono falsos (intercambio 555 de EE. UU., etc.).
Genera nombres, correos y nombres de usuario falsos para pruebas.
Genera números de tarjeta ficticios válidos según Luhn para pruebas en sandbox.
Genera direcciones postales falsas para pruebas.
Reduce una imagen con calidad JPEG/WebP ajustable.
Previsualiza código SVG de forma segura (se muestra como imagen, sin inyectarlo).
Cambia el tamaño de una imagen a dimensiones exactas.
Selecciona arrastrando y recorta una imagen.
Convierte una imagen en un data URI base64 y viceversa.
Convierte un fragmento de código en un PNG con estilo, con temas, marcos de ventana y números de línea.
Convierte una imagen entre formatos.
Rasteriza código SVG a PNG o JPEG con cualquier tamaño.
Genera una imagen de marcador SVG ligera y en línea, sin solicitud de red.
Crea consultas de MongoDB de forma visual.
Convierte filas CSV en sentencias INSERT.
Analiza una consulta en busca de posibles problemas de rendimiento.
Da formato y embellece consultas SQL.
Convierte sentencias INSERT en un array JSON.
Visualiza las relaciones entre tablas.
Compara dos instantáneas de esquema o de consultas.
Genera un diagrama entidad-relación a partir de un esquema.
Visualiza un plan EXPLAIN.
Da formato legible a una consulta o documento de MongoDB.
Da formato legible a stack traces sin procesar.
Resume tasas y patrones de error en los registros.
Analiza y resume informes de fallos.
Anota capturas de pantalla para reportar errores.
Busca y sigue en directo archivos de registro subidos.
Genera un código de barras EAN-13.