בדוק אם אתר מקוון וראה את האחסון, זיהוי וורדפרס, SSL, DNS, SEO וביצועים.
לחצו על מקש כדי לראות בזמן אמת את ערכי key, code ו-keyCode של KeyboardEvent.
השוו את מהירות הריצה של 2 קטעי JS או יותר ב-Web Worker מבודד.
בנו Info.plist ל-iOS/macOS ממפתחות נפוצים של חבילה ופרטיות.
הציגו תצוגה מקדימה של URL בגדלי אזור תצוגה של מכשירים נפוצים.
המירו פקודות curl ל-fetch, Python, PHP או HTTPie ובחזרה.
קודדו באחוזים או פענחו טקסט, במצב רכיב או URI מלא.
שעון עצר בדפדפן עם זמני הקפות.
פענחו תעודת X.509 או CSR: נושא, מנפיק, תוקף, SAN, מפתח וטביעות אצבע.
צרו CSS בסגנון Glassmorphism.
קבלו כתובת תיבת דואר ייחודית ובדקו בקשות webhook נכנסות בזמן אמת.
עצבו וייצאו גרדיאנטים ב-CSS.
מציג את כתובת ה-IP שממנה השרת שלנו רואה אתכם מתחברים.
חפשו פרטי רישום של דומיין.
צרו קוד QR הניתן לסריקה עם הגדרות מוכנות, צבעים, ייצוא SVG/PNG ומצב אצווה.
צרו סיסמאות אקראיות חזקות.
צרו סיסמאות, מפתחות API, מפתחות AES, UUID וזוגות מפתחות RSA/SSH — הכול בצד הלקוח.
צרו UUID מגרסאות v4/v7 בכמות גדולה.
טקסט מילוי קלאסי לדגמים.
בדקו אילו יכולות של פלטפורמת האינטרנט הדפדפן שלכם תומך בהן.
מציג בזמן אמת את גודל המסך ואזור התצוגה.
בדקו כל מקש במקלדת חדשה או ישנה: פריסה על המסך, זיהוי הקשה כפולה, בדיקת Rollover, מפת חום ומהירות הקלדה.
צרו ושלחו בקשות HTTP, בדקו תגובות ושמרו היסטוריה.
מדריך חיפוש להתאמות בין סיומת קובץ <-> סוג MIME.
שלחו התפרצות בקשות לנקודת קצה כדי למצוא את מגבלת הקצב בפועל.
מדריך חיפוש לכל קודי הסטטוס הסטנדרטיים של תגובות HTTP.
Fill in {{variable}} prompt templates and preview the resolved prompt.
בנו או פענחו כותרת HTTP Authorization: Basic.
אמתו בקשת chat completions או את מבנה סכמת הפונקציה/הכלי.
מושך כתובת URL ומסביר את כותרות התגובה שלה, עם ציון אבטחה.
פענחו ובדקו את הכותרת והמטען של JWT ואמתו חתימות.
עברו על זרימת קוד האימות של OAuth2 ובדקו את האסימונים.
תכננו מפרטי נקודות קצה של REST והפיקו מהם תיעוד ודמיות.
העריכו את מספר האסימונים בהנחיית LLM.
הריצו שאילתות מול כל נקודת קצה של GraphQL וסיירו בסכמה שלה.
השוו בין שתי תגובות API וראו את ההבדלים בצורה מובנית.
המירו מפרט OpenAPI/Swagger לאוסף Postman ובחזרה.
נטרו באופן רציף את זמינות נקודת הקצה ואת זמן התגובה שלה באמצעות cron.
המירו טקסט לבתים בינאריים של 8 סיביות ובחזרה.
המירו טקסט לקודי תווים עשרוניים ובחזרה.
המירו טקסט לנקודות קוד של Unicode (U+XXXX) ובחזרה.
המירו טקסט לבתים הקסדצימליים ובחזרה.
המירו טקסט אל/מ-Base58 (האלפבית של ביטקוין).
המירו טקסט אל/מ-Base32 (RFC 4648).
המירו כל קובץ ל-data URI של Base64 בתוך הדפדפן שלכם.
המירו מחרוזת שאילתה של URL לאובייקט JSON ובחזרה.
זהו ופענחו אוטומטית Base64, הקסדצימלי, קידוד URL, gzip ועוד, שכבה אחר שכבה.
המירו Base64 למחרוזת בתים הקסדצימלית ובחזרה.
בדקו תבנית על טקסט עם הדגשה חיה של התאמות וקבוצות לכידה.
חשבו ביטוי מתמטי באמצעות מנתח אמיתי (ללא eval) — אופרטורים, פונקציות וקבועים.
סדרו את השורות בסדר אקראי.
חפשו והחליפו טקסט עם regex ואפשרויות של מילה שלמה.
הסירו שורות ריקות או שורות של רווחים בלבד.
מדריך חיפוש לאסימוני regex, כמתים ותבניות נפוצות.
המירו בין UPPER/lower/Title/camelCase/snake_case ועוד.
עצבו רשימה מחדש: חיתוך רווחים, הסרת כפילויות, מיון, עטיפה וחיבור בכל מפריד.
המירו טקסט ל-slug בטוח לשימוש ב-URL.
השוואת שורות בטקסט רגיל עם הדגשת תוספות והסרות.
נרמלו כתובת אימייל לצורה הקנונית של הספק כדי להסיר כפילויות.
חפשו והעתיקו מתוך מבחר אמוג'י נפוצים, מקובצים לפי קטגוריה.
מיינו שורות לפי סדר אלפביתי, A-Z או Z-A.
ספירה חיה של תווים, מילים, שורות ומשפטים.
קצרו מילים כמו "i18n": האות הראשונה, מספר האותיות שבאמצע והאות האחרונה.
טקסט מילוי אקראי ממילים נפוצות באנגלית.
הפכו טקסט לאמנות ASCII על ידי דגימת גופן אמיתי ולא קבוצת גליפים קבועה.
המירו בין מספרים ערביים לספרות רומיות.
הסירו שורות חוזרות ושמרו את המופע הראשון.
אייתו טקסט באמצעות האלפבית הפונטי של נאט"ו.
פרקו מספר טלפון לקידומת E.164, מדינה ומספר מקומי.
הוסיפו משך זמן לשעת התחלה וראו את התאריך והשעה שיתקבלו.
אריתמטיקה בינארית וממיר בסיסים.
המירו גדלי נתונים בין בתים/KB/MB/GB/TB, בשיטה עשרונית או בינארית.
חישובי רשתות משנה: כתובת רשת ושידור, מסכת רשת, טווח מארחים.
AND/OR/XOR/NOT/הזזה עם תצוגה ברמת הסיבית.
המירו בין שניות, HH:MM:SS ומשכי זמן קריאים.
פענחו את דגלי הסיביות של כתובת MAC וחפשו יצרן בכמיטב היכולת.
הרחיבו בלוק CIDR או טווח כתובות לכל כתובות ה-IP הבודדות.
צרו קידומת כתובת מקומית ייחודית לפי RFC 4193 למספור IPv6 פרטי.
ארבעה חישובי אחוזים נפוצים במקום אחד.
המירו בין צלזיוס, פרנהייט וקלווין.
אריתמטיקה ופעולות סיביות בהקסדצימלי וממיר בסיסים.
צרו כתובות MAC אקראיות בניהול מקומי.
המירו IPv4 לצורת מספר שלם/הקסדצימלי ול-IPv6 ממופה מ-IPv4.
צרו מספרי פורט TCP/UDP אקראיים לשרתי פיתוח ולתצורות.
המירו bps/Mbps ועוד והעריכו זמן הורדה.
עקבו אחרי כתובת אתר דרך כל הפניה וראו קודי מצב, לולאות ושדרוגים ל-HTTPS.
מצאו את הבעלים, ה-AS המקור, הקידומת המוכרזת והשכנים ב-BGP עבור IP, קידומת, מספר AS או שם מארח.
המירו פורמטים של כתובות MAC וקבלו את כתובת ה-IPv6 מקומית-הקישור ואת חבילת הקסם של Wake-on-LAN.
המירו שעה בין אזורי זמן כולל שעון קיץ ומצאו שעת פגישה לכולם.
המירו בין CIDR, מסכת רשת משנה ומסכת wildcard וצרו שורות ACL של Cisco.
חשבו את חלון ה-TCP הדרוש ואת התפוקה בפועל לפי רוחב פס, השהיה ואובדן חבילות.
רשימה הניתנת לחיפוש של יציאות TCP ו-UDP נפוצות והשירותים שמשתמשים בהן.
סכמו נתיבי IPv4 ו-IPv6 לרשימת הקידומות הקטנה ביותר או לנתיב מסכם יחיד.
צרו אסימונים ומפתחות API אקראיים ובטוחים.
קודדו או פענחו טקסט וקבצים ב-Base64.
בדקו את התנהגות ה-CORS של נקודת קצה.
צרו גיבובים ממשפחת MD5/SHA.
צרו ULID ניתנים למיון בקידוד Crockford Base32 בכמות גדולה.
צרו קוד TOTP חי (RFC 6238) מסוד Base32 או מ-URI בפורמט otpauth://.
גבבו או אמתו טקסט באמצעות bcrypt, בעזרת password_hash/password_verify המובנות של PHP.
חשבו HMAC מהודעה ומפתח סודי (SHA-1/256/384/512).
הסתירו את אמצע המחרוזת כדי להסתיר מפתחות/אימיילים בצילומי מסך.
הצפינו ופענחו טקסט בצפנים נפוצים.
אמתו את סכום הביקורת mod-97 של IBAN ופרקו אותו למדינה ו-BBAN.
צרו ביטוי זרע BIP39 (12-24 מילים) עם אנטרופיה וסכום ביקורת תקינים.
דרגו את חוזק הסיסמה והעריכו כמה זמן ייקח לפצח אותה, הכול בצד הלקוח.
חפשו מזהה CVE או מוצר: חומרה, מצב CISA KEV, הסתברות לניצול, מוצרים מושפעים והפניות.
דרגו פגיעויות לפי CVSS 3.1: ציון בסיס, זמני וסביבתי ומחרוזת הווקטור.
בדקו אם סיסמה מופיעה בדליפות ידועות מבלי לשלוח אותה.
בנו Content-Security-Policy ומצאו חולשות במדיניות קיימת.
קראו את הגרסה וזמן היצירה בתוך UUID וצרו ערכי UUID v7 הניתנים למיון.
גלו איזה אלגוריתם יצר גיבוב, או חשבו סכום ביקורת לקובץ עם MD5, SHA-1 ו-SHA-2.
חלצו כתובות IP, דומיינים, URL, דוא״ל, גיבובים ו-CVE מטקסט, ונטרלו או שחזרו קישורים.
הציגו את טביעת האצבע SHA256 ו-MD5, הסוג והגודל של מפתח SSH ציבורי והשוו אותו למפתח אחר.
צרו את מאפיין integrity ואת תג ה-HTML לסקריפטים וגיליונות סגנונות שנטענים מ-CDN.
צרו קובץ security.txt לפי RFC 9116 כדי שחוקרים ידעו איך לדווח על פגיעויות.
נטרו תאריכי תפוגה של אישורי SSL.
בנו מסמך JSON של מדיניות AWS IAM.
חלקו CIDR של VPC לרשתות משנה שוות בגודלן.
בנו קובץ משתנים של Terraform.
החליפו הרשאות קבצים ב-Unix כדי לבנות פקודת chmod.
נתחו או בנו ARN של AWS.
חפשו קודי אזורים של AWS/GCP/Azure.
נתחו/בנו כתובות S3 (virtual-hosted, path-style, s3://).
סדרו מחדש את ההזחה של תצורת Terraform.
המירו קובץ .env ל-JSON או YAML ובחזרה.
המירו פקודת docker run לבלוק שירות מקביל ב-docker-compose.yml.
מטענים לדוגמה לאירועי S3/API Gateway/SNS/SQS/EventBridge.
המירו בין JSON רגיל ל-JSON בפורמט AttributeValue של DynamoDB.
צרו workflow של GitHub Actions עבור Node, Python, PHP, Go, Java, Rust, .NET, Docker או Pages.
בנו קובץ .htaccess של Apache להפניות, HTTPS, מטמון, דחיסה ואבטחה, עם כללי Nginx.
בדקו אילו גרסאות עומדות בטווח גרסאות סמנטי בסגנון npm.
נהלו והשוו קובצי .env.
צרו Dockerfile למחסניות נפוצות.
נתחו מחרוזת User-Agent.
בנו והסבירו ביטויי cron.
צרו קובץ docker-compose.yml.
צרו בלוקי server של nginx.
נטרו את זמינות האתרים והשירותים.
צרו מניפסטים של Kubernetes.
צרו כתובות אימייל לבדיקות בדומיינים השמורים לפי RFC 2606.
צרו שמות, אימיילים ושמות משתמש מדומים לבדיקות.
צרו מספרי טלפון מדומים (מרכזיית 555 האמריקאית ועוד).
צרו מספרי כרטיס פיקטיביים תקינים לפי Luhn לבדיקות בסביבת ארגז חול.
צרו כתובות דואר מדומות לבדיקות.
יחס ניגודיות WCAG בין טקסט לרקע, עם עובר/נכשל ל-AA/AAA.
בחרו צבע וראו אותו כ-HEX/RGB/HSL.
המירו בין קודי צבע הקסדצימליים לערכי RGB.
המירו בין RGB ל-HSV/HSB, המודל שבו משתמשים בוררי הצבעים של Photoshop ו-Figma.
המירו בין RGB ל-HSL.
צרו צבעים הקסדצימליים אקראיים (פסטל/חיוניים/כהים).
המירו בין ערכי צבע CMYK (הדפסה) ל-RGB (מסך).
עיינו בפלטת הצבעים המובנית של Tailwind CSS.
המירו בין שמות צבעים סטנדרטיים ב-CSS לקודים הקסדצימליים.
עיינו בפלטת הצבעים של Material Design מבית Google.
סמנו בגרירה וחתכו תמונה.
שנו גודל של תמונה למידות מדויקות.
הקטינו תמונה בעזרת איכות JPEG/WebP מתכווננת.
הציגו קוד SVG בבטחה (מוצג כתמונה ולא מוזרק לדף).
המירו תמונה ל-data URI של base64 ובחזרה.
המירו תמונה בין פורמטים.
הפכו קוד SVG ל-PNG או JPEG בכל גודל.
צרו תמונה זמנית קלת משקל בפורמט SVG מוטבע ללא בקשת רשת.
הפכו צילומי מסך לתמונות מלוטשות עם מסגרות מכשיר, גרדיאנטים, צללים וטקסט.
הפכו קטע קוד ל-PNG מעוצב עם ערכות נושא, מסגרות חלון ומספרי שורות.
המירו בין TOML ל-JSON/YAML.
השוו בין שני מסמכי JSON.
עצבו ואמתו XML.
אמתו ועצבו מסמכי YAML.
אמתו, עצבו וצמצמו JSON.
המירו JSON ל-XML לפי המוסכמות של ממיר ה-XML ל-JSON שלנו.
צרו JSON לדוגמה ריאליסטי שעומד ב-JSON Schema, עם seed שניתן לחזור עליו.
המירו JSON ל-CSV עם שיטוח, מפרידים ופלט ידידותי ל-Excel.
צרו טיפוסי TypeScript, Go, Java, C# או Python מ-JSON לדוגמה.
בנו סכמת JSON באופן חזותי מנתוני דוגמה.
המירו מסמכי XML ל-JSON.
אמתו TOML והציגו אותו כ-JSON.
בדקו ביטויי JSONPath על JSON לדוגמה.
המירו בין CSV ל-JSON.
המירו תת-קבוצה נפוצה של YAML ל-JSON ובחזרה.
המירו קובץ Java .properties ל-JSON או YAML ובחזרה.
סדרו מחדש את ההזחה של כללי האבטחה של Firestore.
המירו CSV לקובץ .xlsx אמיתי ובחזרה.
בנו קובץ .gitignore מרשימות סימון לפי שפה, עורך ומערכת הפעלה.
מדריך חיפוש לפקודות git נפוצות.
צרו הודעת commit בפורמט Conventional Commits.
הציגו קונפליקטים במיזוג וסייעו בפתרונם.
מצאו ענפים ישנים או ממוזגים לניקוי.
צרו תגי shields.io לגרסה, בנייה, רישיון והורדות והעתיקו אותם כ-Markdown או HTML.
צרו יומן שינויים מהיסטוריית commit.
צרו הערות גרסה מ-PR שמוזגו.
המירו בין חותמות זמן של Unix לתאריכים.
שחזרו את כתובת ה-URL המקורית מקישור שעטף Microsoft Safe Links.
פרקו כתובת URL לפרוטוקול, מארח, נתיב, פרמטרי שאילתה ו-hash.
בנו קישור sms: חוצה פלטפורמות עם הודעה שמולאה מראש.
בנו קישור עמוק עם סכמת URI מותאמת.
בנו קישור ל-Google Play Store משם חבילה.
בנו קישור mailto: עם נושא, גוף, העתק והעתק מוסתר.
בנו קישור ל-Apple App Store ממזהה אפליקציה.
בנו קישור wa.me לפתיחת צ'אט בלחיצה אחת.
עקבו אחר הפניות עד היעד הסופי.
צרו קישורי הפניה קצרים.
המירו אורך CSS בין px, rem, em, pt ו-%.
סדרו מחדש את ההזחה של CSS או צמצמו אותו.
עצבו JavaScript מכווץ או כווצו אותו, עם טיפול בטוח במחרוזות, תבניות וביטויים רגולריים.
צרו את כל גדלי ה-favicon הסטנדרטיים.
בנו טבלת HTML באופן חזותי.
צרו תגי meta, Open Graph ו-Twitter Card לראש הדף.
צמצמו ונקו קוד SVG.
עצבו box-shadow רב-שכבתי ב-CSS.
השוו בין שני צילומי מצב של HTML.
קודדו או פענחו ישויות HTML.
צרו פלטות צבעים הרמוניות.
עצבו אנימציות CSS עם @keyframes.
המירו בין Markdown ל-HTML.
צרו CSS בסגנון Neumorphism.
המירו קובץ גופן בין TTF/OTF ל-WOFF.
בנו שילובי מחלקות Tailwind באופן חזותי.
עצבו וצמצמו קוד HTML.
בנו תגי link חלופיים של hreflang לגרסאות שפה.
בנו sitemap.xml מרשימת כתובות URL שהדבקתם.
קראו את מפת האתר של כל אתר, ראו את מבנה הדפים כעץ וכגרף ובדקו כותרות, תגי מטא וקודי מצב.
בנו קובץ robots.txt מקבוצות כללים.
בנו נתונים מובנים בפורמט JSON-LD לסוגים נפוצים.
בנו תג link קנוני.
בנו מטענים לדוגמה להתראות APNs ו-FCM.
אמתו קובץ google-services.json מול מבנה התצורה הצפוי של Firebase.
בנו קובץ .entitlements (דומיינים משויכים, קבוצות אפליקציות, דחיפה, iCloud ועוד).
צרו את כל גדלי סמל האפליקציה הנדרשים.
נתחו את רמת התחרותיות של מילות מפתח.
מצאו מילות מפתח ל-ASO בעלות ערך גבוה.
צרו מדיניות פרטיות לאפליקציה לנייד.
נהלו מחרוזות תרגום בין שפות.
הציגו רשימת קבצים וגדלים בתוך APK.
צרו מטא-נתונים עבור App Store/Play Store.
צרו הערות גרסה לחנויות האפליקציות.
צרו ברקוד EAN-13.
המירו שורות CSV להצהרות INSERT.
עצבו ויפו שאילתות SQL.
נתחו שאילתה לאיתור בעיות ביצועים אפשריות.
בנו שאילתות MongoDB באופן חזותי.
צרו דיאגרמת ER מסכמה.
הציגו חזותית את הקשרים בין טבלאות.
נתחו הצהרות INSERT למערך JSON.
עצבו שאילתה/מסמך של MongoDB בצורה קריאה.
השוו בין שני צילומי מצב של סכמה או שאילתות.
הציגו חזותית תוכנית EXPLAIN.
סכמו שיעורי שגיאות ודפוסים ביומנים.
חפשו ועקבו בזמן אמת אחרי קובצי יומן שהועלו.
עצבו Stack Trace גולמיים לצורה קריאה.
נתחו וסכמו דוחות קריסה.
הוסיפו הערות לצילומי מסך כדי לדווח על באגים.