Test di API, utilità JSON/DB/Git, generatori cloud, strumenti IA per sviluppatori e altro: gratis, senza registrazione per le funzioni di base.
Premi un tasto per vedere in tempo reale i valori key, code e keyCode di KeyboardEvent.
Converti comandi curl in fetch, Python, PHP o HTTPie, e viceversa.
Verifica quali funzionalità della piattaforma web supporta il tuo browser.
Confronta la velocità di esecuzione di 2 o più snippet JS in un Web Worker isolato.
Crea e invia richieste HTTP, ispeziona le risposte e salva la cronologia.
Aritmetica binaria e convertitore di basi.
Crea o decodifica un'intestazione HTTP Authorization: Basic.
Visualizza l'anteprima di un URL alle dimensioni di viewport dei dispositivi comuni.
Converti testo in codici carattere decimali e viceversa.
Crea un .gitignore da liste di controllo per linguaggio, editor e sistema operativo.
Minimizza e ripulisci il codice SVG.
Percorri un flusso OAuth2 con codice di autorizzazione e ispeziona i token.
Progetta box-shadow CSS a più livelli.
Sfoglia la palette di colori predefinita di Tailwind CSS.
Progetta ed esporta gradienti CSS.
Un cronometro nel browser con tempi parziali.
Mostra l'indirizzo IP con cui il nostro server vede la tua connessione.
Consulta le informazioni di registrazione di un dominio.
Genera un codice QR scansionabile con preset, colori, esportazione SVG/PNG e modalità batch.
Genera password casuali sicure.
Genera password, chiavi API, chiavi AES, UUID e coppie di chiavi RSA/SSH, tutto nel browser.
Genera UUID v4/v7 in blocco.
Il classico testo segnaposto per mockup.
Elimina le righe vuote o composte solo da spazi.
Conteggio in tempo reale di caratteri, parole, righe e frasi.
Riferimento ricercabile di tutti i codici di stato di risposta HTTP standard.
Invia raffiche di richieste a un endpoint per scoprire il suo limite di frequenza effettivo.
Riferimento ricercabile estensione file <-> tipo MIME.
Fill in {{variable}} prompt templates and preview the resolved prompt.
Recupera un URL e spiega le intestazioni di risposta, con un voto di sicurezza.
Convalida una richiesta chat completions o la forma di uno schema di funzione/strumento.
Decodifica e ispeziona intestazione e payload di un JWT e verifica le firme.
Esegui query su qualsiasi endpoint GraphQL ed esplora il suo schema.
Ottieni un URL di casella univoco e ispeziona in tempo reale le richieste webhook in arrivo.
Converti una specifica OpenAPI/Swagger in una collezione Postman e viceversa.
Stima il numero di token di un prompt per LLM.
Progetta specifiche di endpoint REST e genera documentazione e mock a partire da esse.
Confronta due risposte API e vedi le differenze in modo strutturato.
Monitora in modo continuo disponibilità e latenza di un endpoint tramite cron.
Mostra in tempo reale le dimensioni di schermo e viewport.
Codifica o decodifica testo in percent-encoding, in modalità componente o URI completo.
Converti testo in code point Unicode (U+XXXX) e viceversa.
Converti testo da/verso Base58 (alfabeto Bitcoin).
Converti testo in byte esadecimali e viceversa.
Converti testo in byte binari a 8 bit e viceversa.
Converti testo da/verso Base32 (RFC 4648).
Converti qualsiasi file in un data URI Base64, interamente nel browser.
Converti Base64 in una stringa di byte esadecimali e viceversa.
Converti una query string URL in un oggetto JSON e viceversa.
Attiva o disattiva i permessi dei file Unix per creare un comando chmod.
Crea un documento JSON di policy IAM AWS.
Analizza o costruisci un ARN AWS.
Suddividi un CIDR VPC in subnet di uguale dimensione.
Crea un file di variabili Terraform.
Analizza e costruisci URL S3 (virtual-hosted, path-style, s3://).
Converti un file .env in JSON o YAML e viceversa.
Eventi di esempio per S3, API Gateway, SNS, SQS ed EventBridge.
Re-indenta la configurazione Terraform.
Cerca i codici regione di AWS, GCP e Azure.
Converti un comando docker run in un blocco di servizio docker-compose.yml equivalente.
Converti tra JSON semplice e JSON AttributeValue di DynamoDB.
Crea e spiega espressioni cron.
Genera un docker-compose.yml.
Analizza una stringa User-Agent.
Genera un Dockerfile per stack comuni.
Genera manifest Kubernetes.
Genera blocchi server di nginx.
Monitora la disponibilità di siti e servizi.
Gestisci e confronta file .env.
Testa un pattern su un testo con evidenziazione dei match in tempo reale e gruppi di cattura.
Ordina le righe alfabeticamente, A-Z o Z-A.
Rendi casuale l'ordine delle righe.
Valuta un'espressione matematica con un vero parser (senza eval): operatori, funzioni, costanti.
Converti tra MAIUSCOLO, minuscolo, Titolo, camelCase, snake_case, ecc.
Confronto riga per riga di testo semplice con evidenziazione di aggiunte e rimozioni.
Riferimento ricercabile di token, quantificatori e pattern regex comuni.
Trova e sostituisci testo con opzioni regex e parola intera.
Normalizza un'e-mail nella forma canonica del provider per rimuovere i duplicati.
Converti il testo in uno slug sicuro per gli URL.
Cerca e copia da una selezione di emoji comuni, raggruppate per categoria.
Rimodella una lista: elimina spazi, rimuovi duplicati, ordina, racchiudi e unisci con qualsiasi separatore.
Converti tra numeri arabi e numeri romani.
Abbrevia parole come "i18n": prima lettera, numero di lettere intermedie, ultima lettera.
Testo di riempimento casuale con parole inglesi comuni.
Rimuovi le righe ripetute, mantenendo la prima occorrenza.
Compita il testo con l'alfabeto fonetico NATO.
Scomponi un numero di telefono in prefisso E.164, paese e numero nazionale.
Trasforma il testo in ASCII art campionando un vero font, non un set fisso di glifi.
Genera token e chiavi API casuali e sicuri.
Calcola un HMAC da un messaggio e una chiave segreta (SHA-1/256/384/512).
Codifica o decodifica testo e file in Base64.
Genera in tempo reale un codice TOTP (RFC 6238) da un segreto Base32 o da un URI otpauth://.
Genera hash della famiglia MD5/SHA.
Testa il comportamento CORS di un endpoint.
Genera ULID ordinabili codificati in Base32 di Crockford, in blocco.
Calcola o verifica hash con bcrypt, usando password_hash/password_verify nativi di PHP.
Cifra e decifra testo con cifrari comuni.
Maschera il centro di una stringa per oscurare chiavi ed e-mail negli screenshot.
Valuta la robustezza di una password e stima il tempo per violarla, tutto nel browser.
Convalida il checksum mod-97 di un IBAN e scomponilo in paese e BBAN.
Genera una frase seed BIP39 (12-24 parole) con entropia e checksum corretti.
Monitora le date di scadenza dei certificati SSL.
Calcolo delle subnet: indirizzo di rete e broadcast, netmask, intervallo di host.
Converti dimensioni dati tra byte, KB, MB, GB e TB, in decimale o binario.
Decodifica i flag di bit di un indirizzo MAC più una ricerca del produttore al meglio.
Quattro calcoli percentuali comuni in un unico posto.
Converti tra Celsius, Fahrenheit e Kelvin.
Converti tra secondi, HH:MM:SS e durate in formato leggibile.
Aggiungi una durata a un orario di inizio e vedi data e ora risultanti.
AND, OR, XOR, NOT e shift con vista a livello di bit.
Espandi un blocco CIDR o un intervallo di indirizzi in tutti i singoli indirizzi IP.
Genera un prefisso di indirizzo locale univoco RFC 4193 per la numerazione IPv6 privata.
Aritmetica e operazioni bit a bit in esadecimale, più un convertitore di basi.
Genera numeri di porta TCP/UDP casuali per server di sviluppo e configurazioni.
Controlla se un sito web è online e consulta hosting, rilevamento di WordPress, SSL, DNS, SEO e prestazioni.
Converti bps, Mbps, ecc. e stima il tempo di download.
Converti un IPv4 in forma intera, esadecimale e IPv6 mappato su IPv4.
Genera indirizzi MAC casuali ad amministrazione locale.
Riferimento ricercabile dei comandi git più comuni.
Visualizza e aiuta a risolvere i conflitti di merge.
Genera un messaggio di commit convenzionale.
Trova branch obsoleti o già uniti da eliminare.
Genera un changelog dalla cronologia dei commit.
Genera note di rilascio dalle PR unite.
Genera nomi, e-mail e nomi utente finti per i test.
Genera indirizzi e-mail di prova su domini riservati dalla RFC 2606.
Genera numeri di telefono finti (prefisso USA 555, ecc.).
Genera numeri di carta fittizi validi secondo Luhn per test in sandbox.
Genera indirizzi postali finti per i test.
Scegli un colore e vedilo in HEX, RGB e HSL.
Rapporto di contrasto WCAG tra testo e sfondo, con esito AA/AAA.
Genera colori esadecimali casuali (pastello, vivaci, scuri).
Converti tra i nomi di colore standard CSS e i codici esadecimali.
Sfoglia la palette di colori Material Design di Google.
Converti tra CMYK (stampa) e RGB (schermo).
Converti tra codici esadecimali e valori RGB.
Converti tra RGB e HSL.
Converti tra RGB e HSV/HSB, il modello dei selettori colore di Photoshop e Figma.
Converti tra TOML e JSON/YAML.
Formatta e convalida XML.
Confronta due documenti JSON.
Convalida e formatta documenti YAML.
Convalida, formatta e minimizza JSON.
Converti JSON in XML, seguendo le convenzioni del nostro convertitore XML in JSON.
Converti tra CSV e JSON.
Converti un sottoinsieme comune di YAML in JSON e viceversa.
Converti documenti XML in JSON.
Testa espressioni JSONPath su un JSON di esempio.
Crea visivamente un JSON Schema da dati di esempio.
Converti un file .properties di Java in JSON o YAML e viceversa.
Convalida TOML e visualizzalo come JSON.
Converti CSV in un vero file .xlsx e viceversa.
Re-indenta le regole di sicurezza di Firestore.
Ridimensiona un'immagine alle dimensioni esatte.
Riduci un'immagine con qualità JPEG/WebP regolabile.
Seleziona trascinando e ritaglia un'immagine.
Visualizza in sicurezza il codice SVG (mostrato come immagine, non inserito).
Converti un'immagine tra formati.
Converti un'immagine in un data URI base64 e viceversa.
Rasterizza il codice SVG in PNG o JPEG a qualsiasi dimensione.
Genera un'immagine segnaposto SVG inline leggera, senza richieste di rete.
Trasforma gli screenshot in immagini curate con cornici di dispositivo, gradienti, ombre e testo.
Converti tra timestamp Unix e date.
Scomponi un URL in protocollo, host, percorso, parametri di query e hash.
Crea un link sms: multipiattaforma con messaggio precompilato.
Crea un deep link con schema URI personalizzato.
Crea un link Google Play Store da un nome pacchetto.
Recupera l'URL originale da un link avvolto da Microsoft Safe Links.
Crea un link Apple App Store da un ID app.
Crea un link wa.me per avviare una chat con un clic.
Crea un link mailto: con oggetto, corpo, CC e CCN.
Crea link brevi di reindirizzamento.
Segui i reindirizzamenti fino alla destinazione finale.
Crea un robots.txt da gruppi di regole.
Crea una sitemap.xml da un elenco di URL incollato.
Crea tag link alternativi hreflang per le varianti linguistiche.
Crea un tag link canonico.
Crea dati strutturati JSON-LD per i tipi più comuni.
Crea un Info.plist iOS/macOS da chiavi comuni di bundle e privacy.
Crea payload di esempio per APNs e FCM.
Crea un file .entitlements (domini associati, app group, push, iCloud, ecc.).
Convalida un google-services.json rispetto alla struttura di configurazione Firebase attesa.
Elenca file e dimensioni all'interno di un APK.
Genera metadati per App Store e Play Store.
Genera tutte le dimensioni di icona app richieste.
Genera un'informativa sulla privacy per un'app mobile.
Analizza la competitività delle parole chiave.
Trova parole chiave ASO di alto valore.
Genera note di rilascio per gli app store.
Gestisci le stringhe di traduzione tra più lingue.
Converti una lunghezza CSS tra px, rem, em, pt e %.
Re-indenta o minimizza il CSS.
Formatta e minimizza markup HTML.
Converti tra Markdown e HTML.
Genera meta tag head, Open Graph e Twitter Card.
Genera palette di colori armoniose.
Genera tutte le dimensioni standard di favicon.
Codifica o decodifica entità HTML.
Crea visivamente una tabella HTML.
Genera CSS glassmorphism.
Genera CSS neumorphism.
Crea visualmente combinazioni di classi Tailwind.
Progetta animazioni CSS @keyframes.
Confronta due snapshot HTML.
Converti un file di font tra TTF/OTF e WOFF.
Genera un codice a barre EAN-13.
Formatta e abbellisci query SQL.
Crea query MongoDB in modo visuale.
Trasforma istruzioni INSERT in un array JSON.
Converti righe CSV in istruzioni INSERT.
Genera un diagramma ER da uno schema.
Visualizza le relazioni tra le tabelle.
Analizza una query alla ricerca di potenziali problemi di prestazioni.
Confronta due snapshot di schema o di query.
Visualizza un piano EXPLAIN.
Formatta in modo leggibile una query o un documento MongoDB.
Cerca e segui in tempo reale i file di log caricati.
Annota screenshot per segnalare bug.
Riassumi tassi e pattern di errore nei log.
Formatta in modo leggibile stack trace grezzi.
Analizza e riassumi i report di crash.