בדיקות API, כלי JSON/מסדי נתונים/Git, מחוללי ענן, כלי בינה מלאכותית למפתחים ועוד — בחינם, ובלי הרשמה לשימוש בסיסי.
לחצו על מקש כדי לראות בזמן אמת את ערכי key, code ו-keyCode של KeyboardEvent.
המירו פקודות curl ל-fetch, Python, PHP או HTTPie ובחזרה.
בדקו אילו יכולות של פלטפורמת האינטרנט הדפדפן שלכם תומך בהן.
צרו ושלחו בקשות HTTP, בדקו תגובות ושמרו היסטוריה.
מדריך חיפוש לכל קודי הסטטוס הסטנדרטיים של תגובות HTTP.
בנו או פענחו כותרת HTTP Authorization: Basic.
השוו את מהירות הריצה של 2 קטעי JS או יותר ב-Web Worker מבודד.
בנו קובץ משתנים של Terraform.
קודדו באחוזים או פענחו טקסט, במצב רכיב או URI מלא.
חלקו CIDR של VPC לרשתות משנה שוות בגודלן.
צמצמו ונקו קוד SVG.
עברו על זרימת קוד האימות של OAuth2 ובדקו את האסימונים.
עצבו box-shadow רב-שכבתי ב-CSS.
עצבו וייצאו גרדיאנטים ב-CSS.
בנו סכמת JSON באופן חזותי מנתוני דוגמה.
צרו מדיניות פרטיות לאפליקציה לנייד.
שעון עצר בדפדפן עם זמני הקפות.
מציג את כתובת ה-IP שממנה השרת שלנו רואה אתכם מתחברים.
חפשו פרטי רישום של דומיין.
צרו קוד QR הניתן לסריקה עם הגדרות מוכנות, צבעים, ייצוא SVG/PNG ומצב אצווה.
צרו סיסמאות אקראיות חזקות.
צרו סיסמאות, מפתחות API, מפתחות AES, UUID וזוגות מפתחות RSA/SSH — הכול בצד הלקוח.
צרו UUID מגרסאות v4/v7 בכמות גדולה.
טקסט מילוי קלאסי לדגמים.
הסירו שורות ריקות או שורות של רווחים בלבד.
ספירה חיה של תווים, מילים, שורות ומשפטים.
מדריך חיפוש להתאמות בין סיומת קובץ <-> סוג MIME.
מושך כתובת URL ומסביר את כותרות התגובה שלה, עם ציון אבטחה.
שלחו התפרצות בקשות לנקודת קצה כדי למצוא את מגבלת הקצב בפועל.
Fill in {{variable}} prompt templates and preview the resolved prompt.
אמתו בקשת chat completions או את מבנה סכמת הפונקציה/הכלי.
פענחו ובדקו את הכותרת והמטען של JWT ואמתו חתימות.
הריצו שאילתות מול כל נקודת קצה של GraphQL וסיירו בסכמה שלה.
קבלו כתובת תיבת דואר ייחודית ובדקו בקשות webhook נכנסות בזמן אמת.
המירו מפרט OpenAPI/Swagger לאוסף Postman ובחזרה.
העריכו את מספר האסימונים בהנחיית LLM.
תכננו מפרטי נקודות קצה של REST והפיקו מהם תיעוד ודמיות.
השוו בין שתי תגובות API וראו את ההבדלים בצורה מובנית.
נטרו באופן רציף את זמינות נקודת הקצה ואת זמן התגובה שלה באמצעות cron.
הציגו תצוגה מקדימה של URL בגדלי אזור תצוגה של מכשירים נפוצים.
מציג בזמן אמת את גודל המסך ואזור התצוגה.
צרו אסימונים ומפתחות API אקראיים ובטוחים.
חשבו HMAC מהודעה ומפתח סודי (SHA-1/256/384/512).
קודדו או פענחו טקסט וקבצים ב-Base64.
צרו קוד TOTP חי (RFC 6238) מסוד Base32 או מ-URI בפורמט otpauth://.
צרו גיבובים ממשפחת MD5/SHA.
בדקו את התנהגות ה-CORS של נקודת קצה.
צרו ULID ניתנים למיון בקידוד Crockford Base32 בכמות גדולה.
גבבו או אמתו טקסט באמצעות bcrypt, בעזרת password_hash/password_verify המובנות של PHP.
הצפינו ופענחו טקסט בצפנים נפוצים.
הסתירו את אמצע המחרוזת כדי להסתיר מפתחות/אימיילים בצילומי מסך.
דרגו את חוזק הסיסמה והעריכו כמה זמן ייקח לפצח אותה, הכול בצד הלקוח.
אמתו את סכום הביקורת mod-97 של IBAN ופרקו אותו למדינה ו-BBAN.
צרו ביטוי זרע BIP39 (12-24 מילים) עם אנטרופיה וסכום ביקורת תקינים.
נטרו תאריכי תפוגה של אישורי SSL.
בדקו תבנית על טקסט עם הדגשה חיה של התאמות וקבוצות לכידה.
מיינו שורות לפי סדר אלפביתי, A-Z או Z-A.
חשבו ביטוי מתמטי באמצעות מנתח אמיתי (ללא eval) — אופרטורים, פונקציות וקבועים.
סדרו את השורות בסדר אקראי.
השוואת שורות בטקסט רגיל עם הדגשת תוספות והסרות.
מדריך חיפוש לאסימוני regex, כמתים ותבניות נפוצות.
המירו בין UPPER/lower/Title/camelCase/snake_case ועוד.
חפשו והחליפו טקסט עם regex ואפשרויות של מילה שלמה.
המירו טקסט ל-slug בטוח לשימוש ב-URL.
נרמלו כתובת אימייל לצורה הקנונית של הספק כדי להסיר כפילויות.
חפשו והעתיקו מתוך מבחר אמוג'י נפוצים, מקובצים לפי קטגוריה.
עצבו רשימה מחדש: חיתוך רווחים, הסרת כפילויות, מיון, עטיפה וחיבור בכל מפריד.
המירו בין מספרים ערביים לספרות רומיות.
קצרו מילים כמו "i18n": האות הראשונה, מספר האותיות שבאמצע והאות האחרונה.
טקסט מילוי אקראי ממילים נפוצות באנגלית.
הסירו שורות חוזרות ושמרו את המופע הראשון.
אייתו טקסט באמצעות האלפבית הפונטי של נאט"ו.
הפכו טקסט לאמנות ASCII על ידי דגימת גופן אמיתי ולא קבוצת גליפים קבועה.
פרקו מספר טלפון לקידומת E.164, מדינה ומספר מקומי.
המירו טקסט לקודי תווים עשרוניים ובחזרה.
המירו טקסט לנקודות קוד של Unicode (U+XXXX) ובחזרה.
המירו טקסט לבתים הקסדצימליים ובחזרה.
המירו טקסט לבתים בינאריים של 8 סיביות ובחזרה.
המירו טקסט אל/מ-Base32 (RFC 4648).
המירו טקסט אל/מ-Base58 (האלפבית של ביטקוין).
המירו כל קובץ ל-data URI של Base64 בתוך הדפדפן שלכם.
המירו Base64 למחרוזת בתים הקסדצימלית ובחזרה.
המירו מחרוזת שאילתה של URL לאובייקט JSON ובחזרה.
החליפו הרשאות קבצים ב-Unix כדי לבנות פקודת chmod.
בנו מסמך JSON של מדיניות AWS IAM.
נתחו או בנו ARN של AWS.
נתחו/בנו כתובות S3 (virtual-hosted, path-style, s3://).
המירו קובץ .env ל-JSON או YAML ובחזרה.
סדרו מחדש את ההזחה של תצורת Terraform.
חפשו קודי אזורים של AWS/GCP/Azure.
מטענים לדוגמה לאירועי S3/API Gateway/SNS/SQS/EventBridge.
המירו פקודת docker run לבלוק שירות מקביל ב-docker-compose.yml.
המירו בין JSON רגיל ל-JSON בפורמט AttributeValue של DynamoDB.
בנו והסבירו ביטויי cron.
צרו קובץ docker-compose.yml.
נתחו מחרוזת User-Agent.
צרו Dockerfile למחסניות נפוצות.
צרו מניפסטים של Kubernetes.
צרו בלוקי server של nginx.
נטרו את זמינות האתרים והשירותים.
נהלו והשוו קובצי .env.
חישובי רשתות משנה: כתובת רשת ושידור, מסכת רשת, טווח מארחים.
אריתמטיקה בינארית וממיר בסיסים.
המירו גדלי נתונים בין בתים/KB/MB/GB/TB, בשיטה עשרונית או בינארית.
פענחו את דגלי הסיביות של כתובת MAC וחפשו יצרן בכמיטב היכולת.
ארבעה חישובי אחוזים נפוצים במקום אחד.
המירו בין שניות, HH:MM:SS ומשכי זמן קריאים.
הוסיפו משך זמן לשעת התחלה וראו את התאריך והשעה שיתקבלו.
המירו בין צלזיוס, פרנהייט וקלווין.
AND/OR/XOR/NOT/הזזה עם תצוגה ברמת הסיבית.
הרחיבו בלוק CIDR או טווח כתובות לכל כתובות ה-IP הבודדות.
אריתמטיקה ופעולות סיביות בהקסדצימלי וממיר בסיסים.
צרו קידומת כתובת מקומית ייחודית לפי RFC 4193 למספור IPv6 פרטי.
צרו מספרי פורט TCP/UDP אקראיים לשרתי פיתוח ולתצורות.
המירו bps/Mbps ועוד והעריכו זמן הורדה.
בדוק אם אתר מקוון וראה את האחסון, זיהוי וורדפרס, SSL, DNS, SEO וביצועים.
צרו כתובות MAC אקראיות בניהול מקומי.
המירו IPv4 לצורת מספר שלם/הקסדצימלי ול-IPv6 ממופה מ-IPv4.
המירו בין TOML ל-JSON/YAML.
עצבו ואמתו XML.
השוו בין שני מסמכי JSON.
אמתו ועצבו מסמכי YAML.
אמתו, עצבו וצמצמו JSON.
המירו JSON ל-XML לפי המוסכמות של ממיר ה-XML ל-JSON שלנו.
המירו בין CSV ל-JSON.
המירו תת-קבוצה נפוצה של YAML ל-JSON ובחזרה.
המירו מסמכי XML ל-JSON.
בדקו ביטויי JSONPath על JSON לדוגמה.
המירו קובץ Java .properties ל-JSON או YAML ובחזרה.
אמתו TOML והציגו אותו כ-JSON.
המירו CSV לקובץ .xlsx אמיתי ובחזרה.
סדרו מחדש את ההזחה של כללי האבטחה של Firestore.
בנו קובץ .gitignore מרשימות סימון לפי שפה, עורך ומערכת הפעלה.
הציגו קונפליקטים במיזוג וסייעו בפתרונם.
מדריך חיפוש לפקודות git נפוצות.
מצאו ענפים ישנים או ממוזגים לניקוי.
צרו הודעת commit בפורמט Conventional Commits.
צרו יומן שינויים מהיסטוריית commit.
צרו הערות גרסה מ-PR שמוזגו.
שנו גודל של תמונה למידות מדויקות.
הקטינו תמונה בעזרת איכות JPEG/WebP מתכווננת.
סמנו בגרירה וחתכו תמונה.
הציגו קוד SVG בבטחה (מוצג כתמונה ולא מוזרק לדף).
המירו תמונה בין פורמטים.
המירו תמונה ל-data URI של base64 ובחזרה.
הפכו קוד SVG ל-PNG או JPEG בכל גודל.
צרו תמונה זמנית קלת משקל בפורמט SVG מוטבע ללא בקשת רשת.
הפכו צילומי מסך לתמונות מלוטשות עם מסגרות מכשיר, גרדיאנטים, צללים וטקסט.
צרו שמות, אימיילים ושמות משתמש מדומים לבדיקות.
צרו כתובות אימייל לבדיקות בדומיינים השמורים לפי RFC 2606.
צרו מספרי טלפון מדומים (מרכזיית 555 האמריקאית ועוד).
צרו מספרי כרטיס פיקטיביים תקינים לפי Luhn לבדיקות בסביבת ארגז חול.
צרו כתובות דואר מדומות לבדיקות.
המירו בין חותמות זמן של Unix לתאריכים.
פרקו כתובת URL לפרוטוקול, מארח, נתיב, פרמטרי שאילתה ו-hash.
בנו קישור עמוק עם סכמת URI מותאמת.
בנו קישור sms: חוצה פלטפורמות עם הודעה שמולאה מראש.
בנו קישור ל-Google Play Store משם חבילה.
שחזרו את כתובת ה-URL המקורית מקישור שעטף Microsoft Safe Links.
בנו קישור ל-Apple App Store ממזהה אפליקציה.
בנו קישור wa.me לפתיחת צ'אט בלחיצה אחת.
בנו קישור mailto: עם נושא, גוף, העתק והעתק מוסתר.
צרו קישורי הפניה קצרים.
עקבו אחר הפניות עד היעד הסופי.
בחרו צבע וראו אותו כ-HEX/RGB/HSL.
יחס ניגודיות WCAG בין טקסט לרקע, עם עובר/נכשל ל-AA/AAA.
צרו צבעים הקסדצימליים אקראיים (פסטל/חיוניים/כהים).
המירו בין שמות צבעים סטנדרטיים ב-CSS לקודים הקסדצימליים.
המירו בין קודי צבע הקסדצימליים לערכי RGB.
עיינו בפלטת הצבעים של Material Design מבית Google.
המירו בין ערכי צבע CMYK (הדפסה) ל-RGB (מסך).
המירו בין RGB ל-HSV/HSB, המודל שבו משתמשים בוררי הצבעים של Photoshop ו-Figma.
עיינו בפלטת הצבעים המובנית של Tailwind CSS.
המירו בין RGB ל-HSL.
בנו קובץ robots.txt מקבוצות כללים.
בנו sitemap.xml מרשימת כתובות URL שהדבקתם.
בנו תגי link חלופיים של hreflang לגרסאות שפה.
בנו תג link קנוני.
בנו נתונים מובנים בפורמט JSON-LD לסוגים נפוצים.
בנו Info.plist ל-iOS/macOS ממפתחות נפוצים של חבילה ופרטיות.
בנו מטענים לדוגמה להתראות APNs ו-FCM.
בנו קובץ .entitlements (דומיינים משויכים, קבוצות אפליקציות, דחיפה, iCloud ועוד).
אמתו קובץ google-services.json מול מבנה התצורה הצפוי של Firebase.
הציגו רשימת קבצים וגדלים בתוך APK.
צרו מטא-נתונים עבור App Store/Play Store.
צרו את כל גדלי סמל האפליקציה הנדרשים.
נתחו את רמת התחרותיות של מילות מפתח.
מצאו מילות מפתח ל-ASO בעלות ערך גבוה.
צרו הערות גרסה לחנויות האפליקציות.
נהלו מחרוזות תרגום בין שפות.
המירו אורך CSS בין px, rem, em, pt ו-%.
סדרו מחדש את ההזחה של CSS או צמצמו אותו.
עצבו וצמצמו קוד HTML.
המירו בין Markdown ל-HTML.
צרו תגי meta, Open Graph ו-Twitter Card לראש הדף.
צרו פלטות צבעים הרמוניות.
צרו את כל גדלי ה-favicon הסטנדרטיים.
קודדו או פענחו ישויות HTML.
בנו טבלת HTML באופן חזותי.
צרו CSS בסגנון Glassmorphism.
צרו CSS בסגנון Neumorphism.
בנו שילובי מחלקות Tailwind באופן חזותי.
עצבו אנימציות CSS עם @keyframes.
השוו בין שני צילומי מצב של HTML.
המירו קובץ גופן בין TTF/OTF ל-WOFF.
צרו ברקוד EAN-13.
עצבו ויפו שאילתות SQL.
בנו שאילתות MongoDB באופן חזותי.
נתחו הצהרות INSERT למערך JSON.
המירו שורות CSV להצהרות INSERT.
צרו דיאגרמת ER מסכמה.
הציגו חזותית את הקשרים בין טבלאות.
נתחו שאילתה לאיתור בעיות ביצועים אפשריות.
השוו בין שני צילומי מצב של סכמה או שאילתות.
הציגו חזותית תוכנית EXPLAIN.
עצבו שאילתה/מסמך של MongoDB בצורה קריאה.
חפשו ועקבו בזמן אמת אחרי קובצי יומן שהועלו.
הוסיפו הערות לצילומי מסך כדי לדווח על באגים.
סכמו שיעורי שגיאות ודפוסים ביומנים.
עצבו Stack Trace גולמיים לצורה קריאה.
נתחו וסכמו דוחות קריסה.