API 테스트, JSON/DB/Git 유틸리티, 클라우드 생성기, AI 개발 도구 등을 무료로 제공합니다. 기본 기능은 가입이 필요 없습니다.
키를 누르면 KeyboardEvent의 key/code/keyCode 값을 실시간으로 볼 수 있습니다.
curl 명령을 fetch, Python, PHP, HTTPie로, 또는 그 반대로 변환합니다.
HTTP 요청을 만들어 보내고, 응답을 확인하고, 기록을 저장합니다.
내 브라우저가 지원하는 웹 플랫폼 기능을 확인합니다.
모든 표준 HTTP 응답 상태 코드를 검색할 수 있는 참고 자료입니다.
HTTP Authorization: Basic 헤더를 만들거나 디코딩합니다.
둘 이상의 JS 스니펫의 실행 속도를 격리된 Web Worker에서 비교합니다.
텍스트를 퍼센트 인코딩하거나 디코딩합니다(구성요소 또는 전체 URI 모드).
TOML과 JSON/YAML을 서로 변환합니다.
패턴을 텍스트에 테스트하고 일치 부분을 실시간으로 강조하며 캡처 그룹을 보여 줍니다.
스크린샷을 기기 프레임, 그라데이션, 그림자, 텍스트로 멋지게 다듬습니다.
랩 타임이 있는 브라우저 스톱워치입니다.
우리 서버가 보는 내 접속 IP 주소를 보여 줍니다.
도메인 등록 정보를 조회합니다.
프리셋, 색상, SVG/PNG 내보내기, 일괄 모드를 지원하는 스캔 가능한 QR 코드를 생성합니다.
강력한 랜덤 비밀번호를 생성합니다.
비밀번호, API 키, AES 키, UUID, RSA/SSH 키 쌍을 생성합니다. 모두 클라이언트에서 동작합니다.
v4/v7 UUID를 대량으로 생성합니다.
목업용 고전적인 자리표시 텍스트입니다.
빈 줄이나 공백만 있는 줄을 지웁니다.
글자, 단어, 줄, 문장 수를 실시간으로 셉니다.
엔드포인트에 요청을 몰아서 보내 실제 속도 제한을 알아봅니다.
두 API 응답을 비교해 구조화된 차이를 확인합니다.
모든 GraphQL 엔드포인트에 쿼리를 실행하고 스키마를 둘러봅니다.
URL을 가져와 응답 헤더를 설명하고 보안 헤더 등급을 매깁니다.
JWT의 헤더와 페이로드를 디코딩해 확인하고 서명을 검증합니다.
파일 확장자 <-> MIME 유형 매핑을 검색할 수 있는 참고 자료입니다.
OAuth2 인증 코드 흐름을 단계별로 따라가며 토큰을 확인합니다.
채팅 완성 요청이나 함수/도구 스키마의 형태를 검증합니다.
OpenAPI/Swagger 명세를 Postman 컬렉션으로, 또는 그 반대로 변환합니다.
Fill in {{variable}} prompt templates and preview the resolved prompt.
REST 엔드포인트 명세를 설계하고 이를 바탕으로 문서와 목(mock)을 생성합니다.
LLM 프롬프트의 토큰 수를 추정합니다.
cron으로 엔드포인트의 가동 상태와 지연 시간을 지속적으로 모니터링합니다.
고유한 수신함 URL을 받아 들어오는 웹훅 요청을 실시간으로 확인합니다.
화면/뷰포트 크기를 실시간으로 보여 줍니다.
일반적인 기기 뷰포트 크기로 URL을 미리 봅니다.
.env 파일을 JSON이나 YAML로, 또는 그 반대로 변환합니다.
Terraform 변수 파일을 만듭니다.
AWS ARN을 분석하거나 조립합니다.
Unix 파일 권한을 토글해 chmod 명령을 만듭니다.
AWS/GCP/Azure 리전 코드를 조회합니다.
cron 표현식을 만들고 설명합니다.
docker-compose.yml을 생성합니다.
docker run 명령을 동등한 docker-compose.yml 서비스 블록으로 변환합니다.
일반적인 스택용 Dockerfile을 생성합니다.
일반 JSON과 DynamoDB AttributeValue JSON을 서로 변환합니다.
.env 파일을 관리하고 비교합니다.
AWS IAM 정책 JSON 문서를 만듭니다.
Kubernetes 매니페스트를 생성합니다.
S3/API Gateway/SNS/SQS/EventBridge용 샘플 이벤트 페이로드입니다.
nginx server 블록을 생성합니다.
S3 URL(virtual-hosted, path-style, s3://)을 분석/생성합니다.
Terraform 설정의 들여쓰기를 다시 맞춥니다.
사이트와 서비스의 가동 상태를 모니터링합니다.
User-Agent 문자열을 분석합니다.
VPC CIDR을 같은 크기의 서브넷으로 나눕니다.
CMYK(인쇄)와 RGB(화면) 색상 값을 서로 변환합니다.
표준 CSS 색상 이름과 16진수 코드를 서로 변환합니다.
색상을 고르고 HEX/RGB/HSL로 확인합니다.
WCAG 텍스트/배경 대비율과 AA/AAA 통과 여부를 확인합니다.
16진수 코드와 RGB 값을 서로 변환합니다.
Google의 Material Design 색상 팔레트를 둘러봅니다.
무작위 16진수 색상(파스텔/선명/어두운 색)을 생성합니다.
RGB와 HSL을 서로 변환합니다.
RGB와 HSV/HSB(Photoshop/Figma 색상 선택기가 쓰는 모델)를 서로 변환합니다.
Tailwind CSS의 기본 색상 팔레트를 둘러봅니다.
CSV 행을 INSERT 문으로 변환합니다.
테이블 간 관계를 시각화합니다.
스키마에서 ER 다이어그램을 생성합니다.
MongoDB 쿼리/문서를 보기 좋게 정리합니다.
MongoDB 쿼리를 시각적으로 만듭니다.
EXPLAIN 계획을 시각화합니다.
두 스키마/쿼리 스냅샷을 비교합니다.
SQL 쿼리를 정리하고 보기 좋게 만듭니다.
쿼리의 잠재적인 성능 문제를 분석합니다.
INSERT 문을 행 객체의 JSON 배열로 변환합니다.
텍스트와 10진 문자 코드를 서로 변환합니다.
텍스트를 Base32(RFC 4648)로, 또는 그 반대로 변환합니다.
텍스트를 Base58(비트코인 알파벳)으로, 또는 그 반대로 변환합니다.
Base64를 16진수 바이트 문자열로, 또는 그 반대로 변환합니다.
텍스트와 8비트 2진수 바이트를 서로 변환합니다.
모든 파일을 브라우저 안에서 Base64 데이터 URI로 변환합니다.
텍스트와 16진수 바이트를 서로 변환합니다.
URL 쿼리 문자열을 JSON 객체로, 또는 그 반대로 변환합니다.
텍스트와 유니코드 코드 포인트(U+XXXX)를 서로 변환합니다.
샌드박스 테스트용으로 Luhn 검증을 통과하는 더미 카드 번호를 생성합니다.
테스트용 가짜 도로명 주소를 생성합니다.
가짜 전화번호(미국 555 교환번호 등)를 생성합니다.
테스트용 가짜 이름/이메일/사용자 이름을 생성합니다.
RFC 2606 예약 도메인으로 테스트 이메일 주소를 생성합니다.
조화로운 색상 팔레트를 생성합니다.
CSS @keyframes 애니메이션을 디자인합니다.
CSS의 들여쓰기를 다시 맞추거나 압축합니다.
CSS 그라데이션을 디자인하고 내보냅니다.
CSS 길이를 px, rem, em, pt, % 사이에서 변환합니다.
표준 파비콘 크기를 모두 생성합니다.
글꼴 파일을 TTF/OTF와 WOFF 사이에서 변환합니다.
글라스모피즘 CSS를 생성합니다.
두 HTML 스냅샷을 비교합니다.
HTML 엔터티를 인코딩하거나 디코딩합니다.
HTML 마크업을 정리하고 압축합니다.
HTML 표를 시각적으로 만듭니다.
Markdown과 HTML을 서로 변환합니다.
head 메타/Open Graph/Twitter Card 태그를 생성합니다.
뉴모피즘 CSS를 생성합니다.
겹겹이 쌓은 CSS box-shadow를 디자인합니다.
SVG 마크업을 압축하고 정리합니다.
Tailwind 클래스 조합을 시각적으로 만듭니다.
언어, 편집기, OS별 체크리스트로 .gitignore를 만듭니다.
정리할 오래되었거나 병합된 브랜치를 찾습니다.
커밋 기록에서 변경 이력을 생성합니다.
자주 쓰는 git 명령을 검색할 수 있는 참고 자료입니다.
Conventional Commits 형식의 커밋 메시지를 생성합니다.
병합 충돌을 시각화하고 해결을 돕습니다.
병합된 PR에서 릴리스 노트를 생성합니다.
이미지를 base64 데이터 URI로, 또는 그 반대로 변환합니다.
JPEG/WebP 품질을 조절해 이미지를 줄입니다.
드래그로 영역을 선택해 이미지를 자릅니다.
이미지를 정확한 크기로 조절합니다.
이미지를 형식 간에 변환합니다.
네트워크 요청이 필요 없는 가벼운 인라인 SVG 자리표시자 이미지를 생성합니다.
SVG 마크업을 원하는 크기의 PNG나 JPEG로 래스터화합니다.
SVG 마크업을 안전하게 미리 봅니다(이미지로 렌더링하며 페이지에 삽입하지 않습니다).
CSV와 JSON을 서로 변환합니다.
CSV를 실제 .xlsx 파일로, 또는 그 반대로 변환합니다.
Firestore 보안 규칙의 들여쓰기를 다시 맞춥니다.
Java .properties 파일을 JSON이나 YAML로, 또는 그 반대로 변환합니다.
두 JSON 문서의 차이를 비교합니다.
JSON을 검증하고, 보기 좋게 정리하고, 압축합니다.
샘플 JSON에 JSONPath 식을 테스트합니다.
샘플 데이터에서 JSON 스키마를 시각적으로 만듭니다.
우리 XML → JSON 변환기의 규칙에 맞춰 JSON을 XML로 변환합니다.
TOML을 검증하고 JSON으로 미리 봅니다.
XML을 보기 좋게 정리하고 검증합니다.
XML 문서를 JSON으로 변환합니다.
일반적인 YAML 부분 집합을 JSON으로, 또는 그 반대로 변환합니다.
YAML 문서를 검증하고 정리합니다.
크래시 리포트를 분석하고 요약합니다.
버그를 보고하기 위해 스크린샷에 주석을 답니다.
로그의 오류율과 패턴을 요약합니다.
업로드한 로그 파일을 검색하고 실시간으로 따라갑니다.
원본 스택 트레이스를 보기 좋게 정리합니다.
APK 안의 파일과 크기를 나열합니다.
필요한 모든 앱 아이콘 크기를 생성합니다.
모바일 앱용 개인정보 처리방침을 생성합니다.
앱 스토어용 릴리스 노트를 생성합니다.
키워드 경쟁력을 분석합니다.
App Store/Play Store 메타데이터를 생성합니다.
가치 높은 ASO 키워드를 찾습니다.
.entitlements 파일(연결된 도메인, 앱 그룹, 푸시, iCloud 등)을 만듭니다.
google-services.json이 예상되는 Firebase 설정 형태와 맞는지 검증합니다.
일반적인 번들/개인정보 키로 iOS/macOS Info.plist를 만듭니다.
여러 로캘의 번역 문자열을 관리합니다.
APNs와 FCM 샘플 푸시 페이로드를 만듭니다.
2진수 산술과 진법 변환기입니다.
AND/OR/XOR/NOT/시프트를 비트 단위로 보여 줍니다.
서브넷 계산: 네트워크/브로드캐스트 주소, 넷마스크, 호스트 범위.
초, HH:MM:SS, 읽기 쉬운 시간 표현 사이에서 변환합니다.
시작 시각에 시간 길이를 더해 결과 날짜/시간을 확인합니다.
16진수 산술/비트 연산과 진법 변환기입니다.
IPv4를 정수/16진수 형태와 IPv4 매핑 IPv6로 변환합니다.
CIDR 블록이나 주소 범위를 개별 IP 주소 전체로 펼칩니다.
사설 IPv6 번호 지정을 위한 RFC 4193 고유 로컬 주소 접두사를 생성합니다.
로컬 관리 방식의 무작위 MAC 주소를 생성합니다.
MAC 주소의 비트 플래그를 해석하고 최선을 다해 제조사를 조회합니다.
bps/Mbps 등을 변환하고 다운로드 시간을 추정합니다.
자주 쓰는 퍼센트 계산 네 가지를 한곳에서 합니다.
개발 서버와 설정용 무작위 TCP/UDP 포트 번호를 생성합니다.
데이터 크기를 바이트/KB/MB/GB/TB 사이에서 10진 또는 2진으로 변환합니다.
섭씨, 화씨, 켈빈 사이에서 변환합니다.
웹사이트가 온라인인지 확인하고 호스팅, WordPress 감지, SSL, DNS, SEO, 성능을 확인합니다.
EAN-13 바코드를 생성합니다.
텍스트와 파일을 Base64로 인코딩하거나 디코딩합니다.
PHP 기본 password_hash/password_verify로 텍스트를 bcrypt 해시하거나 검증합니다.
올바른 엔트로피와 체크섬을 가진 BIP39 니모닉 시드 구문(12~24단어)을 생성합니다.
엔드포인트의 CORS 동작을 테스트합니다.
일반적인 암호로 텍스트를 암호화/복호화합니다.
MD5/SHA 계열 해시를 생성합니다.
메시지와 비밀 키로 HMAC을 계산합니다(SHA-1/256/384/512).
IBAN의 mod-97 체크섬을 검증하고 국가/BBAN으로 분해합니다.
Base32 시크릿이나 otpauth:// URI로 실시간 TOTP(RFC 6238) 코드를 생성합니다.
비밀번호 강도를 점수로 매기고 해독 시간을 추정합니다. 모두 클라이언트에서 동작합니다.
SSL 인증서 만료일을 모니터링합니다.
스크린샷의 키/이메일을 가리기 위해 문자열의 가운데를 마스킹합니다.
안전한 랜덤 토큰/API 키를 생성합니다.
정렬 가능한 Crockford Base32 인코딩 ULID를 대량으로 생성합니다.
canonical link 태그를 만듭니다.
언어별 대체 페이지를 알리는 hreflang link 태그를 만듭니다.
규칙 그룹으로 robots.txt를 만듭니다.
일반적인 유형의 JSON-LD 구조화 데이터를 만듭니다.
붙여 넣은 URL 목록으로 sitemap.xml을 만듭니다.
고정된 글리프 세트가 아니라 실제 글꼴을 샘플링해 텍스트를 ASCII 아트로 만듭니다.
UPPER/lower/Title/camelCase/snake_case 등 사이에서 변환합니다.
반복된 줄을 제거하고 첫 번째만 남깁니다.
중복 제거를 위해 이메일을 제공업체의 표준 형태로 정규화합니다.
카테고리별로 정리된 엄선한 이모지를 검색하고 복사합니다.
정규식과 단어 단위 옵션으로 텍스트를 찾고 바꿉니다.
목록을 다듬습니다: 공백 제거, 중복 제거, 정렬, 감싸기, 원하는 구분자로 합치기.
진짜 파서(eval 없음)로 수식을 계산합니다. 연산자, 함수, 상수를 지원합니다.
"i18n"처럼 첫 글자, 가운데 글자 수, 마지막 글자로 단어를 줄입니다.
전화번호를 E.164 국가 번호, 국가, 국내 번호로 분해합니다.
흔한 영어 단어로 만든 무작위 채움 텍스트입니다.
정규식 토큰, 수량자, 자주 쓰는 패턴을 검색할 수 있는 참고 자료입니다.
아라비아 숫자와 로마 숫자를 서로 변환합니다.
줄의 순서를 무작위로 섞습니다.
텍스트를 URL에 안전한 슬러그로 변환합니다.
줄을 알파벳순(A-Z 또는 Z-A)으로 정렬합니다.
추가/삭제를 강조해 보여 주는 일반 텍스트 줄 비교입니다.
NATO 음성 알파벳으로 텍스트를 철자로 읽습니다.
앱 ID로 Apple App Store 링크를 만듭니다.
사용자 지정 URI 스킴 딥 링크를 만듭니다.
제목/본문/참조/숨은참조가 포함된 mailto: 링크를 만듭니다.
패키지 이름으로 Google Play Store 링크를 만듭니다.
Microsoft Safe Links로 감싸진 링크에서 원래 URL을 복원합니다.
메시지가 미리 입력된 크로스 플랫폼 sms: 링크를 만듭니다.
Unix 타임스탬프와 날짜를 서로 변환합니다.
리디렉션을 따라가 최종 목적지를 보여 줍니다.
URL을 프로토콜, 호스트, 경로, 쿼리 매개변수, 해시로 나눕니다.
짧은 리디렉션 링크를 만듭니다.
wa.me 클릭 한 번으로 채팅하는 링크를 만듭니다.