Testes de API, utilitários de JSON/BD/Git, geradores para nuvem, ferramentas de IA para desenvolvedores e mais: grátis e sem cadastro para o básico.
Pressione uma tecla para ver em tempo real seus valores key, code e keyCode do KeyboardEvent.
Compare a velocidade de execução de 2 ou mais trechos de JS, executados em um Web Worker isolado.
Verifique se um site está online e veja hospedagem, detecção de WordPress, SSL, DNS, SEO e desempenho.
Monte um Info.plist de iOS/macOS a partir de chaves comuns de bundle e privacidade.
Visualize uma URL nos tamanhos de viewport de dispositivos comuns.
Some uma duração a um horário inicial e veja a data e hora resultantes.
Converta comandos curl para fetch, Python, PHP ou HTTPie, e vice-versa.
Teste um padrão em um texto com destaque de correspondências em tempo real e grupos de captura.
Codifique ou decodifique texto com porcentagem, no modo componente ou URI completa.
Converta texto em bytes binários de 8 bits e vice-versa.
Teste expressões JSONPath em um JSON de exemplo.
Projete animações CSS com @keyframes.
Gere JSON de exemplo realista que segue um JSON Schema, com semente repetível.
Decodifique e inspecione o cabeçalho e o payload de um JWT e verifique assinaturas.
Crie um JSON Schema visualmente a partir de dados de exemplo.
Um cronômetro no navegador com tempos de volta.
Mostra o endereço IP com o qual nosso servidor vê você se conectar.
Consulte as informações de registro de um domínio.
Gere um QR Code escaneável com predefinições, cores, exportação SVG/PNG e modo em lote.
Gere senhas aleatórias fortes.
Gere senhas, chaves de API, chaves AES, UUIDs e pares de chaves RSA/SSH, tudo no navegador.
Gere UUIDs v4/v7 em lote.
O clássico texto de preenchimento para mockups.
Remova linhas vazias ou só com espaços.
Contagem em tempo real de caracteres, palavras, linhas e frases.
Verifique quais recursos da plataforma web o seu navegador suporta.
Mostra em tempo real o tamanho da sua tela e do seu viewport.
Crie e envie requisições HTTP, inspecione respostas e salve o histórico.
Envie rajadas de requisições a um endpoint para descobrir seu limite de taxa real.
Referência pesquisável de extensão de arquivo <-> tipo MIME.
Referência pesquisável de todos os códigos de status de resposta HTTP padrão.
Monte ou decodifique um cabeçalho HTTP Authorization: Basic.
Fill in {{variable}} prompt templates and preview the resolved prompt.
Busca uma URL e explica seus cabeçalhos de resposta, com uma nota de segurança.
Valide uma requisição de chat completions ou o formato de um esquema de função/ferramenta.
Percorra um fluxo OAuth2 com código de autorização e inspecione os tokens.
Projete especificações de endpoints REST e gere documentação e mocks a partir delas.
Estime a quantidade de tokens de um prompt para LLM.
Compare duas respostas de API e veja as diferenças de forma estruturada.
Converta uma especificação OpenAPI/Swagger em uma coleção do Postman e vice-versa.
Execute consultas em qualquer endpoint GraphQL e navegue pelo esquema.
Receba uma URL de caixa de entrada exclusiva e inspecione em tempo real as requisições de webhook recebidas.
Monitore continuamente a disponibilidade e a latência de um endpoint via cron.
Converta texto em códigos de caracteres decimais e vice-versa.
Converta texto em pontos de código Unicode (U+XXXX) e vice-versa.
Converta texto em bytes hexadecimais e vice-versa.
Converta texto em Base58 (alfabeto do Bitcoin) e vice-versa.
Converta texto em Base32 (RFC 4648) e vice-versa.
Converta qualquer arquivo em um data URI Base64, tudo no seu navegador.
Converta uma query string de URL em um objeto JSON e vice-versa.
Converta Base64 em uma sequência de bytes hexadecimais e vice-versa.
Detecte e decodifique automaticamente Base64, hex, codificação URL, gzip e mais, camada por camada.
Avalie uma expressão matemática com um analisador real (sem eval): operadores, funções e constantes.
Randomize a ordem das linhas.
Localize e substitua texto com regex e opções de palavra inteira.
Converta entre MAIÚSCULAS, minúsculas, Título, camelCase, snake_case etc.
Comparação linha a linha de texto simples com destaque de adições e remoções.
Referência pesquisável de tokens, quantificadores e padrões comuns de regex.
Remodele uma lista: apare, remova duplicatas, ordene, envolva e junte com qualquer separador.
Normalize um e-mail para sua forma canônica por provedor, para eliminar duplicatas.
Pesquise e copie emojis de um conjunto selecionado de uso comum, agrupados por categoria.
Converta texto em um slug seguro para URL.
Ordene linhas alfabeticamente, de A a Z ou de Z a A.
Texto de preenchimento aleatório com palavras comuns em inglês.
Abrevie palavras como "i18n": primeira letra, quantidade de letras do meio e última letra.
Converta entre números arábicos e números romanos.
Remova linhas repetidas, mantendo a primeira ocorrência.
Transforme texto em arte ASCII amostrando uma fonte real, e não um conjunto fixo de glifos.
Soletre texto com o alfabeto fonético da OTAN.
Analise um número de telefone e obtenha seu código E.164, país e número nacional.
Aritmética binária e conversor de bases.
Converta tamanhos de dados entre bytes, KB, MB, GB e TB, em decimal ou binário.
Cálculo de sub-redes: endereço de rede e de broadcast, máscara e faixa de hosts.
AND, OR, XOR, NOT e deslocamentos com visualização em nível de bit.
Converta entre segundos, HH:MM:SS e durações em texto legível.
Quatro cálculos de porcentagem comuns em um só lugar.
Decodifique os indicadores de bits de um endereço MAC e busque o fabricante da melhor forma possível.
Expanda um bloco CIDR ou uma faixa de endereços em todos os seus endereços IP.
Gere um prefixo de endereço local único (RFC 4193) para numeração IPv6 privada.
Converta entre graus Celsius, Fahrenheit e Kelvin.
Aritmética e operações bit a bit em hexadecimal, mais um conversor de bases.
Gere endereços MAC aleatórios de administração local.
Converta IPv4 para sua forma inteira, hexadecimal e IPv6 mapeado para IPv4.
Converta bps, Mbps etc. e estime o tempo de download.
Gere números de porta TCP/UDP aleatórios para servidores de desenvolvimento e configurações.
Siga um endereço web por todos os redirecionamentos e veja códigos de status, loops e atualizações para HTTPS.
Encontre titular, AS de origem, prefixo anunciado e vizinhos BGP de um IP, prefixo, número de AS ou nome de host.
Calcule a janela TCP necessária e a vazão real dados largura de banda, latência e perda de pacotes.
Converta formatos de endereço MAC e obtenha o endereço IPv6 link-local e o pacote mágico do Wake-on-LAN.
Converta o horário entre fusos com horário de verão e encontre uma hora de reunião para todos.
Converta entre CIDR, máscara de sub-rede e máscara wildcard e gere linhas de ACL da Cisco.
Lista pesquisável das portas TCP e UDP comuns e dos serviços que as usam.
Resuma rotas IPv4 e IPv6 na menor lista de prefixos ou em uma única rota de resumo.
Gere tokens e chaves de API aleatórios e seguros.
Codifique ou decodifique texto e arquivos em Base64.
Gere ULIDs ordenáveis em Base32 de Crockford, em lote.
Gere hashes da família MD5/SHA.
Gere ou verifique hashes bcrypt com password_hash e password_verify nativos do PHP.
Gere um código TOTP (RFC 6238) em tempo real a partir de um segredo Base32 ou de uma URI otpauth://.
Teste o comportamento CORS de um endpoint.
Calcule um HMAC a partir de uma mensagem e de uma chave secreta (SHA-1/256/384/512).
Oculte o meio de uma string para esconder chaves e e-mails em capturas de tela.
Criptografe e descriptografe texto com cifras comuns.
Valide o dígito verificador mod-97 de um IBAN e separe-o em país e BBAN.
Gere uma frase semente BIP39 (12 a 24 palavras) com a entropia e o checksum corretos.
Avalie a força de uma senha e estime o tempo para quebrá-la, tudo no navegador.
Verifique se uma senha aparece em vazamentos conhecidos sem enviá-la.
Pesquise um ID de CVE ou produto: gravidade, status CISA KEV, chance de exploração, produtos afetados e referências.
Crie uma Content-Security-Policy e encontre fraquezas em uma existente.
Descubra qual algoritmo gerou um hash ou calcule o checksum de um arquivo com MD5, SHA-1 e SHA-2.
Pontue vulnerabilidades com CVSS 3.1: pontuações base, temporal e de ambiente e a string do vetor.
Leia a versão e a hora de criação dentro de um UUID e gere UUIDs v7 ordenáveis.
Mostre a impressão digital SHA256 e MD5, o tipo e o tamanho de uma chave pública SSH e compare com outra.
Crie o atributo integrity e a tag HTML para scripts e folhas de estilo carregados de uma CDN.
Extraia IPs, domínios, URLs, e-mails, hashes e CVEs de um texto e neutralize ou restaure links.
Crie um arquivo security.txt conforme a RFC 9116 para que os pesquisadores saibam como relatar vulnerabilidades.
Decodifique um certificado X.509 ou CSR: assunto, emissor, validade, SANs, chave e impressões digitais.
Monitore as datas de expiração de certificados SSL.
Monte um documento JSON de política IAM da AWS.
Divida um CIDR de VPC em sub-redes iguais.
Alterne permissões de arquivo Unix para montar um comando chmod.
Monte um arquivo de variáveis do Terraform.
Analise ou construa um ARN da AWS.
Analise e construa URLs do S3 (virtual-hosted, path-style, s3://).
Consulte os códigos de região da AWS, GCP e Azure.
Converta um arquivo .env em JSON ou YAML e vice-versa.
Reindente a configuração do Terraform.
Exemplos de eventos para S3, API Gateway, SNS, SQS e EventBridge.
Converta um comando docker run no bloco de serviço equivalente do docker-compose.yml.
Converta entre JSON comum e JSON AttributeValue do DynamoDB.
Gere um workflow do GitHub Actions para Node, Python, PHP, Go, Java, Rust, .NET, Docker ou Pages.
Crie um arquivo .htaccess do Apache para redirecionamentos, HTTPS, cache, compressão e segurança, com regras do Nginx.
Teste quais versões satisfazem um intervalo de versão semântica no estilo npm.
Gerencie e compare arquivos .env.
Gere um Dockerfile para stacks comuns.
Crie e explique expressões cron.
Gere um docker-compose.yml.
Analise uma string User-Agent.
Gere blocos server do nginx.
Gere manifestos do Kubernetes.
Monitore a disponibilidade de sites e serviços.
Gere endereços de e-mail de teste em domínios reservados pela RFC 2606.
Gere nomes, e-mails e nomes de usuário falsos para testes.
Gere números de telefone falsos (prefixo 555 dos EUA etc.).
Gere números de cartão fictícios válidos pelo algoritmo de Luhn para testes em sandbox.
Gere endereços postais falsos para testes.
Monte um .gitignore a partir de listas por linguagem, editor e sistema operacional.
Referência pesquisável dos comandos git mais comuns.
Visualize e ajude a resolver conflitos de merge.
Gere uma mensagem de commit convencional.
Encontre branches obsoletas ou já mescladas para limpar.
Crie selos do shields.io para versão, build, licença e downloads e copie como Markdown ou HTML.
Gere um registro de alterações a partir do histórico de commits.
Gere notas de versão a partir dos PRs mesclados.
Converta entre TOML e JSON/YAML.
Formate e valide XML.
Compare dois documentos JSON.
Valide e formate documentos YAML.
Valide, formate e minifique JSON.
Converta JSON em XML, seguindo as convenções do nosso conversor de XML para JSON.
Converta JSON em CSV com achatamento, delimitadores e saída compatível com Excel.
Gere tipos TypeScript, Go, Java, C# ou Python a partir de um JSON de exemplo.
Valide TOML e visualize-o como JSON.
Converta documentos XML em JSON.
Converta entre CSV e JSON.
Converta um subconjunto comum de YAML em JSON e vice-versa.
Converta um arquivo .properties do Java em JSON ou YAML e vice-versa.
Reindente as regras de segurança do Firestore.
Converta CSV em um arquivo .xlsx de verdade e vice-versa.
Selecione arrastando e corte uma imagem.
Redimensione uma imagem para dimensões exatas.
Reduza uma imagem com qualidade JPEG/WebP ajustável.
Visualize código SVG com segurança (exibido como imagem, sem ser injetado).
Converta uma imagem em um data URI base64 e vice-versa.
Converta uma imagem entre formatos.
Rasterize código SVG para PNG ou JPEG em qualquer tamanho.
Gere uma imagem placeholder SVG leve e embutida, sem requisição de rede.
Transforme capturas de tela em imagens bem acabadas com molduras de dispositivo, gradientes, sombras e texto.
Transforme um trecho de código em um PNG estilizado com temas, molduras de janela e números de linha.
Taxa de contraste WCAG entre texto e fundo, com aprovação ou reprovação AA/AAA.
Escolha uma cor e veja-a em HEX, RGB e HSL.
Converta entre códigos hexadecimais e valores RGB.
Converta entre RGB e HSL.
Converta entre RGB e HSV/HSB, o modelo dos seletores de cor do Photoshop e do Figma.
Gere cores hexadecimais aleatórias (pastel, vibrantes ou escuras).
Converta entre valores de cor CMYK (impressão) e RGB (tela).
Explore a paleta de cores padrão do Tailwind CSS.
Converta entre as cores nomeadas padrão do CSS e códigos hexadecimais.
Explore a paleta de cores do Material Design do Google.
Converta entre timestamps Unix e datas.
Recupere a URL original de um link envolvido pelo Microsoft Safe Links.
Divida uma URL em protocolo, host, caminho, parâmetros de consulta e hash.
Monte um deep link com esquema de URI personalizado.
Monte um link sms: multiplataforma com mensagem pré-preenchida.
Monte um link da Google Play Store a partir do nome de um pacote.
Monte um link mailto: com assunto, corpo, cc e cco.
Monte um link da App Store da Apple a partir do ID de um app.
Monte um link wa.me para iniciar uma conversa com um clique.
Siga os redirecionamentos até o destino final.
Crie links curtos de redirecionamento.
Monte tags link alternativas de hreflang para idiomas.
Monte um sitemap.xml a partir de uma lista de URLs colada.
Monte um robots.txt a partir de grupos de regras.
Monte dados estruturados JSON-LD para os tipos mais comuns.
Leia o sitemap de qualquer site, veja a estrutura das páginas como árvore e grafo e verifique títulos, meta tags e códigos de status.
Monte uma tag link canônica.
Monte payloads de exemplo para APNs e FCM.
Valide um google-services.json em relação à estrutura de configuração esperada do Firebase.
Monte um arquivo .entitlements (domínios associados, grupos de apps, push, iCloud etc.).
Gere todos os tamanhos de ícone de app necessários.
Analise a competitividade das palavras-chave.
Gere uma política de privacidade para um app móvel.
Encontre palavras-chave ASO de alto valor.
Gerencie strings de tradução em vários idiomas.
Liste os arquivos e tamanhos dentro de um APK.
Gere notas de versão para as lojas de apps.
Gere metadados para a App Store e a Play Store.
Reindente ou minifique CSS.
Converta um comprimento CSS entre px, rem, em, pt e %.
Formate JavaScript minificado ou compacte-o, com tratamento seguro de strings, templates e regex.
Gere todos os tamanhos padrão de favicon.
Monte uma tabela HTML visualmente.
Gere paletas de cores harmoniosas.
Minifique e limpe código SVG.
Gere CSS de glassmorphism.
Projete box-shadows CSS em camadas.
Gere meta tags do head, Open Graph e Twitter Card.
Projete e exporte gradientes CSS.
Codifique ou decodifique entidades HTML.
Converta entre Markdown e HTML.
Compare dois instantâneos de HTML.
Gere CSS de neumorfismo.
Converta um arquivo de fonte entre TTF/OTF e WOFF.
Monte combinações de classes do Tailwind visualmente.
Formate e minifique código HTML.
Gere um código de barras EAN-13.
Converta linhas CSV em instruções INSERT.
Formate e embeleze consultas SQL.
Crie consultas MongoDB visualmente.
Visualize os relacionamentos entre tabelas.
Analise uma consulta em busca de possíveis problemas de desempenho.
Transforme instruções INSERT em um array JSON.
Gere um diagrama entidade-relacionamento a partir de um esquema.
Formate de forma legível uma consulta ou documento do MongoDB.
Compare dois instantâneos de esquema ou de consultas.
Visualize um plano EXPLAIN.
Resuma taxas e padrões de erro nos logs.
Pesquise e acompanhe em tempo real arquivos de log enviados.
Formate stack traces brutos de forma legível.
Anote capturas de tela para reportar bugs.
Analise e resuma relatórios de falha.