Проверьте, работает ли сайт, и узнайте хостинг, наличие WordPress, SSL, DNS, SEO и производительность.
Нажмите клавишу, чтобы увидеть её значения key/code/keyCode из KeyboardEvent в реальном времени.
Соберите Info.plist для iOS/macOS из типичных ключей bundle и конфиденциальности.
Сравните скорость выполнения 2+ фрагментов JS в изолированном Web Worker.
Просмотрите URL в типичных размерах области просмотра устройств.
Преобразуйте команды curl в fetch, Python, PHP или HTTPie и обратно.
Кодируйте процентами или декодируйте текст в режиме компонента или полного URI.
Секундомер в браузере с отсечками кругов.
Декодируйте сертификат X.509 или CSR: субъект, издатель, срок действия, SAN, ключ и отпечатки.
Создавайте CSS глассморфизма.
Получите уникальный адрес почтового ящика и просматривайте входящие вебхук-запросы в реальном времени.
Создавайте и экспортируйте CSS-градиенты.
Показывает IP-адрес, с которого наш сервер видит ваше подключение.
Узнайте регистрационные данные домена.
Создайте сканируемый QR-код с пресетами, цветами, экспортом SVG/PNG и пакетным режимом.
Создавайте надёжные случайные пароли.
Создавайте пароли, API-ключи, ключи AES, UUID и пары ключей RSA/SSH — всё на стороне клиента.
Создавайте UUID v4/v7 пачками.
Классический текст-заполнитель для макетов.
Проверьте, какие функции веб-платформы поддерживает ваш браузер.
Показывает размер экрана и области просмотра в реальном времени.
Проверьте каждую клавишу новой или старой клавиатуры: экранная раскладка, обнаружение двойных нажатий, тест rollover, тепловая карта и скорость печати.
Преобразуйте текст в 8-битные двоичные байты и обратно.
Преобразуйте текст в десятичные коды символов и обратно.
Преобразуйте текст в кодовые точки Unicode (U+XXXX) и обратно.
Преобразуйте текст в шестнадцатеричные байты и обратно.
Преобразуйте текст в/из Base58 (алфавит Bitcoin).
Преобразуйте текст в/из Base32 (RFC 4648).
Преобразуйте любой файл в data URI Base64 прямо в браузере.
Автоматически определяйте и декодируйте Base64, hex, URL-кодирование, gzip и другое, слой за слоем.
Преобразуйте Base64 в строку шестнадцатеричных байтов и обратно.
Преобразуйте query string URL в JSON-объект и обратно.
Добавьте длительность к времени начала и увидьте итоговые дату и время.
Двоичная арифметика и конвертер систем счисления.
Переводите размеры данных между байтами/КБ/МБ/ГБ/ТБ, десятичные или двоичные.
Расчёт подсетей: адрес сети и широковещательный адрес, маска, диапазон хостов.
AND/OR/XOR/NOT/сдвиги с побитовым представлением.
Расшифруйте битовые флаги MAC-адреса и найдите производителя по возможности.
Раскройте блок CIDR или диапазон адресов во все отдельные IP-адреса.
Переводите между секундами, ЧЧ:ММ:СС и читаемыми длительностями.
Создайте префикс уникального локального адреса RFC 4193 для частной нумерации IPv6.
Четыре распространённых расчёта процентов в одном месте.
Переводите между градусами Цельсия, Фаренгейта и кельвинами.
Шестнадцатеричная арифметика и битовые операции плюс конвертер систем счисления.
Создавайте случайные локально администрируемые MAC-адреса.
Преобразуйте IPv4 в целое/шестнадцатеричное представление и IPv6, отображённый из IPv4.
Создавайте случайные номера портов TCP/UDP для серверов разработки и конфигураций.
Проследите веб-адрес через все перенаправления и узнайте коды статуса, циклы и переходы на HTTPS.
Узнайте владельца, AS-источник, анонсируемый префикс и BGP-соседей для IP, префикса, номера AS или имени хоста.
Переводите бит/с, Мбит/с и т. д. и оценивайте время загрузки.
Преобразуйте форматы MAC-адресов, получите адрес IPv6 link-local и магический пакет Wake-on-LAN.
Преобразуйте CIDR, маску подсети и wildcard-маску и создавайте строки ACL для Cisco.
Преобразуйте время между часовыми поясами с учётом летнего времени и найдите время встречи для всех.
Список распространённых портов TCP и UDP и использующих их служб с поиском.
Рассчитайте нужное окно TCP и реальную пропускную способность при заданных пропускной способности, задержке и потерях пакетов.
Суммируйте маршруты IPv4 и IPv6 в минимальный список префиксов или один суммарный маршрут.
Создавайте и отправляйте HTTP-запросы, изучайте ответы и сохраняйте историю.
Поиск по соответствию расширение файла <-> MIME-тип.
Справочник всех стандартных кодов состояния HTTP с поиском.
Отправьте серию запросов к эндпоинту, чтобы найти его реальный лимит.
Fill in {{variable}} prompt templates and preview the resolved prompt.
Соберите или декодируйте HTTP-заголовок Authorization: Basic.
Проверьте запрос chat completions или структуру схемы функции/инструмента.
Получает URL и объясняет заголовки ответа, с оценкой безопасности.
Пройдите поток OAuth2 с кодом авторизации и изучите токены.
Проектируйте спецификации REST-эндпоинтов и создавайте по ним документацию и моки.
Декодируйте и изучайте заголовок и полезную нагрузку JWT, проверяйте подписи.
Оцените количество токенов в промпте для LLM.
Сравните два ответа API и увидьте различия в структурированном виде.
Выполняйте запросы к любому GraphQL-эндпоинту и изучайте его схему.
Преобразуйте спецификацию OpenAPI/Swagger в коллекцию Postman и обратно.
Постоянно отслеживайте доступность и задержку эндпоинта через cron.
Проверяйте шаблон на тексте с подсветкой совпадений в реальном времени и группами захвата.
Вычислите математическое выражение настоящим парсером (без eval): операторы, функции, константы.
Случайно перемешайте порядок строк.
Удаляйте пустые строки и строки только из пробелов.
Приведите email к канонической форме провайдера для удаления дублей.
Ищите и заменяйте текст с regex и поиском целых слов.
Сортируйте строки по алфавиту: А-Я или Я-А.
Преобразуйте между ВЕРХНИМ/нижним/Заглавным/camelCase/snake_case и др.
Поиск по токенам, квантификаторам и распространённым шаблонам regex.
Подсчёт символов, слов, строк и предложений в реальном времени.
Преобразуйте список: обрезка, удаление дублей, сортировка, обрамление и объединение любым разделителем.
Преобразуйте текст в slug, безопасный для URL.
Построчное сравнение текста с подсветкой добавленного и удалённого.
Ищите и копируйте из подобранного набора распространённых эмодзи по категориям.
Случайный текст-заполнитель из распространённых английских слов.
Сокращайте слова как «i18n»: первая буква, число букв между ними, последняя буква.
Превратите текст в ASCII-арт, сэмплируя настоящий шрифт, а не фиксированный набор глифов.
Преобразуйте между арабскими и римскими числами.
Удаляйте повторы, сохраняя первое вхождение.
Произнесите текст по фонетическому алфавиту НАТО.
Разберите номер телефона на код страны E.164, страну и национальный номер.
Создавайте безопасные случайные токены и API-ключи.
Кодируйте или декодируйте текст и файлы в Base64.
Проверьте поведение CORS эндпоинта.
Создавайте пачками сортируемые ULID в кодировке Base32 Крокфорда.
Создавайте хеши семейства MD5/SHA.
Хешируйте или проверяйте текст через bcrypt с помощью встроенных password_hash/password_verify в PHP.
Создайте актуальный TOTP-код (RFC 6238) из секрета Base32 или URI otpauth://.
Вычислите HMAC по сообщению и секретному ключу (SHA-1/256/384/512).
Замаскируйте середину строки, чтобы скрыть ключи и email на скриншотах.
Шифруйте и расшифровывайте текст распространёнными шифрами.
Проверьте контрольную сумму mod-97 IBAN и разберите его на страну и BBAN.
Создайте мнемоническую seed-фразу BIP39 (12–24 слова) с корректной энтропией и контрольной суммой.
Оцените надёжность пароля и время его взлома, полностью на стороне клиента.
Ищите идентификатор CVE или продукт: критичность, статус CISA KEV, вероятность эксплуатации, затронутые продукты и ссылки.
Оценивайте уязвимости по CVSS 3.1: базовая, временная и контекстная оценки и строка вектора.
Читайте версию и время создания внутри UUID и генерируйте сортируемые UUID v7.
Проверьте, встречается ли пароль в известных утечках, не отправляя его.
Узнайте, каким алгоритмом получен хеш, или вычислите контрольную сумму файла с помощью MD5, SHA-1 и SHA-2.
Создайте Content-Security-Policy и найдите слабые места в существующей.
Покажите отпечатки SHA256 и MD5, тип и размер открытого SSH-ключа и сравните его с другим.
Извлекайте IP, домены, URL, email, хеши и CVE из текста, обезвреживайте и восстанавливайте ссылки.
Создайте атрибут integrity и HTML-тег для скриптов и стилей, загружаемых с CDN.
Создайте файл security.txt по RFC 9116, чтобы исследователи знали, как сообщать об уязвимостях.
Отслеживайте даты истечения SSL-сертификатов.
Соберите JSON-документ политики AWS IAM.
Разделите CIDR VPC на равные подсети.
Соберите файл переменных Terraform.
Переключайте права доступа Unix, чтобы собрать команду chmod.
Разберите или соберите AWS ARN.
Найдите коды регионов AWS/GCP/Azure.
Разбирайте и собирайте URL S3 (virtual-hosted, path-style, s3://).
Перерасставьте отступы в конфигурации Terraform.
Примеры событий для S3/API Gateway/SNS/SQS/EventBridge.
Преобразуйте файл .env в JSON или YAML и обратно.
Преобразуйте команду docker run в эквивалентный блок сервиса docker-compose.yml.
Создайте рабочий процесс GitHub Actions для Node, Python, PHP, Go, Java, Rust, .NET, Docker или Pages.
Преобразуйте между обычным JSON и JSON AttributeValue DynamoDB.
Создайте файл .htaccess для Apache: редиректы, HTTPS, кэширование, сжатие и безопасность, с правилами для Nginx.
Проверьте, какие версии удовлетворяют диапазону семантических версий в стиле npm.
Управляйте файлами .env и сравнивайте их.
Создайте Dockerfile для распространённых стеков.
Разберите строку User-Agent.
Создайте файл docker-compose.yml.
Создавайте и объясняйте cron-выражения.
Создавайте блоки server для nginx.
Отслеживайте доступность сайтов и сервисов.
Создавайте манифесты Kubernetes.
Создавайте тестовые адреса email в доменах, зарезервированных RFC 2606.
Создавайте поддельные номера телефонов (американский обменный код 555 и т. д.).
Создавайте поддельные имена, email и логины для тестирования.
Создавайте фиктивные номера карт, корректные по Луну, для тестов в песочнице.
Создавайте поддельные почтовые адреса для тестирования.
Коэффициент контрастности текста и фона по WCAG, результат AA/AAA.
Выберите цвет и увидьте его в HEX/RGB/HSL.
Преобразуйте между RGB и HSV/HSB — моделью выбора цвета в Photoshop и Figma.
Преобразуйте между шестнадцатеричными кодами и значениями RGB.
Преобразуйте между RGB и HSL.
Создавайте случайные HEX-цвета (пастельные/яркие/тёмные).
Преобразуйте между значениями CMYK (печать) и RGB (экран).
Просматривайте стандартную палитру цветов Tailwind CSS.
Преобразуйте между стандартными именами цветов CSS и HEX-кодами.
Просматривайте палитру цветов Material Design от Google.
Сравните два JSON-документа.
Проверяйте и форматируйте YAML-документы.
Преобразуйте между TOML и JSON/YAML.
Форматируйте и проверяйте XML.
Проверяйте, форматируйте и минифицируйте JSON.
Преобразуйте JSON в XML по соглашениям нашего конвертера XML в JSON.
Создавайте реалистичный пример JSON по JSON Schema с воспроизводимым seed.
Преобразуйте JSON в CSV с разворачиванием вложенности, разделителями и совместимостью с Excel.
Создавайте типы TypeScript, Go, Java, C# или Python из примера JSON.
Визуально постройте JSON Schema по примерам данных.
Преобразуйте XML-документы в JSON.
Проверяйте выражения JSONPath на примере JSON.
Проверяйте TOML и просматривайте его как JSON.
Преобразуйте между CSV и JSON.
Преобразуйте файл Java .properties в JSON или YAML и обратно.
Преобразуйте распространённое подмножество YAML в JSON и обратно.
Перерасставьте отступы в правилах безопасности Firestore.
Преобразуйте CSV в настоящий файл .xlsx и обратно.
Соберите .gitignore из списков по языку, редактору и ОС.
Поиск по распространённым командам git.
Создайте conventional-сообщение коммита.
Визуализируйте конфликты слияния и помогайте их разрешать.
Найдите устаревшие или уже слитые ветки для удаления.
Создавайте значки shields.io для версии, сборки, лицензии и загрузок и копируйте их как Markdown или HTML.
Создайте журнал изменений по истории коммитов.
Создайте заметки о релизе по слитым PR.
Уменьшайте изображение с настраиваемым качеством JPEG/WebP.
Выделите область перетаскиванием и обрежьте изображение.
Измените размер изображения до точных значений.
Безопасно просматривайте SVG-разметку (отображается как изображение, без внедрения).
Преобразуйте изображение в data URI base64 и обратно.
Преобразуйте изображение между форматами.
Растеризуйте SVG-разметку в PNG или JPEG любого размера.
Превращайте скриншоты в аккуратные изображения с рамками устройств, градиентами, тенями и текстом.
Превратите фрагмент кода в стильный PNG с темами, рамками окна и номерами строк.
Создайте лёгкое встроенное SVG-изображение-заглушку без сетевого запроса.
Преобразуйте между временными метками Unix и датами.
Восстановите исходный URL из ссылки, обёрнутой Microsoft Safe Links.
Разберите URL на протокол, хост, путь, параметры запроса и хеш.
Соберите deep link с собственной схемой URI.
Соберите кроссплатформенную ссылку sms: с готовым сообщением.
Соберите ссылку Google Play Store по имени пакета.
Соберите ссылку Apple App Store по ID приложения.
Соберите ссылку mailto: с темой, текстом, копией и скрытой копией.
Соберите ссылку wa.me для чата в один клик.
Проследите перенаправления до конечного адреса.
Создавайте короткие ссылки-перенаправления.
Соберите примеры payload для APNs и FCM.
Проверьте google-services.json на соответствие ожидаемой структуре конфигурации Firebase.
Соберите файл .entitlements (связанные домены, группы приложений, push, iCloud и др.).
Создайте все необходимые размеры иконки приложения.
Анализируйте конкурентность ключевых слов.
Найдите ценные ключевые слова для ASO.
Создайте политику конфиденциальности для мобильного приложения.
Управляйте строками перевода для разных языков.
Список файлов и размеров внутри APK.
Создавайте метаданные для App Store и Play Store.
Создавайте заметки о релизе для магазинов приложений.
Форматируйте минифицированный JavaScript или сжимайте его с безопасной обработкой строк, шаблонов и регулярных выражений.
Перерасставьте отступы или минифицируйте CSS.
Переведите длину CSS между px, rem, em, pt и %.
Создайте все стандартные размеры favicon.
Сравните два снимка HTML.
Визуально создайте HTML-таблицу.
Создавайте гармоничные цветовые палитры.
Кодируйте или декодируйте HTML-сущности.
Создавайте CSS-анимации @keyframes.
Создавайте мета-теги head, Open Graph и Twitter Card.
Минифицируйте и очищайте SVG-разметку.
Создавайте многослойные CSS box-shadow.
Преобразуйте между Markdown и HTML.
Создавайте CSS неоморфизма.
Преобразуйте файл шрифта между TTF/OTF и WOFF.
Визуально собирайте комбинации классов Tailwind.
Форматируйте и минифицируйте HTML-разметку.
Соберите альтернативные теги link hreflang для языковых версий.
Соберите sitemap.xml из вставленного списка URL.
Прочитайте карту любого сайта, посмотрите структуру страниц в виде дерева и графа и проверьте заголовки, мета-теги и коды ответа.
Соберите robots.txt из групп правил.
Соберите канонический тег link.
Создайте структурированные данные JSON-LD для распространённых типов.
Создайте штрихкод EAN-13.
Преобразуйте строки CSV в операторы INSERT.
Форматируйте и украшайте SQL-запросы.
Стройте запросы MongoDB визуально.
Создайте ER-диаграмму по схеме.
Проанализируйте запрос на возможные проблемы с производительностью.
Визуализируйте связи между таблицами.
Преобразуйте операторы INSERT в массив JSON.
Отформатируйте запрос или документ MongoDB.
Сравните два снимка схемы или запросов.
Визуализируйте план EXPLAIN.
Сводка по частоте и шаблонам ошибок в логах.
Приведите необработанные стек-трейсы к читаемому виду.
Ищите и следите в реальном времени за загруженными лог-файлами.
Разбирайте и обобщайте отчёты о сбоях.
Добавляйте пометки к скриншотам для сообщений об ошибках.