Testowanie API, narzędzia JSON/baz danych/Git, generatory chmurowe, narzędzia AI dla programistów i więcej — za darmo, podstawy bez rejestracji.
Naciśnij klawisz, aby zobaczyć na żywo jego wartości key/code/keyCode z KeyboardEvent.
Porównaj szybkość wykonania 2+ fragmentów JS w izolowanym Web Workerze.
Sprawdź, czy witryna działa, i zobacz hosting, wykrywanie WordPressa, SSL, DNS, SEO i wydajność.
Arytmetyka binarna i konwerter systemów liczbowych.
Konwertuj polecenia curl na fetch, Python, PHP lub HTTPie i z powrotem.
Sprawdź, które funkcje platformy webowej obsługuje Twoja przeglądarka.
Dodaj czas trwania do godziny startu i zobacz wynikową datę/godzinę.
Twórz i wysyłaj żądania HTTP, sprawdzaj odpowiedzi i zapisuj historię.
Testuj wzorzec na tekście z podświetlaniem dopasowań na żywo i grupami przechwytującymi.
Zbuduj plik zmiennych Terraform.
Przykładowe zdarzenia dla S3/API Gateway/SNS/SQS/EventBridge.
Wygeneruj notatki o wydaniu ze scalonych PR-ów.
Zarządzaj ciągami tłumaczeń w wielu językach.
Wygeneruj przepływ pracy GitHub Actions dla Node, Python, PHP, Go, Java, Rust, .NET, Docker lub Pages.
Wygeneruj Dockerfile dla popularnych stosów.
Stoper w przeglądarce z czasami okrążeń.
Pokazuje adres IP, z którego widzi Cię nasz serwer.
Sprawdź dane rejestracyjne domeny.
Generuj skanowalny kod QR z ustawieniami, kolorami, eksportem SVG/PNG i trybem wsadowym.
Generuj silne losowe hasła.
Generuj hasła, klucze API, klucze AES, UUID i pary kluczy RSA/SSH — wszystko po stronie klienta.
Generuj UUID v4/v7 hurtowo.
Klasyczny tekst zastępczy do makiet.
Usuń puste lub zawierające tylko białe znaki linie.
Liczba znaków, słów, linii i zdań na żywo.
Wyświetl podgląd adresu URL w typowych rozmiarach viewportu urządzeń.
Pokazuje na żywo rozmiar ekranu i viewportu.
Przeszukiwalny wykaz rozszerzenie pliku <-> typ MIME.
Zbuduj lub zdekoduj nagłówek HTTP Authorization: Basic.
Wyślij serię żądań do endpointu, aby znaleźć jego rzeczywisty limit.
Fill in {{variable}} prompt templates and preview the resolved prompt.
Przeszukiwalny wykaz wszystkich standardowych kodów statusu odpowiedzi HTTP.
Zwaliduj żądanie chat completions lub kształt schematu funkcji/narzędzia.
Pobiera adres URL i wyjaśnia jego nagłówki odpowiedzi, z oceną bezpieczeństwa.
Dekoduj i sprawdzaj nagłówek oraz payload JWT, weryfikuj podpisy.
Wykonuj zapytania do dowolnego endpointu GraphQL i przeglądaj jego schemat.
Przejdź przez przepływ OAuth2 z kodem autoryzacji i sprawdź tokeny.
Uzyskaj unikalny adres skrzynki i na żywo sprawdzaj przychodzące żądania webhook.
Konwertuj specyfikację OpenAPI/Swagger na kolekcję Postman i z powrotem.
Oszacuj liczbę tokenów promptu dla LLM.
Projektuj specyfikacje endpointów REST i generuj z nich dokumentację oraz makiety.
Porównaj dwie odpowiedzi API i zobacz różnice w uporządkowanej formie.
Stale monitoruj dostępność i opóźnienia endpointu przez cron.
Przeliczaj rozmiary danych między bajtami/KB/MB/GB/TB, dziesiętnie lub binarnie.
Obliczenia podsieci: adres sieci i rozgłoszeniowy, maska, zakres hostów.
AND/OR/XOR/NOT/przesunięcia z widokiem na poziomie bitów.
Rozwiń blok CIDR lub zakres adresów do wszystkich pojedynczych adresów IP.
Przeliczaj między sekundami, GG:MM:SS i czytelnymi czasami trwania.
Przeliczaj między Celsjuszem, Fahrenheitem i Kelwinem.
Zdekoduj flagi bitowe adresu MAC oraz najlepsze możliwe wyszukanie producenta.
Cztery popularne obliczenia procentowe w jednym miejscu.
Wygeneruj prefiks Unique Local Address RFC 4193 do prywatnej numeracji IPv6.
Arytmetyka i operacje bitowe w systemie szesnastkowym oraz konwerter systemów.
Generuj losowe numery portów TCP/UDP dla serwerów deweloperskich i konfiguracji.
Przeliczaj bps/Mbps itd. i szacuj czas pobierania.
Generuj losowe, lokalnie administrowane adresy MAC.
Konwertuj IPv4 na postać całkowitą/szesnastkową i IPv6 mapowany z IPv4.
Śledź adres internetowy przez każde przekierowanie i sprawdź kody stanu, pętle i przejścia na HTTPS.
Znajdź właściciela, AS pochodzenia, ogłaszany prefiks i sąsiadów BGP dla IP, prefiksu, numeru AS lub nazwy hosta.
Przeszukiwalna lista popularnych portów TCP i UDP oraz usług, które z nich korzystają.
Przeliczaj czas między strefami z uwzględnieniem czasu letniego i znajdź godzinę spotkania dla wszystkich.
Przeliczaj CIDR, maskę podsieci i maskę wildcard oraz generuj linie ACL Cisco.
Oblicz potrzebne okno TCP i rzeczywistą przepustowość przy danej przepustowości łącza, opóźnieniu i utracie pakietów.
Konwertuj formaty adresów MAC i uzyskaj adres IPv6 link-local oraz pakiet magiczny Wake-on-LAN.
Agreguj trasy IPv4 i IPv6 do najmniejszej listy prefiksów lub jednej trasy zbiorczej.
Oblicz wyrażenie matematyczne prawdziwym parserem (bez eval): operatory, funkcje, stałe.
Konwertuj między WIELKIMI/małymi/Tytułowymi/camelCase/snake_case itd.
Znajduj i zamieniaj tekst z opcjami regex i całych słów.
Losowo zmień kolejność linii.
Sortuj linie alfabetycznie, A-Z lub Z-A.
Przeszukiwalny zbiór tokenów, kwantyfikatorów i popularnych wzorców regex.
Porównanie tekstu linia po linii z wyróżnieniem dodanych i usuniętych.
Przekształć listę: przytnij, usuń duplikaty, posortuj, ujmij w cudzysłowy i połącz dowolnym separatorem.
Znormalizuj e-mail do postaci kanonicznej dla dostawcy, aby usuwać duplikaty.
Szukaj i kopiuj z wyselekcjonowanego zestawu popularnych emoji, pogrupowanych według kategorii.
Zamień tekst na slug bezpieczny dla adresów URL.
Skracaj słowa jak „i18n”: pierwsza litera, liczba liter w środku, ostatnia litera.
Losowy tekst wypełniający z popularnych angielskich słów.
Konwertuj między liczbami arabskimi a rzymskimi.
Usuń powtórzone linie, zachowując pierwsze wystąpienie.
Przeliteruj tekst alfabetem fonetycznym NATO.
Zamień tekst na ASCII art, próbkując prawdziwą czcionkę, a nie stały zestaw glifów.
Rozbij numer telefonu na kod kraju E.164, kraj i numer krajowy.
Koduj procentowo lub dekoduj tekst w trybie komponentu lub pełnego URI.
Konwertuj tekst na dziesiętne kody znaków i z powrotem.
Konwertuj tekst na punkty kodowe Unicode (U+XXXX) i z powrotem.
Konwertuj tekst na 8-bitowe bajty binarne i z powrotem.
Konwertuj tekst do/z Base32 (RFC 4648).
Konwertuj tekst na bajty szesnastkowe i z powrotem.
Konwertuj tekst do/z Base58 (alfabet Bitcoina).
Konwertuj Base64 na ciąg bajtów szesnastkowych i z powrotem.
Zamień dowolny plik na data URI Base64, w całości w przeglądarce.
Konwertuj query string adresu URL na obiekt JSON i z powrotem.
Automatycznie wykrywaj i dekoduj Base64, szesnastkowy, kodowanie URL, gzip i inne, warstwa po warstwie.
Generuj bezpieczne losowe tokeny i klucze API.
Koduj lub dekoduj tekst i pliki w Base64.
Oblicz HMAC z wiadomości i tajnego klucza (SHA-1/256/384/512).
Generuj na żywo kod TOTP (RFC 6238) z sekretu Base32 lub URI otpauth://.
Testuj zachowanie CORS endpointu.
Generuj hurtowo sortowalne ULID kodowane Base32 Crockforda.
Haszuj lub weryfikuj tekst bcryptem, używając natywnych password_hash/password_verify w PHP.
Generuj skróty z rodziny MD5/SHA.
Zamaskuj środek ciągu, aby ukryć klucze/e-maile na zrzutach ekranu.
Szyfruj i odszyfrowuj tekst popularnymi szyframi.
Zwaliduj sumę kontrolną mod-97 numeru IBAN i rozbij go na kraj i BBAN.
Wygeneruj frazę seed BIP39 (12-24 słowa) z poprawną entropią i sumą kontrolną.
Oceń siłę hasła i oszacuj czas jego złamania, w całości po stronie klienta.
Sprawdź, jaki algorytm utworzył skrót, lub oblicz sumę kontrolną pliku za pomocą MD5, SHA-1 i SHA-2.
Sprawdź, czy hasło występuje w znanych wyciekach, bez jego wysyłania.
Wyszukaj identyfikator CVE lub produkt: ważność, status CISA KEV, prawdopodobieństwo wykorzystania, dotknięte produkty i odnośniki.
Odczytaj wersję i czas utworzenia zapisane w UUID i generuj sortowalne UUID v7.
Pokaż odcisk SHA256 i MD5, typ oraz rozmiar publicznego klucza SSH i porównaj go z innym.
Oceniaj podatności według CVSS 3.1: wyniki bazowy, czasowy i środowiskowy oraz ciąg wektora.
Zbuduj Content-Security-Policy i znajdź słabe punkty w istniejącej.
Wyodrębnij IP, domeny, URL, e-maile, skróty i CVE z tekstu oraz zneutralizuj lub przywróć linki.
Zdekoduj certyfikat X.509 lub CSR: podmiot, wystawca, ważność, SAN, klucz i odciski.
Utwórz atrybut integrity i znacznik HTML dla skryptów i arkuszy stylów ładowanych z CDN.
Utwórz plik security.txt zgodny z RFC 9116, aby badacze wiedzieli, jak zgłaszać luki.
Monitoruj daty wygaśnięcia certyfikatów SSL.
Zbuduj dokument JSON polityki AWS IAM.
Przełączaj uprawnienia plików Unix, aby zbudować polecenie chmod.
Analizuj lub buduj ARN AWS.
Podziel CIDR VPC na równe podsieci.
Analizuj i buduj adresy S3 (virtual-hosted, path-style, s3://).
Konwertuj plik .env na JSON lub YAML i z powrotem.
Ponownie wcinaj konfigurację Terraform.
Sprawdź kody regionów AWS/GCP/Azure.
Konwertuj między zwykłym JSON a JSON AttributeValue DynamoDB.
Zamień polecenie docker run na równoważny blok usługi docker-compose.yml.
Zbuduj plik .htaccess dla Apache: przekierowania, HTTPS, cache, kompresja i bezpieczeństwo, z regułami Nginx.
Sprawdź, które wersje spełniają zakres wersji semantycznych w stylu npm.
Buduj i objaśniaj wyrażenia cron.
Wygeneruj plik docker-compose.yml.
Analizuj ciąg User-Agent.
Generuj bloki server nginx.
Generuj manifesty Kubernetes.
Zarządzaj plikami .env i porównuj je.
Monitoruj dostępność stron i usług.
Konwertuj między TOML a JSON/YAML.
Formatuj i waliduj XML.
Porównaj dwa dokumenty JSON.
Waliduj i formatuj dokumenty YAML.
Waliduj, formatuj i minifikuj JSON.
Konwertuj JSON na XML, zgodnie z konwencjami naszego konwertera XML na JSON.
Konwertuj JSON na CSV ze spłaszczaniem, separatorami i wynikiem przyjaznym dla Excela.
Generuj realistyczny przykładowy JSON zgodny z JSON Schema, z powtarzalnym ziarnem.
Generuj typy TypeScript, Go, Java, C# lub Python z przykładowego JSON.
Konwertuj między CSV a JSON.
Zbuduj schemat JSON wizualnie na podstawie przykładowych danych.
Konwertuj dokumenty XML na JSON.
Konwertuj popularny podzbiór YAML na JSON i z powrotem.
Testuj wyrażenia JSONPath na przykładowym JSON-ie.
Waliduj TOML i wyświetl podgląd jako JSON.
Konwertuj CSV na prawdziwy plik .xlsx i z powrotem.
Ponownie wcinaj reguły bezpieczeństwa Firestore.
Konwertuj plik .properties Javy na JSON lub YAML i z powrotem.
Generuj testowe adresy e-mail w domenach zarezerwowanych przez RFC 2606.
Generuj fałszywe imiona, e-maile i nazwy użytkowników do testów.
Generuj fałszywe numery telefonów (centrala 555 w USA itd.).
Generuj poprawne wg Luhna fikcyjne numery kart do testów w sandboxie.
Generuj fałszywe adresy pocztowe do testów.
Zmniejsz obraz dzięki regulowanej jakości JPEG/WebP.
Zaznacz przeciągnięciem i przytnij obraz.
Zmień rozmiar obrazu na dokładne wymiary.
Bezpiecznie wyświetl podgląd kodu SVG (renderowany jako obraz, niewstrzykiwany).
Konwertuj obraz między formatami.
Konwertuj obraz na data URI base64 i z powrotem.
Rasteryzuj kod SVG do PNG lub JPEG w dowolnym rozmiarze.
Generuj lekki zastępczy obraz inline SVG bez żądania sieciowego.
Zamień zrzuty ekranu w dopracowane obrazy z ramkami urządzeń, gradientami, cieniami i tekstem.
Zamień fragment kodu w stylowy PNG z motywami, ramkami okna i numerami wierszy.
Konwertuj między znacznikami czasu Unix a datami.
Odzyskaj oryginalny adres z linku opakowanego przez Microsoft Safe Links.
Rozbij URL na protokół, host, ścieżkę, parametry zapytania i hash.
Zbuduj wieloplatformowy link sms: z wypełnioną wiadomością.
Zbuduj deep link z własnym schematem URI.
Zbuduj link do Google Play Store z nazwy pakietu.
Zbuduj link mailto: z tematem/treścią/DW/UDW.
Zbuduj link wa.me do rozpoczęcia czatu jednym kliknięciem.
Zbuduj link do Apple App Store z identyfikatora aplikacji.
Twórz krótkie linki przekierowujące.
Śledź przekierowania do ostatecznego celu.
Zbuduj .gitignore z list kontrolnych dla języka, edytora i systemu.
Przeszukiwalny zbiór popularnych poleceń git.
Wizualizuj konflikty scalania i pomagaj je rozwiązywać.
Wygeneruj konwencjonalny komunikat commit.
Znajdź nieaktualne lub scalone gałęzie do usunięcia.
Twórz plakietki shields.io dla wersji, budowania, licencji i pobrań i kopiuj je jako Markdown lub HTML.
Wygeneruj changelog z historii commitów.
Współczynnik kontrastu WCAG tekstu do tła, wynik AA/AAA.
Wybierz kolor i zobacz go jako HEX/RGB/HSL.
Konwertuj między kodami szesnastkowymi a wartościami RGB.
Generuj losowe kolory szesnastkowe (pastelowe/żywe/ciemne).
Konwertuj między RGB a HSL.
Konwertuj między RGB a HSV/HSB, modelem używanym w próbnikach Photoshopa i Figmy.
Konwertuj między standardowymi nazwami kolorów CSS a kodami szesnastkowymi.
Przeglądaj domyślną paletę kolorów Tailwind CSS.
Przeglądaj paletę kolorów Material Design Google.
Konwertuj między wartościami CMYK (druk) a RGB (ekran).
Zbuduj sitemap.xml z wklejonej listy adresów URL.
Zbuduj alternatywne tagi link hreflang dla wersji językowych.
Zbuduj robots.txt z grup reguł.
Zbuduj kanoniczny tag link.
Zbuduj dane strukturalne JSON-LD dla popularnych typów.
Odczytaj mapę witryny dowolnej strony, zobacz strukturę podstron jako drzewo i graf oraz sprawdź tytuły, tagi meta i kody stanu.
Zbuduj Info.plist iOS/macOS z typowych kluczy bundle i prywatności.
Zwaliduj google-services.json względem oczekiwanej struktury konfiguracji Firebase.
Buduj przykładowe payloady APNs i FCM.
Zbuduj plik .entitlements (powiązane domeny, grupy aplikacji, push, iCloud itd.).
Generuj wszystkie wymagane rozmiary ikon aplikacji.
Wyświetl pliki i rozmiary wewnątrz APK.
Znajdź cenne słowa kluczowe ASO.
Wygeneruj politykę prywatności aplikacji mobilnej.
Analizuj konkurencyjność słów kluczowych.
Generuj notatki o wydaniu dla sklepów z aplikacjami.
Generuj metadane dla App Store i Play Store.
Przelicz długość CSS między px, rem, em, pt i %.
Ponownie wcinaj lub minifikuj CSS.
Formatuj zminifikowany JavaScript lub go kompaktuj, z bezpieczną obsługą ciągów, szablonów i regex.
Generuj wszystkie standardowe rozmiary favicon.
Projektuj i eksportuj gradienty CSS.
Projektuj warstwowe box-shadow w CSS.
Generuj harmonijne palety kolorów.
Formatuj i minifikuj kod HTML.
Wizualnie zbuduj tabelę HTML.
Wizualnie buduj kombinacje klas Tailwind.
Konwertuj między Markdown a HTML.
Minifikuj i czyść kod SVG.
Generuj tagi meta head, Open Graph i Twitter Card.
Projektuj animacje CSS @keyframes.
Generuj CSS glassmorphism.
Koduj lub dekoduj encje HTML.
Generuj CSS neumorfizmu.
Porównaj dwie migawki HTML.
Konwertuj plik czcionki między TTF/OTF a WOFF.
Generuj kod kreskowy EAN-13.
Formatuj i upiększaj zapytania SQL.
Wygeneruj diagram ER ze schematu.
Konwertuj wiersze CSV na instrukcje INSERT.
Wizualizuj relacje między tabelami.
Przetwórz instrukcje INSERT na tablicę JSON.
Buduj zapytania MongoDB wizualnie.
Porównaj dwie migawki schematu lub zapytań.
Przeanalizuj zapytanie pod kątem potencjalnych problemów z wydajnością.
Wizualizuj plan EXPLAIN.
Sformatuj czytelnie zapytanie/dokument MongoDB.
Przeszukuj i śledź na żywo wgrane pliki logów.
Podsumuj wskaźniki i wzorce błędów w logach.
Analizuj i podsumowuj raporty awarii.
Dodawaj adnotacje do zrzutów ekranu, aby zgłaszać błędy.
Formatuj surowe stack trace do czytelnej postaci.