Testes de API, utilitários de JSON/BD/Git, geradores para nuvem, ferramentas de IA para desenvolvedores e mais: grátis e sem cadastro para o básico.
Pressione uma tecla para ver em tempo real seus valores key, code e keyCode do KeyboardEvent.
Converta comandos curl para fetch, Python, PHP ou HTTPie, e vice-versa.
Verifique quais recursos da plataforma web o seu navegador suporta.
Compare a velocidade de execução de 2 ou mais trechos de JS, executados em um Web Worker isolado.
Crie e envie requisições HTTP, inspecione respostas e salve o histórico.
Aritmética binária e conversor de bases.
Monte ou decodifique um cabeçalho HTTP Authorization: Basic.
Visualize uma URL nos tamanhos de viewport de dispositivos comuns.
Converta texto em códigos de caracteres decimais e vice-versa.
Monte um .gitignore a partir de listas por linguagem, editor e sistema operacional.
Minifique e limpe código SVG.
Percorra um fluxo OAuth2 com código de autorização e inspecione os tokens.
Projete box-shadows CSS em camadas.
Explore a paleta de cores padrão do Tailwind CSS.
Projete e exporte gradientes CSS.
Um cronômetro no navegador com tempos de volta.
Mostra o endereço IP com o qual nosso servidor vê você se conectar.
Consulte as informações de registro de um domínio.
Gere um QR Code escaneável com predefinições, cores, exportação SVG/PNG e modo em lote.
Gere senhas aleatórias fortes.
Gere senhas, chaves de API, chaves AES, UUIDs e pares de chaves RSA/SSH, tudo no navegador.
Gere UUIDs v4/v7 em lote.
O clássico texto de preenchimento para mockups.
Remova linhas vazias ou só com espaços.
Contagem em tempo real de caracteres, palavras, linhas e frases.
Referência pesquisável de todos os códigos de status de resposta HTTP padrão.
Envie rajadas de requisições a um endpoint para descobrir seu limite de taxa real.
Referência pesquisável de extensão de arquivo <-> tipo MIME.
Fill in {{variable}} prompt templates and preview the resolved prompt.
Busca uma URL e explica seus cabeçalhos de resposta, com uma nota de segurança.
Valide uma requisição de chat completions ou o formato de um esquema de função/ferramenta.
Decodifique e inspecione o cabeçalho e o payload de um JWT e verifique assinaturas.
Execute consultas em qualquer endpoint GraphQL e navegue pelo esquema.
Receba uma URL de caixa de entrada exclusiva e inspecione em tempo real as requisições de webhook recebidas.
Converta uma especificação OpenAPI/Swagger em uma coleção do Postman e vice-versa.
Estime a quantidade de tokens de um prompt para LLM.
Projete especificações de endpoints REST e gere documentação e mocks a partir delas.
Compare duas respostas de API e veja as diferenças de forma estruturada.
Monitore continuamente a disponibilidade e a latência de um endpoint via cron.
Mostra em tempo real o tamanho da sua tela e do seu viewport.
Codifique ou decodifique texto com porcentagem, no modo componente ou URI completa.
Converta texto em pontos de código Unicode (U+XXXX) e vice-versa.
Converta texto em Base58 (alfabeto do Bitcoin) e vice-versa.
Converta texto em bytes hexadecimais e vice-versa.
Converta texto em bytes binários de 8 bits e vice-versa.
Converta texto em Base32 (RFC 4648) e vice-versa.
Converta qualquer arquivo em um data URI Base64, tudo no seu navegador.
Converta Base64 em uma sequência de bytes hexadecimais e vice-versa.
Converta uma query string de URL em um objeto JSON e vice-versa.
Alterne permissões de arquivo Unix para montar um comando chmod.
Monte um documento JSON de política IAM da AWS.
Analise ou construa um ARN da AWS.
Divida um CIDR de VPC em sub-redes iguais.
Monte um arquivo de variáveis do Terraform.
Analise e construa URLs do S3 (virtual-hosted, path-style, s3://).
Converta um arquivo .env em JSON ou YAML e vice-versa.
Exemplos de eventos para S3, API Gateway, SNS, SQS e EventBridge.
Reindente a configuração do Terraform.
Consulte os códigos de região da AWS, GCP e Azure.
Converta um comando docker run no bloco de serviço equivalente do docker-compose.yml.
Converta entre JSON comum e JSON AttributeValue do DynamoDB.
Crie e explique expressões cron.
Gere um docker-compose.yml.
Analise uma string User-Agent.
Gere um Dockerfile para stacks comuns.
Gere manifestos do Kubernetes.
Gere blocos server do nginx.
Monitore a disponibilidade de sites e serviços.
Gerencie e compare arquivos .env.
Teste um padrão em um texto com destaque de correspondências em tempo real e grupos de captura.
Ordene linhas alfabeticamente, de A a Z ou de Z a A.
Randomize a ordem das linhas.
Avalie uma expressão matemática com um analisador real (sem eval): operadores, funções e constantes.
Converta entre MAIÚSCULAS, minúsculas, Título, camelCase, snake_case etc.
Comparação linha a linha de texto simples com destaque de adições e remoções.
Referência pesquisável de tokens, quantificadores e padrões comuns de regex.
Localize e substitua texto com regex e opções de palavra inteira.
Normalize um e-mail para sua forma canônica por provedor, para eliminar duplicatas.
Converta texto em um slug seguro para URL.
Pesquise e copie emojis de um conjunto selecionado de uso comum, agrupados por categoria.
Remodele uma lista: apare, remova duplicatas, ordene, envolva e junte com qualquer separador.
Converta entre números arábicos e números romanos.
Abrevie palavras como "i18n": primeira letra, quantidade de letras do meio e última letra.
Texto de preenchimento aleatório com palavras comuns em inglês.
Remova linhas repetidas, mantendo a primeira ocorrência.
Soletre texto com o alfabeto fonético da OTAN.
Analise um número de telefone e obtenha seu código E.164, país e número nacional.
Transforme texto em arte ASCII amostrando uma fonte real, e não um conjunto fixo de glifos.
Gere tokens e chaves de API aleatórios e seguros.
Calcule um HMAC a partir de uma mensagem e de uma chave secreta (SHA-1/256/384/512).
Codifique ou decodifique texto e arquivos em Base64.
Gere um código TOTP (RFC 6238) em tempo real a partir de um segredo Base32 ou de uma URI otpauth://.
Gere hashes da família MD5/SHA.
Teste o comportamento CORS de um endpoint.
Gere ULIDs ordenáveis em Base32 de Crockford, em lote.
Gere ou verifique hashes bcrypt com password_hash e password_verify nativos do PHP.
Criptografe e descriptografe texto com cifras comuns.
Oculte o meio de uma string para esconder chaves e e-mails em capturas de tela.
Avalie a força de uma senha e estime o tempo para quebrá-la, tudo no navegador.
Valide o dígito verificador mod-97 de um IBAN e separe-o em país e BBAN.
Gere uma frase semente BIP39 (12 a 24 palavras) com a entropia e o checksum corretos.
Monitore as datas de expiração de certificados SSL.
Cálculo de sub-redes: endereço de rede e de broadcast, máscara e faixa de hosts.
Converta tamanhos de dados entre bytes, KB, MB, GB e TB, em decimal ou binário.
Decodifique os indicadores de bits de um endereço MAC e busque o fabricante da melhor forma possível.
Quatro cálculos de porcentagem comuns em um só lugar.
Converta entre graus Celsius, Fahrenheit e Kelvin.
Converta entre segundos, HH:MM:SS e durações em texto legível.
Some uma duração a um horário inicial e veja a data e hora resultantes.
AND, OR, XOR, NOT e deslocamentos com visualização em nível de bit.
Expanda um bloco CIDR ou uma faixa de endereços em todos os seus endereços IP.
Gere um prefixo de endereço local único (RFC 4193) para numeração IPv6 privada.
Aritmética e operações bit a bit em hexadecimal, mais um conversor de bases.
Gere números de porta TCP/UDP aleatórios para servidores de desenvolvimento e configurações.
Verifique se um site está online e veja hospedagem, detecção de WordPress, SSL, DNS, SEO e desempenho.
Converta bps, Mbps etc. e estime o tempo de download.
Converta IPv4 para sua forma inteira, hexadecimal e IPv6 mapeado para IPv4.
Gere endereços MAC aleatórios de administração local.
Referência pesquisável dos comandos git mais comuns.
Visualize e ajude a resolver conflitos de merge.
Gere uma mensagem de commit convencional.
Encontre branches obsoletas ou já mescladas para limpar.
Gere um registro de alterações a partir do histórico de commits.
Gere notas de versão a partir dos PRs mesclados.
Gere nomes, e-mails e nomes de usuário falsos para testes.
Gere endereços de e-mail de teste em domínios reservados pela RFC 2606.
Gere números de telefone falsos (prefixo 555 dos EUA etc.).
Gere números de cartão fictícios válidos pelo algoritmo de Luhn para testes em sandbox.
Gere endereços postais falsos para testes.
Escolha uma cor e veja-a em HEX, RGB e HSL.
Taxa de contraste WCAG entre texto e fundo, com aprovação ou reprovação AA/AAA.
Gere cores hexadecimais aleatórias (pastel, vibrantes ou escuras).
Converta entre as cores nomeadas padrão do CSS e códigos hexadecimais.
Explore a paleta de cores do Material Design do Google.
Converta entre valores de cor CMYK (impressão) e RGB (tela).
Converta entre códigos hexadecimais e valores RGB.
Converta entre RGB e HSL.
Converta entre RGB e HSV/HSB, o modelo dos seletores de cor do Photoshop e do Figma.
Converta entre TOML e JSON/YAML.
Formate e valide XML.
Compare dois documentos JSON.
Valide e formate documentos YAML.
Valide, formate e minifique JSON.
Converta JSON em XML, seguindo as convenções do nosso conversor de XML para JSON.
Converta entre CSV e JSON.
Converta um subconjunto comum de YAML em JSON e vice-versa.
Converta documentos XML em JSON.
Teste expressões JSONPath em um JSON de exemplo.
Crie um JSON Schema visualmente a partir de dados de exemplo.
Converta um arquivo .properties do Java em JSON ou YAML e vice-versa.
Valide TOML e visualize-o como JSON.
Converta CSV em um arquivo .xlsx de verdade e vice-versa.
Reindente as regras de segurança do Firestore.
Redimensione uma imagem para dimensões exatas.
Reduza uma imagem com qualidade JPEG/WebP ajustável.
Selecione arrastando e corte uma imagem.
Visualize código SVG com segurança (exibido como imagem, sem ser injetado).
Converta uma imagem entre formatos.
Converta uma imagem em um data URI base64 e vice-versa.
Rasterize código SVG para PNG ou JPEG em qualquer tamanho.
Gere uma imagem placeholder SVG leve e embutida, sem requisição de rede.
Transforme capturas de tela em imagens bem acabadas com molduras de dispositivo, gradientes, sombras e texto.
Converta entre timestamps Unix e datas.
Divida uma URL em protocolo, host, caminho, parâmetros de consulta e hash.
Monte um link sms: multiplataforma com mensagem pré-preenchida.
Monte um deep link com esquema de URI personalizado.
Monte um link da Google Play Store a partir do nome de um pacote.
Recupere a URL original de um link envolvido pelo Microsoft Safe Links.
Monte um link da App Store da Apple a partir do ID de um app.
Monte um link wa.me para iniciar uma conversa com um clique.
Monte um link mailto: com assunto, corpo, cc e cco.
Crie links curtos de redirecionamento.
Siga os redirecionamentos até o destino final.
Monte um robots.txt a partir de grupos de regras.
Monte um sitemap.xml a partir de uma lista de URLs colada.
Monte tags link alternativas de hreflang para idiomas.
Monte uma tag link canônica.
Monte dados estruturados JSON-LD para os tipos mais comuns.
Monte um Info.plist de iOS/macOS a partir de chaves comuns de bundle e privacidade.
Monte payloads de exemplo para APNs e FCM.
Monte um arquivo .entitlements (domínios associados, grupos de apps, push, iCloud etc.).
Valide um google-services.json em relação à estrutura de configuração esperada do Firebase.
Liste os arquivos e tamanhos dentro de um APK.
Gere metadados para a App Store e a Play Store.
Gere todos os tamanhos de ícone de app necessários.
Gere uma política de privacidade para um app móvel.
Analise a competitividade das palavras-chave.
Encontre palavras-chave ASO de alto valor.
Gere notas de versão para as lojas de apps.
Gerencie strings de tradução em vários idiomas.
Converta um comprimento CSS entre px, rem, em, pt e %.
Reindente ou minifique CSS.
Formate e minifique código HTML.
Converta entre Markdown e HTML.
Gere meta tags do head, Open Graph e Twitter Card.
Gere paletas de cores harmoniosas.
Gere todos os tamanhos padrão de favicon.
Codifique ou decodifique entidades HTML.
Monte uma tabela HTML visualmente.
Gere CSS de glassmorphism.
Gere CSS de neumorfismo.
Monte combinações de classes do Tailwind visualmente.
Projete animações CSS com @keyframes.
Compare dois instantâneos de HTML.
Converta um arquivo de fonte entre TTF/OTF e WOFF.
Gere um código de barras EAN-13.
Formate e embeleze consultas SQL.
Crie consultas MongoDB visualmente.
Transforme instruções INSERT em um array JSON.
Converta linhas CSV em instruções INSERT.
Gere um diagrama entidade-relacionamento a partir de um esquema.
Visualize os relacionamentos entre tabelas.
Analise uma consulta em busca de possíveis problemas de desempenho.
Compare dois instantâneos de esquema ou de consultas.
Visualize um plano EXPLAIN.
Formate de forma legível uma consulta ou documento do MongoDB.
Pesquise e acompanhe em tempo real arquivos de log enviados.
Anote capturas de tela para reportar bugs.
Resuma taxas e padrões de erro nos logs.
Formate stack traces brutos de forma legível.
Analise e resuma relatórios de falha.