Controlla se un sito web è online e consulta hosting, rilevamento di WordPress, SSL, DNS, SEO e prestazioni.
Confronta la velocità di esecuzione di 2 o più snippet JS in un Web Worker isolato.
Crea un Info.plist iOS/macOS da chiavi comuni di bundle e privacy.
Premi un tasto per vedere in tempo reale i valori key, code e keyCode di KeyboardEvent.
Formatta JavaScript minificato o compattalo, con gestione sicura di stringhe, template e regex.
Visualizza l'anteprima di un URL alle dimensioni di viewport dei dispositivi comuni.
Leggi la sitemap di qualsiasi sito, vedi la struttura delle pagine come albero e grafo e controlla titoli, meta tag e codici di stato.
Crea un documento JSON di policy IAM AWS.
Convalida TOML e visualizzalo come JSON.
Formatta in modo leggibile una query o un documento MongoDB.
Genera blocchi server di nginx.
Genera numeri di porta TCP/UDP casuali per server di sviluppo e configurazioni.
Un cronometro nel browser con tempi parziali.
Mostra l'indirizzo IP con cui il nostro server vede la tua connessione.
Consulta le informazioni di registrazione di un dominio.
Genera un codice QR scansionabile con preset, colori, esportazione SVG/PNG e modalità batch.
Genera password casuali sicure.
Genera password, chiavi API, chiavi AES, UUID e coppie di chiavi RSA/SSH, tutto nel browser.
Genera UUID v4/v7 in blocco.
Il classico testo segnaposto per mockup.
Verifica quali funzionalità della piattaforma web supporta il tuo browser.
Mostra in tempo reale le dimensioni di schermo e viewport.
Prova ogni tasto di una tastiera nuova o vecchia: layout a schermo, rilevamento della doppia pressione, test di rollover, mappa di calore e velocità di scrittura.
Codifica o decodifica testo in percent-encoding, in modalità componente o URI completo.
Converti testo in byte binari a 8 bit e viceversa.
Converti testo in codici carattere decimali e viceversa.
Converti testo in byte esadecimali e viceversa.
Converti testo in code point Unicode (U+XXXX) e viceversa.
Converti testo da/verso Base58 (alfabeto Bitcoin).
Converti testo da/verso Base32 (RFC 4648).
Rileva e decodifica automaticamente Base64, esadecimale, codifica URL, gzip e altro, livello per livello.
Converti qualsiasi file in un data URI Base64, interamente nel browser.
Converti Base64 in una stringa di byte esadecimali e viceversa.
Converti una query string URL in un oggetto JSON e viceversa.
Aggiungi una durata a un orario di inizio e vedi data e ora risultanti.
Aritmetica binaria e convertitore di basi.
Converti dimensioni dati tra byte, KB, MB, GB e TB, in decimale o binario.
Calcolo delle subnet: indirizzo di rete e broadcast, netmask, intervallo di host.
AND, OR, XOR, NOT e shift con vista a livello di bit.
Converti tra secondi, HH:MM:SS e durate in formato leggibile.
Decodifica i flag di bit di un indirizzo MAC più una ricerca del produttore al meglio.
Espandi un blocco CIDR o un intervallo di indirizzi in tutti i singoli indirizzi IP.
Segui un indirizzo web attraverso ogni reindirizzamento e vedi codici di stato, loop e passaggi a HTTPS.
Quattro calcoli percentuali comuni in un unico posto.
Genera un prefisso di indirizzo locale univoco RFC 4193 per la numerazione IPv6 privata.
Converti tra Celsius, Fahrenheit e Kelvin.
Genera indirizzi MAC casuali ad amministrazione locale.
Converti tra CIDR, subnet mask e wildcard mask e genera righe di ACL Cisco.
Aritmetica e operazioni bit a bit in esadecimale, più un convertitore di basi.
Converti un IPv4 in forma intera, esadecimale e IPv6 mappato su IPv4.
Trova titolare, AS di origine, prefisso annunciato e vicini BGP di un IP, prefisso, numero AS o hostname.
Converti i formati degli indirizzi MAC e ottieni l'indirizzo IPv6 link-local e il magic packet Wake-on-LAN.
Converti bps, Mbps, ecc. e stima il tempo di download.
Converti l'ora tra fusi orari con ora legale e trova un orario di riunione per tutti.
Elenco ricercabile delle porte TCP e UDP comuni e dei servizi che le usano.
Calcola la finestra TCP necessaria e il throughput reale in base a banda, latenza e perdita di pacchetti.
Riepiloga route IPv4 e IPv6 nell'elenco di prefissi più piccolo o in un'unica route di riepilogo.
Testa un pattern su un testo con evidenziazione dei match in tempo reale e gruppi di cattura.
Valuta un'espressione matematica con un vero parser (senza eval): operatori, funzioni, costanti.
Rendi casuale l'ordine delle righe.
Elimina le righe vuote o composte solo da spazi.
Conteggio in tempo reale di caratteri, parole, righe e frasi.
Trova e sostituisci testo con opzioni regex e parola intera.
Rimodella una lista: elimina spazi, rimuovi duplicati, ordina, racchiudi e unisci con qualsiasi separatore.
Converti tra MAIUSCOLO, minuscolo, Titolo, camelCase, snake_case, ecc.
Normalizza un'e-mail nella forma canonica del provider per rimuovere i duplicati.
Ordina le righe alfabeticamente, A-Z o Z-A.
Riferimento ricercabile di token, quantificatori e pattern regex comuni.
Confronto riga per riga di testo semplice con evidenziazione di aggiunte e rimozioni.
Converti il testo in uno slug sicuro per gli URL.
Cerca e copia da una selezione di emoji comuni, raggruppate per categoria.
Abbrevia parole come "i18n": prima lettera, numero di lettere intermedie, ultima lettera.
Testo di riempimento casuale con parole inglesi comuni.
Trasforma il testo in ASCII art campionando un vero font, non un set fisso di glifi.
Compita il testo con l'alfabeto fonetico NATO.
Converti tra numeri arabi e numeri romani.
Rimuovi le righe ripetute, mantenendo la prima occorrenza.
Scomponi un numero di telefono in prefisso E.164, paese e numero nazionale.
Genera token e chiavi API casuali e sicuri.
Codifica o decodifica testo e file in Base64.
Genera hash della famiglia MD5/SHA.
Testa il comportamento CORS di un endpoint.
Genera ULID ordinabili codificati in Base32 di Crockford, in blocco.
Calcola o verifica hash con bcrypt, usando password_hash/password_verify nativi di PHP.
Genera in tempo reale un codice TOTP (RFC 6238) da un segreto Base32 o da un URI otpauth://.
Calcola un HMAC da un messaggio e una chiave segreta (SHA-1/256/384/512).
Maschera il centro di una stringa per oscurare chiavi ed e-mail negli screenshot.
Cifra e decifra testo con cifrari comuni.
Cerca un ID CVE o un prodotto: gravità, stato CISA KEV, probabilità di sfruttamento, prodotti interessati e riferimenti.
Convalida il checksum mod-97 di un IBAN e scomponilo in paese e BBAN.
Genera una frase seed BIP39 (12-24 parole) con entropia e checksum corretti.
Valuta la robustezza di una password e stima il tempo per violarla, tutto nel browser.
Valuta le vulnerabilità con CVSS 3.1: punteggi base, temporale e ambientale e stringa del vettore.
Scopri quale algoritmo ha prodotto un hash o calcola il checksum di un file con MD5, SHA-1 e SHA-2.
Estrai IP, domini, URL, email, hash e CVE dal testo e neutralizza o ripristina i link.
Crea una Content-Security-Policy e trova i punti deboli di una esistente.
Leggi versione e ora di creazione contenute in un UUID e genera UUID v7 ordinabili.
Mostra l'impronta SHA256 e MD5, il tipo e la dimensione di una chiave pubblica SSH e confrontala con un'altra.
Crea l'attributo integrity e il tag HTML per script e fogli di stile caricati da una CDN.
Controlla se una password compare in violazioni note senza inviarla.
Crea un file security.txt conforme a RFC 9116 perché i ricercatori sappiano come segnalare le vulnerabilità.
Decodifica un certificato X.509 o una CSR: soggetto, emittente, validità, SAN, chiave e impronte.
Monitora le date di scadenza dei certificati SSL.
Converti comandi curl in fetch, Python, PHP o HTTPie, e viceversa.
Riferimento ricercabile estensione file <-> tipo MIME.
Crea e invia richieste HTTP, ispeziona le risposte e salva la cronologia.
Invia raffiche di richieste a un endpoint per scoprire il suo limite di frequenza effettivo.
Riferimento ricercabile di tutti i codici di stato di risposta HTTP standard.
Fill in {{variable}} prompt templates and preview the resolved prompt.
Crea o decodifica un'intestazione HTTP Authorization: Basic.
Convalida una richiesta chat completions o la forma di uno schema di funzione/strumento.
Recupera un URL e spiega le intestazioni di risposta, con un voto di sicurezza.
Decodifica e ispeziona intestazione e payload di un JWT e verifica le firme.
Progetta specifiche di endpoint REST e genera documentazione e mock a partire da esse.
Percorri un flusso OAuth2 con codice di autorizzazione e ispeziona i token.
Confronta due risposte API e vedi le differenze in modo strutturato.
Esegui query su qualsiasi endpoint GraphQL ed esplora il suo schema.
Stima il numero di token di un prompt per LLM.
Converti una specifica OpenAPI/Swagger in una collezione Postman e viceversa.
Ottieni un URL di casella univoco e ispeziona in tempo reale le richieste webhook in arrivo.
Monitora in modo continuo disponibilità e latenza di un endpoint tramite cron.
Suddividi un CIDR VPC in subnet di uguale dimensione.
Attiva o disattiva i permessi dei file Unix per creare un comando chmod.
Crea un file di variabili Terraform.
Analizza o costruisci un ARN AWS.
Eventi di esempio per S3, API Gateway, SNS, SQS ed EventBridge.
Analizza e costruisci URL S3 (virtual-hosted, path-style, s3://).
Cerca i codici regione di AWS, GCP e Azure.
Converti un comando docker run in un blocco di servizio docker-compose.yml equivalente.
Re-indenta la configurazione Terraform.
Genera un workflow GitHub Actions per Node, Python, PHP, Go, Java, Rust, .NET, Docker o Pages.
Converti tra JSON semplice e JSON AttributeValue di DynamoDB.
Converti un file .env in JSON o YAML e viceversa.
Verifica quali versioni soddisfano un intervallo di versioni semantiche in stile npm.
Crea un file .htaccess Apache per reindirizzamenti, HTTPS, cache, compressione e sicurezza, con regole Nginx.
Gestisci e confronta file .env.
Monitora la disponibilità di siti e servizi.
Genera un Dockerfile per stack comuni.
Crea e spiega espressioni cron.
Genera un docker-compose.yml.
Analizza una stringa User-Agent.
Genera manifest Kubernetes.
Re-indenta o minimizza il CSS.
Converti una lunghezza CSS tra px, rem, em, pt e %.
Genera CSS glassmorphism.
Genera tutte le dimensioni standard di favicon.
Formatta e minimizza markup HTML.
Progetta animazioni CSS @keyframes.
Minimizza e ripulisci il codice SVG.
Genera palette di colori armoniose.
Crea visivamente una tabella HTML.
Confronta due snapshot HTML.
Codifica o decodifica entità HTML.
Converti tra Markdown e HTML.
Progetta ed esporta gradienti CSS.
Genera meta tag head, Open Graph e Twitter Card.
Progetta box-shadow CSS a più livelli.
Converti un file di font tra TTF/OTF e WOFF.
Genera CSS neumorphism.
Crea visualmente combinazioni di classi Tailwind.
Crea un .gitignore da liste di controllo per linguaggio, editor e sistema operativo.
Riferimento ricercabile dei comandi git più comuni.
Genera un messaggio di commit convenzionale.
Visualizza e aiuta a risolvere i conflitti di merge.
Trova branch obsoleti o già uniti da eliminare.
Crea badge shields.io per versione, build, licenza e download e copiali come Markdown o HTML.
Genera un changelog dalla cronologia dei commit.
Genera note di rilascio dalle PR unite.
Rapporto di contrasto WCAG tra testo e sfondo, con esito AA/AAA.
Converti tra codici esadecimali e valori RGB.
Converti tra RGB e HSV/HSB, il modello dei selettori colore di Photoshop e Figma.
Scegli un colore e vedilo in HEX, RGB e HSL.
Converti tra RGB e HSL.
Genera colori esadecimali casuali (pastello, vivaci, scuri).
Converti tra CMYK (stampa) e RGB (schermo).
Sfoglia la palette di colori predefinita di Tailwind CSS.
Converti tra i nomi di colore standard CSS e i codici esadecimali.
Sfoglia la palette di colori Material Design di Google.
Seleziona trascinando e ritaglia un'immagine.
Riduci un'immagine con qualità JPEG/WebP regolabile.
Visualizza in sicurezza il codice SVG (mostrato come immagine, non inserito).
Ridimensiona un'immagine alle dimensioni esatte.
Converti un'immagine in un data URI base64 e viceversa.
Rasterizza il codice SVG in PNG o JPEG a qualsiasi dimensione.
Trasforma uno snippet di codice in un PNG curato con temi, cornici finestra e numeri di riga.
Trasforma gli screenshot in immagini curate con cornici di dispositivo, gradienti, ombre e testo.
Converti un'immagine tra formati.
Genera un'immagine segnaposto SVG inline leggera, senza richieste di rete.
Confronta due documenti JSON.
Convalida e formatta documenti YAML.
Converti tra TOML e JSON/YAML.
Formatta e convalida XML.
Convalida, formatta e minimizza JSON.
Converti JSON in XML, seguendo le convenzioni del nostro convertitore XML in JSON.
Genera JSON di esempio realistico conforme a uno JSON Schema, con seed ripetibile.
Converti JSON in CSV con appiattimento, delimitatori e output adatto a Excel.
Genera tipi TypeScript, Go, Java, C# o Python da un JSON di esempio.
Crea visivamente un JSON Schema da dati di esempio.
Converti documenti XML in JSON.
Testa espressioni JSONPath su un JSON di esempio.
Converti tra CSV e JSON.
Re-indenta le regole di sicurezza di Firestore.
Converti un file .properties di Java in JSON o YAML e viceversa.
Converti un sottoinsieme comune di YAML in JSON e viceversa.
Converti CSV in un vero file .xlsx e viceversa.
Genera indirizzi e-mail di prova su domini riservati dalla RFC 2606.
Genera nomi, e-mail e nomi utente finti per i test.
Genera numeri di telefono finti (prefisso USA 555, ecc.).
Genera numeri di carta fittizi validi secondo Luhn per test in sandbox.
Genera indirizzi postali finti per i test.
Crea payload di esempio per APNs e FCM.
Convalida un google-services.json rispetto alla struttura di configurazione Firebase attesa.
Crea un file .entitlements (domini associati, app group, push, iCloud, ecc.).
Genera tutte le dimensioni di icona app richieste.
Analizza la competitività delle parole chiave.
Genera un'informativa sulla privacy per un'app mobile.
Trova parole chiave ASO di alto valore.
Gestisci le stringhe di traduzione tra più lingue.
Elenca file e dimensioni all'interno di un APK.
Genera metadati per App Store e Play Store.
Genera note di rilascio per gli app store.
Crea tag link alternativi hreflang per le varianti linguistiche.
Crea una sitemap.xml da un elenco di URL incollato.
Crea un robots.txt da gruppi di regole.
Crea un tag link canonico.
Crea dati strutturati JSON-LD per i tipi più comuni.
Converti tra timestamp Unix e date.
Recupera l'URL originale da un link avvolto da Microsoft Safe Links.
Scomponi un URL in protocollo, host, percorso, parametri di query e hash.
Crea un deep link con schema URI personalizzato.
Crea un link sms: multipiattaforma con messaggio precompilato.
Crea un link Google Play Store da un nome pacchetto.
Crea un link mailto: con oggetto, corpo, CC e CCN.
Crea un link Apple App Store da un ID app.
Crea un link wa.me per avviare una chat con un clic.
Segui i reindirizzamenti fino alla destinazione finale.
Crea link brevi di reindirizzamento.
Genera un codice a barre EAN-13.
Converti righe CSV in istruzioni INSERT.
Crea query MongoDB in modo visuale.
Formatta e abbellisci query SQL.
Genera un diagramma ER da uno schema.
Trasforma istruzioni INSERT in un array JSON.
Analizza una query alla ricerca di potenziali problemi di prestazioni.
Visualizza le relazioni tra le tabelle.
Confronta due snapshot di schema o di query.
Visualizza un piano EXPLAIN.
Formatta in modo leggibile stack trace grezzi.
Riassumi tassi e pattern di errore nei log.
Cerca e segui in tempo reale i file di log caricati.
Annota screenshot per segnalare bug.
Analizza e riassumi i report di crash.