בדיקות API, כלי JSON/מסדי נתונים/Git, מחוללי ענן, כלי בינה מלאכותית למפתחים ועוד — בחינם, ובלי הרשמה לשימוש בסיסי.
לחצו על מקש כדי לראות בזמן אמת את ערכי key, code ו-keyCode של KeyboardEvent.
השוו את מהירות הריצה של 2 קטעי JS או יותר ב-Web Worker מבודד.
בדוק אם אתר מקוון וראה את האחסון, זיהוי וורדפרס, SSL, DNS, SEO וביצועים.
אריתמטיקה בינארית וממיר בסיסים.
המירו פקודות curl ל-fetch, Python, PHP או HTTPie ובחזרה.
בדקו תבנית על טקסט עם הדגשה חיה של התאמות וקבוצות לכידה.
הוסיפו משך זמן לשעת התחלה וראו את התאריך והשעה שיתקבלו.
קודדו באחוזים או פענחו טקסט, במצב רכיב או URI מלא.
בדקו אילו יכולות של פלטפורמת האינטרנט הדפדפן שלכם תומך בהן.
הציגו תצוגה מקדימה של URL בגדלי אזור תצוגה של מכשירים נפוצים.
צרו הערות גרסה מ-PR שמוזגו.
נהלו מחרוזות תרגום בין שפות.
צרו workflow של GitHub Actions עבור Node, Python, PHP, Go, Java, Rust, .NET, Docker או Pages.
צרו Dockerfile למחסניות נפוצות.
המירו CSV לקובץ .xlsx אמיתי ובחזרה.
שעון עצר בדפדפן עם זמני הקפות.
מציג את כתובת ה-IP שממנה השרת שלנו רואה אתכם מתחברים.
חפשו פרטי רישום של דומיין.
צרו קוד QR הניתן לסריקה עם הגדרות מוכנות, צבעים, ייצוא SVG/PNG ומצב אצווה.
צרו סיסמאות אקראיות חזקות.
צרו סיסמאות, מפתחות API, מפתחות AES, UUID וזוגות מפתחות RSA/SSH — הכול בצד הלקוח.
צרו UUID מגרסאות v4/v7 בכמות גדולה.
טקסט מילוי קלאסי לדגמים.
הסירו שורות ריקות או שורות של רווחים בלבד.
ספירה חיה של תווים, מילים, שורות ומשפטים.
מציג בזמן אמת את גודל המסך ואזור התצוגה.
צרו ושלחו בקשות HTTP, בדקו תגובות ושמרו היסטוריה.
שלחו התפרצות בקשות לנקודת קצה כדי למצוא את מגבלת הקצב בפועל.
מדריך חיפוש להתאמות בין סיומת קובץ <-> סוג MIME.
בנו או פענחו כותרת HTTP Authorization: Basic.
Fill in {{variable}} prompt templates and preview the resolved prompt.
מדריך חיפוש לכל קודי הסטטוס הסטנדרטיים של תגובות HTTP.
מושך כתובת URL ומסביר את כותרות התגובה שלה, עם ציון אבטחה.
אמתו בקשת chat completions או את מבנה סכמת הפונקציה/הכלי.
פענחו ובדקו את הכותרת והמטען של JWT ואמתו חתימות.
הריצו שאילתות מול כל נקודת קצה של GraphQL וסיירו בסכמה שלה.
עברו על זרימת קוד האימות של OAuth2 ובדקו את האסימונים.
קבלו כתובת תיבת דואר ייחודית ובדקו בקשות webhook נכנסות בזמן אמת.
העריכו את מספר האסימונים בהנחיית LLM.
המירו מפרט OpenAPI/Swagger לאוסף Postman ובחזרה.
תכננו מפרטי נקודות קצה של REST והפיקו מהם תיעוד ודמיות.
השוו בין שתי תגובות API וראו את ההבדלים בצורה מובנית.
נטרו באופן רציף את זמינות נקודת הקצה ואת זמן התגובה שלה באמצעות cron.
חישובי רשתות משנה: כתובת רשת ושידור, מסכת רשת, טווח מארחים.
המירו גדלי נתונים בין בתים/KB/MB/GB/TB, בשיטה עשרונית או בינארית.
AND/OR/XOR/NOT/הזזה עם תצוגה ברמת הסיבית.
ארבעה חישובי אחוזים נפוצים במקום אחד.
המירו בין שניות, HH:MM:SS ומשכי זמן קריאים.
פענחו את דגלי הסיביות של כתובת MAC וחפשו יצרן בכמיטב היכולת.
הרחיבו בלוק CIDR או טווח כתובות לכל כתובות ה-IP הבודדות.
המירו בין צלזיוס, פרנהייט וקלווין.
צרו קידומת כתובת מקומית ייחודית לפי RFC 4193 למספור IPv6 פרטי.
אריתמטיקה ופעולות סיביות בהקסדצימלי וממיר בסיסים.
המירו bps/Mbps ועוד והעריכו זמן הורדה.
צרו כתובות MAC אקראיות בניהול מקומי.
צרו מספרי פורט TCP/UDP אקראיים לשרתי פיתוח ולתצורות.
המירו IPv4 לצורת מספר שלם/הקסדצימלי ול-IPv6 ממופה מ-IPv4.
עקבו אחרי כתובת אתר דרך כל הפניה וראו קודי מצב, לולאות ושדרוגים ל-HTTPS.
מצאו את הבעלים, ה-AS המקור, הקידומת המוכרזת והשכנים ב-BGP עבור IP, קידומת, מספר AS או שם מארח.
רשימה הניתנת לחיפוש של יציאות TCP ו-UDP נפוצות והשירותים שמשתמשים בהן.
המירו שעה בין אזורי זמן כולל שעון קיץ ומצאו שעת פגישה לכולם.
חשבו את חלון ה-TCP הדרוש ואת התפוקה בפועל לפי רוחב פס, השהיה ואובדן חבילות.
המירו בין CIDR, מסכת רשת משנה ומסכת wildcard וצרו שורות ACL של Cisco.
המירו פורמטים של כתובות MAC וקבלו את כתובת ה-IPv6 מקומית-הקישור ואת חבילת הקסם של Wake-on-LAN.
סכמו נתיבי IPv4 ו-IPv6 לרשימת הקידומות הקטנה ביותר או לנתיב מסכם יחיד.
חשבו ביטוי מתמטי באמצעות מנתח אמיתי (ללא eval) — אופרטורים, פונקציות וקבועים.
המירו בין UPPER/lower/Title/camelCase/snake_case ועוד.
חפשו והחליפו טקסט עם regex ואפשרויות של מילה שלמה.
סדרו את השורות בסדר אקראי.
השוואת שורות בטקסט רגיל עם הדגשת תוספות והסרות.
עצבו רשימה מחדש: חיתוך רווחים, הסרת כפילויות, מיון, עטיפה וחיבור בכל מפריד.
מיינו שורות לפי סדר אלפביתי, A-Z או Z-A.
מדריך חיפוש לאסימוני regex, כמתים ותבניות נפוצות.
נרמלו כתובת אימייל לצורה הקנונית של הספק כדי להסיר כפילויות.
חפשו והעתיקו מתוך מבחר אמוג'י נפוצים, מקובצים לפי קטגוריה.
המירו טקסט ל-slug בטוח לשימוש ב-URL.
קצרו מילים כמו "i18n": האות הראשונה, מספר האותיות שבאמצע והאות האחרונה.
טקסט מילוי אקראי ממילים נפוצות באנגלית.
המירו בין מספרים ערביים לספרות רומיות.
הסירו שורות חוזרות ושמרו את המופע הראשון.
אייתו טקסט באמצעות האלפבית הפונטי של נאט"ו.
הפכו טקסט לאמנות ASCII על ידי דגימת גופן אמיתי ולא קבוצת גליפים קבועה.
פרקו מספר טלפון לקידומת E.164, מדינה ומספר מקומי.
המירו טקסט לקודי תווים עשרוניים ובחזרה.
המירו טקסט לנקודות קוד של Unicode (U+XXXX) ובחזרה.
המירו טקסט לבתים בינאריים של 8 סיביות ובחזרה.
המירו טקסט לבתים הקסדצימליים ובחזרה.
המירו טקסט אל/מ-Base32 (RFC 4648).
המירו טקסט אל/מ-Base58 (האלפבית של ביטקוין).
המירו Base64 למחרוזת בתים הקסדצימלית ובחזרה.
המירו כל קובץ ל-data URI של Base64 בתוך הדפדפן שלכם.
המירו מחרוזת שאילתה של URL לאובייקט JSON ובחזרה.
זהו ופענחו אוטומטית Base64, הקסדצימלי, קידוד URL, gzip ועוד, שכבה אחר שכבה.
צרו אסימונים ומפתחות API אקראיים ובטוחים.
קודדו או פענחו טקסט וקבצים ב-Base64.
חשבו HMAC מהודעה ומפתח סודי (SHA-1/256/384/512).
צרו ULID ניתנים למיון בקידוד Crockford Base32 בכמות גדולה.
צרו גיבובים ממשפחת MD5/SHA.
צרו קוד TOTP חי (RFC 6238) מסוד Base32 או מ-URI בפורמט otpauth://.
בדקו את התנהגות ה-CORS של נקודת קצה.
גבבו או אמתו טקסט באמצעות bcrypt, בעזרת password_hash/password_verify המובנות של PHP.
הסתירו את אמצע המחרוזת כדי להסתיר מפתחות/אימיילים בצילומי מסך.
הצפינו ופענחו טקסט בצפנים נפוצים.
אמתו את סכום הביקורת mod-97 של IBAN ופרקו אותו למדינה ו-BBAN.
דרגו את חוזק הסיסמה והעריכו כמה זמן ייקח לפצח אותה, הכול בצד הלקוח.
צרו ביטוי זרע BIP39 (12-24 מילים) עם אנטרופיה וסכום ביקורת תקינים.
גלו איזה אלגוריתם יצר גיבוב, או חשבו סכום ביקורת לקובץ עם MD5, SHA-1 ו-SHA-2.
בדקו אם סיסמה מופיעה בדליפות ידועות מבלי לשלוח אותה.
חפשו מזהה CVE או מוצר: חומרה, מצב CISA KEV, הסתברות לניצול, מוצרים מושפעים והפניות.
קראו את הגרסה וזמן היצירה בתוך UUID וצרו ערכי UUID v7 הניתנים למיון.
הציגו את טביעת האצבע SHA256 ו-MD5, הסוג והגודל של מפתח SSH ציבורי והשוו אותו למפתח אחר.
דרגו פגיעויות לפי CVSS 3.1: ציון בסיס, זמני וסביבתי ומחרוזת הווקטור.
בנו Content-Security-Policy ומצאו חולשות במדיניות קיימת.
חלצו כתובות IP, דומיינים, URL, דוא״ל, גיבובים ו-CVE מטקסט, ונטרלו או שחזרו קישורים.
צרו את מאפיין integrity ואת תג ה-HTML לסקריפטים וגיליונות סגנונות שנטענים מ-CDN.
פענחו תעודת X.509 או CSR: נושא, מנפיק, תוקף, SAN, מפתח וטביעות אצבע.
צרו קובץ security.txt לפי RFC 9116 כדי שחוקרים ידעו איך לדווח על פגיעויות.
נטרו תאריכי תפוגה של אישורי SSL.
בנו מסמך JSON של מדיניות AWS IAM.
החליפו הרשאות קבצים ב-Unix כדי לבנות פקודת chmod.
בנו קובץ משתנים של Terraform.
חלקו CIDR של VPC לרשתות משנה שוות בגודלן.
נתחו או בנו ARN של AWS.
נתחו/בנו כתובות S3 (virtual-hosted, path-style, s3://).
חפשו קודי אזורים של AWS/GCP/Azure.
המירו קובץ .env ל-JSON או YAML ובחזרה.
מטענים לדוגמה לאירועי S3/API Gateway/SNS/SQS/EventBridge.
סדרו מחדש את ההזחה של תצורת Terraform.
המירו בין JSON רגיל ל-JSON בפורמט AttributeValue של DynamoDB.
המירו פקודת docker run לבלוק שירות מקביל ב-docker-compose.yml.
בנו קובץ .htaccess של Apache להפניות, HTTPS, מטמון, דחיסה ואבטחה, עם כללי Nginx.
בדקו אילו גרסאות עומדות בטווח גרסאות סמנטי בסגנון npm.
בנו והסבירו ביטויי cron.
צרו קובץ docker-compose.yml.
נתחו מחרוזת User-Agent.
צרו בלוקי server של nginx.
צרו מניפסטים של Kubernetes.
נהלו והשוו קובצי .env.
נטרו את זמינות האתרים והשירותים.
צרו כתובות אימייל לבדיקות בדומיינים השמורים לפי RFC 2606.
צרו שמות, אימיילים ושמות משתמש מדומים לבדיקות.
צרו מספרי טלפון מדומים (מרכזיית 555 האמריקאית ועוד).
צרו מספרי כרטיס פיקטיביים תקינים לפי Luhn לבדיקות בסביבת ארגז חול.
צרו כתובות דואר מדומות לבדיקות.
בנו קובץ .gitignore מרשימות סימון לפי שפה, עורך ומערכת הפעלה.
מדריך חיפוש לפקודות git נפוצות.
הציגו קונפליקטים במיזוג וסייעו בפתרונם.
צרו הודעת commit בפורמט Conventional Commits.
מצאו ענפים ישנים או ממוזגים לניקוי.
צרו תגי shields.io לגרסה, בנייה, רישיון והורדות והעתיקו אותם כ-Markdown או HTML.
צרו יומן שינויים מהיסטוריית commit.
המירו בין TOML ל-JSON/YAML.
עצבו ואמתו XML.
השוו בין שני מסמכי JSON.
אמתו ועצבו מסמכי YAML.
אמתו, עצבו וצמצמו JSON.
המירו JSON ל-XML לפי המוסכמות של ממיר ה-XML ל-JSON שלנו.
צרו JSON לדוגמה ריאליסטי שעומד ב-JSON Schema, עם seed שניתן לחזור עליו.
המירו JSON ל-CSV עם שיטוח, מפרידים ופלט ידידותי ל-Excel.
צרו טיפוסי TypeScript, Go, Java, C# או Python מ-JSON לדוגמה.
בנו סכמת JSON באופן חזותי מנתוני דוגמה.
המירו בין CSV ל-JSON.
המירו מסמכי XML ל-JSON.
המירו תת-קבוצה נפוצה של YAML ל-JSON ובחזרה.
בדקו ביטויי JSONPath על JSON לדוגמה.
אמתו TOML והציגו אותו כ-JSON.
סדרו מחדש את ההזחה של כללי האבטחה של Firestore.
המירו קובץ Java .properties ל-JSON או YAML ובחזרה.
המירו בין חותמות זמן של Unix לתאריכים.
שחזרו את כתובת ה-URL המקורית מקישור שעטף Microsoft Safe Links.
בנו קישור עמוק עם סכמת URI מותאמת.
בנו קישור sms: חוצה פלטפורמות עם הודעה שמולאה מראש.
פרקו כתובת URL לפרוטוקול, מארח, נתיב, פרמטרי שאילתה ו-hash.
בנו קישור ל-Google Play Store משם חבילה.
בנו קישור mailto: עם נושא, גוף, העתק והעתק מוסתר.
בנו קישור wa.me לפתיחת צ'אט בלחיצה אחת.
בנו קישור ל-Apple App Store ממזהה אפליקציה.
צרו קישורי הפניה קצרים.
עקבו אחר הפניות עד היעד הסופי.
הקטינו תמונה בעזרת איכות JPEG/WebP מתכווננת.
סמנו בגרירה וחתכו תמונה.
שנו גודל של תמונה למידות מדויקות.
הציגו קוד SVG בבטחה (מוצג כתמונה ולא מוזרק לדף).
המירו תמונה בין פורמטים.
המירו תמונה ל-data URI של base64 ובחזרה.
הפכו קוד SVG ל-PNG או JPEG בכל גודל.
צרו תמונה זמנית קלת משקל בפורמט SVG מוטבע ללא בקשת רשת.
הפכו צילומי מסך לתמונות מלוטשות עם מסגרות מכשיר, גרדיאנטים, צללים וטקסט.
הפכו קטע קוד ל-PNG מעוצב עם ערכות נושא, מסגרות חלון ומספרי שורות.
יחס ניגודיות WCAG בין טקסט לרקע, עם עובר/נכשל ל-AA/AAA.
בחרו צבע וראו אותו כ-HEX/RGB/HSL.
המירו בין קודי צבע הקסדצימליים לערכי RGB.
צרו צבעים הקסדצימליים אקראיים (פסטל/חיוניים/כהים).
המירו בין RGB ל-HSV/HSB, המודל שבו משתמשים בוררי הצבעים של Photoshop ו-Figma.
המירו בין RGB ל-HSL.
המירו בין שמות צבעים סטנדרטיים ב-CSS לקודים הקסדצימליים.
עיינו בפלטת הצבעים המובנית של Tailwind CSS.
עיינו בפלטת הצבעים של Material Design מבית Google.
המירו בין ערכי צבע CMYK (הדפסה) ל-RGB (מסך).
בנו תגי link חלופיים של hreflang לגרסאות שפה.
בנו sitemap.xml מרשימת כתובות URL שהדבקתם.
בנו קובץ robots.txt מקבוצות כללים.
בנו תג link קנוני.
בנו נתונים מובנים בפורמט JSON-LD לסוגים נפוצים.
קראו את מפת האתר של כל אתר, ראו את מבנה הדפים כעץ וכגרף ובדקו כותרות, תגי מטא וקודי מצב.
בנו Info.plist ל-iOS/macOS ממפתחות נפוצים של חבילה ופרטיות.
בנו מטענים לדוגמה להתראות APNs ו-FCM.
אמתו קובץ google-services.json מול מבנה התצורה הצפוי של Firebase.
בנו קובץ .entitlements (דומיינים משויכים, קבוצות אפליקציות, דחיפה, iCloud ועוד).
הציגו רשימת קבצים וגדלים בתוך APK.
צרו את כל גדלי סמל האפליקציה הנדרשים.
נתחו את רמת התחרותיות של מילות מפתח.
מצאו מילות מפתח ל-ASO בעלות ערך גבוה.
צרו מדיניות פרטיות לאפליקציה לנייד.
צרו הערות גרסה לחנויות האפליקציות.
צרו מטא-נתונים עבור App Store/Play Store.
סדרו מחדש את ההזחה של CSS או צמצמו אותו.
המירו אורך CSS בין px, rem, em, pt ו-%.
עצבו JavaScript מכווץ או כווצו אותו, עם טיפול בטוח במחרוזות, תבניות וביטויים רגולריים.
צרו את כל גדלי ה-favicon הסטנדרטיים.
עצבו וייצאו גרדיאנטים ב-CSS.
עצבו box-shadow רב-שכבתי ב-CSS.
צרו פלטות צבעים הרמוניות.
צרו תגי meta, Open Graph ו-Twitter Card לראש הדף.
צמצמו ונקו קוד SVG.
עצבו וצמצמו קוד HTML.
בנו טבלת HTML באופן חזותי.
בנו שילובי מחלקות Tailwind באופן חזותי.
המירו בין Markdown ל-HTML.
עצבו אנימציות CSS עם @keyframes.
צרו CSS בסגנון Glassmorphism.
צרו CSS בסגנון Neumorphism.
קודדו או פענחו ישויות HTML.
השוו בין שני צילומי מצב של HTML.
המירו קובץ גופן בין TTF/OTF ל-WOFF.
צרו ברקוד EAN-13.
עצבו ויפו שאילתות SQL.
צרו דיאגרמת ER מסכמה.
המירו שורות CSV להצהרות INSERT.
הציגו חזותית את הקשרים בין טבלאות.
בנו שאילתות MongoDB באופן חזותי.
נתחו הצהרות INSERT למערך JSON.
השוו בין שני צילומי מצב של סכמה או שאילתות.
נתחו שאילתה לאיתור בעיות ביצועים אפשריות.
הציגו חזותית תוכנית EXPLAIN.
עצבו שאילתה/מסמך של MongoDB בצורה קריאה.
חפשו ועקבו בזמן אמת אחרי קובצי יומן שהועלו.
סכמו שיעורי שגיאות ודפוסים ביומנים.
נתחו וסכמו דוחות קריסה.
הוסיפו הערות לצילומי מסך כדי לדווח על באגים.
עצבו Stack Trace גולמיים לצורה קריאה.