עצבו JavaScript מכווץ או כווצו אותו, עם טיפול בטוח במחרוזות, תבניות וביטויים רגולריים.
בדוק אם אתר מקוון וראה את האחסון, זיהוי וורדפרס, SSL, DNS, SEO וביצועים.
השוו את מהירות הריצה של 2 קטעי JS או יותר ב-Web Worker מבודד.
קראו את מפת האתר של כל אתר, ראו את מבנה הדפים כעץ וכגרף ובדקו כותרות, תגי מטא וקודי מצב.
בנו Info.plist ל-iOS/macOS ממפתחות נפוצים של חבילה ופרטיות.
לחצו על מקש כדי לראות בזמן אמת את ערכי key, code ו-keyCode של KeyboardEvent.
הפכו צילומי מסך לתמונות מלוטשות עם מסגרות מכשיר, גרדיאנטים, צללים וטקסט.
עקבו אחרי כתובת אתר דרך כל הפניה וראו קודי מצב, לולאות ושדרוגים ל-HTTPS.
צרו תמונה זמנית קלת משקל בפורמט SVG מוטבע ללא בקשת רשת.
צרו Dockerfile למחסניות נפוצות.
המירו מסמכי XML ל-JSON.
בנו נתונים מובנים בפורמט JSON-LD לסוגים נפוצים.
שעון עצר בדפדפן עם זמני הקפות.
מציג את כתובת ה-IP שממנה השרת שלנו רואה אתכם מתחברים.
חפשו פרטי רישום של דומיין.
צרו קוד QR הניתן לסריקה עם הגדרות מוכנות, צבעים, ייצוא SVG/PNG ומצב אצווה.
צרו סיסמאות אקראיות חזקות.
צרו סיסמאות, מפתחות API, מפתחות AES, UUID וזוגות מפתחות RSA/SSH — הכול בצד הלקוח.
צרו UUID מגרסאות v4/v7 בכמות גדולה.
טקסט מילוי קלאסי לדגמים.
סדרו מחדש את ההזחה של CSS או צמצמו אותו.
המירו אורך CSS בין px, rem, em, pt ו-%.
צרו CSS בסגנון Glassmorphism.
עצבו וצמצמו קוד HTML.
המירו בין Markdown ל-HTML.
עצבו אנימציות CSS עם @keyframes.
צרו את כל גדלי ה-favicon הסטנדרטיים.
צמצמו ונקו קוד SVG.
עצבו וייצאו גרדיאנטים ב-CSS.
בנו טבלת HTML באופן חזותי.
השוו בין שני צילומי מצב של HTML.
צרו פלטות צבעים הרמוניות.
עצבו box-shadow רב-שכבתי ב-CSS.
קודדו או פענחו ישויות HTML.
צרו תגי meta, Open Graph ו-Twitter Card לראש הדף.
המירו קובץ גופן בין TTF/OTF ל-WOFF.
בנו שילובי מחלקות Tailwind באופן חזותי.
צרו CSS בסגנון Neumorphism.
הציגו תצוגה מקדימה של URL בגדלי אזור תצוגה של מכשירים נפוצים.
בדקו אילו יכולות של פלטפורמת האינטרנט הדפדפן שלכם תומך בהן.
מציג בזמן אמת את גודל המסך ואזור התצוגה.
בדקו כל מקש במקלדת חדשה או ישנה: פריסה על המסך, זיהוי הקשה כפולה, בדיקת Rollover, מפת חום ומהירות הקלדה.
הוסיפו משך זמן לשעת התחלה וראו את התאריך והשעה שיתקבלו.
המירו גדלי נתונים בין בתים/KB/MB/GB/TB, בשיטה עשרונית או בינארית.
אריתמטיקה בינארית וממיר בסיסים.
AND/OR/XOR/NOT/הזזה עם תצוגה ברמת הסיבית.
הרחיבו בלוק CIDR או טווח כתובות לכל כתובות ה-IP הבודדות.
חישובי רשתות משנה: כתובת רשת ושידור, מסכת רשת, טווח מארחים.
ארבעה חישובי אחוזים נפוצים במקום אחד.
המירו בין שניות, HH:MM:SS ומשכי זמן קריאים.
המירו פורמטים של כתובות MAC וקבלו את כתובת ה-IPv6 מקומית-הקישור ואת חבילת הקסם של Wake-on-LAN.
פענחו את דגלי הסיביות של כתובת MAC וחפשו יצרן בכמיטב היכולת.
המירו IPv4 לצורת מספר שלם/הקסדצימלי ול-IPv6 ממופה מ-IPv4.
צרו כתובות MAC אקראיות בניהול מקומי.
מצאו את הבעלים, ה-AS המקור, הקידומת המוכרזת והשכנים ב-BGP עבור IP, קידומת, מספר AS או שם מארח.
המירו בין CIDR, מסכת רשת משנה ומסכת wildcard וצרו שורות ACL של Cisco.
צרו קידומת כתובת מקומית ייחודית לפי RFC 4193 למספור IPv6 פרטי.
המירו בין צלזיוס, פרנהייט וקלווין.
רשימה הניתנת לחיפוש של יציאות TCP ו-UDP נפוצות והשירותים שמשתמשים בהן.
צרו מספרי פורט TCP/UDP אקראיים לשרתי פיתוח ולתצורות.
המירו bps/Mbps ועוד והעריכו זמן הורדה.
אריתמטיקה ופעולות סיביות בהקסדצימלי וממיר בסיסים.
חשבו את חלון ה-TCP הדרוש ואת התפוקה בפועל לפי רוחב פס, השהיה ואובדן חבילות.
סכמו נתיבי IPv4 ו-IPv6 לרשימת הקידומות הקטנה ביותר או לנתיב מסכם יחיד.
המירו שעה בין אזורי זמן כולל שעון קיץ ומצאו שעת פגישה לכולם.
המירו טקסט לבתים בינאריים של 8 סיביות ובחזרה.
המירו טקסט לקודי תווים עשרוניים ובחזרה.
קודדו באחוזים או פענחו טקסט, במצב רכיב או URI מלא.
זהו ופענחו אוטומטית Base64, הקסדצימלי, קידוד URL, gzip ועוד, שכבה אחר שכבה.
המירו טקסט לנקודות קוד של Unicode (U+XXXX) ובחזרה.
המירו טקסט לבתים הקסדצימליים ובחזרה.
המירו טקסט אל/מ-Base32 (RFC 4648).
המירו טקסט אל/מ-Base58 (האלפבית של ביטקוין).
המירו כל קובץ ל-data URI של Base64 בתוך הדפדפן שלכם.
המירו Base64 למחרוזת בתים הקסדצימלית ובחזרה.
המירו מחרוזת שאילתה של URL לאובייקט JSON ובחזרה.
בנו תגי link חלופיים של hreflang לגרסאות שפה.
בנו sitemap.xml מרשימת כתובות URL שהדבקתם.
בנו קובץ robots.txt מקבוצות כללים.
בנו תג link קנוני.
בדקו תבנית על טקסט עם הדגשה חיה של התאמות וקבוצות לכידה.
עצבו רשימה מחדש: חיתוך רווחים, הסרת כפילויות, מיון, עטיפה וחיבור בכל מפריד.
חשבו ביטוי מתמטי באמצעות מנתח אמיתי (ללא eval) — אופרטורים, פונקציות וקבועים.
ספירה חיה של תווים, מילים, שורות ומשפטים.
הסירו שורות ריקות או שורות של רווחים בלבד.
מדריך חיפוש לאסימוני regex, כמתים ותבניות נפוצות.
השוואת שורות בטקסט רגיל עם הדגשת תוספות והסרות.
הפכו טקסט לאמנות ASCII על ידי דגימת גופן אמיתי ולא קבוצת גליפים קבועה.
סדרו את השורות בסדר אקראי.
חפשו והחליפו טקסט עם regex ואפשרויות של מילה שלמה.
נרמלו כתובת אימייל לצורה הקנונית של הספק כדי להסיר כפילויות.
המירו טקסט ל-slug בטוח לשימוש ב-URL.
המירו בין UPPER/lower/Title/camelCase/snake_case ועוד.
טקסט מילוי אקראי ממילים נפוצות באנגלית.
הסירו שורות חוזרות ושמרו את המופע הראשון.
אייתו טקסט באמצעות האלפבית הפונטי של נאט"ו.
מיינו שורות לפי סדר אלפביתי, A-Z או Z-A.
קצרו מילים כמו "i18n": האות הראשונה, מספר האותיות שבאמצע והאות האחרונה.
חפשו והעתיקו מתוך מבחר אמוג'י נפוצים, מקובצים לפי קטגוריה.
המירו בין מספרים ערביים לספרות רומיות.
פרקו מספר טלפון לקידומת E.164, מדינה ומספר מקומי.
בנו מטענים לדוגמה להתראות APNs ו-FCM.
אמתו קובץ google-services.json מול מבנה התצורה הצפוי של Firebase.
בנו קובץ .entitlements (דומיינים משויכים, קבוצות אפליקציות, דחיפה, iCloud ועוד).
צרו את כל גדלי סמל האפליקציה הנדרשים.
צרו מדיניות פרטיות לאפליקציה לנייד.
נהלו מחרוזות תרגום בין שפות.
נתחו את רמת התחרותיות של מילות מפתח.
הציגו רשימת קבצים וגדלים בתוך APK.
מצאו מילות מפתח ל-ASO בעלות ערך גבוה.
צרו מטא-נתונים עבור App Store/Play Store.
צרו הערות גרסה לחנויות האפליקציות.
בנו מסמך JSON של מדיניות AWS IAM.
חלקו CIDR של VPC לרשתות משנה שוות בגודלן.
החליפו הרשאות קבצים ב-Unix כדי לבנות פקודת chmod.
בנו קובץ משתנים של Terraform.
חפשו קודי אזורים של AWS/GCP/Azure.
נתחו או בנו ARN של AWS.
נהלו והשוו קובצי .env.
מטענים לדוגמה לאירועי S3/API Gateway/SNS/SQS/EventBridge.
המירו פקודת docker run לבלוק שירות מקביל ב-docker-compose.yml.
סדרו מחדש את ההזחה של תצורת Terraform.
צרו workflow של GitHub Actions עבור Node, Python, PHP, Go, Java, Rust, .NET, Docker או Pages.
נתחו/בנו כתובות S3 (virtual-hosted, path-style, s3://).
נטרו את זמינות האתרים והשירותים.
המירו קובץ .env ל-JSON או YAML ובחזרה.
בנו קובץ .htaccess של Apache להפניות, HTTPS, מטמון, דחיסה ואבטחה, עם כללי Nginx.
המירו בין JSON רגיל ל-JSON בפורמט AttributeValue של DynamoDB.
בדקו אילו גרסאות עומדות בטווח גרסאות סמנטי בסגנון npm.
צרו בלוקי server של nginx.
בנו והסבירו ביטויי cron.
נתחו מחרוזת User-Agent.
צרו קובץ docker-compose.yml.
צרו מניפסטים של Kubernetes.
המירו בין RGB ל-HSV/HSB, המודל שבו משתמשים בוררי הצבעים של Photoshop ו-Figma.
יחס ניגודיות WCAG בין טקסט לרקע, עם עובר/נכשל ל-AA/AAA.
המירו בין RGB ל-HSL.
המירו בין קודי צבע הקסדצימליים לערכי RGB.
בחרו צבע וראו אותו כ-HEX/RGB/HSL.
המירו בין ערכי צבע CMYK (הדפסה) ל-RGB (מסך).
עיינו בפלטת הצבעים המובנית של Tailwind CSS.
צרו צבעים הקסדצימליים אקראיים (פסטל/חיוניים/כהים).
המירו בין שמות צבעים סטנדרטיים ב-CSS לקודים הקסדצימליים.
עיינו בפלטת הצבעים של Material Design מבית Google.
קודדו או פענחו טקסט וקבצים ב-Base64.
בדקו את התנהגות ה-CORS של נקודת קצה.
צרו ULID ניתנים למיון בקידוד Crockford Base32 בכמות גדולה.
צרו גיבובים ממשפחת MD5/SHA.
צרו קוד TOTP חי (RFC 6238) מסוד Base32 או מ-URI בפורמט otpauth://.
גבבו או אמתו טקסט באמצעות bcrypt, בעזרת password_hash/password_verify המובנות של PHP.
הציגו את טביעת האצבע SHA256 ו-MD5, הסוג והגודל של מפתח SSH ציבורי והשוו אותו למפתח אחר.
חפשו מזהה CVE או מוצר: חומרה, מצב CISA KEV, הסתברות לניצול, מוצרים מושפעים והפניות.
אמתו את סכום הביקורת mod-97 של IBAN ופרקו אותו למדינה ו-BBAN.
צרו אסימונים ומפתחות API אקראיים ובטוחים.
דרגו פגיעויות לפי CVSS 3.1: ציון בסיס, זמני וסביבתי ומחרוזת הווקטור.
קראו את הגרסה וזמן היצירה בתוך UUID וצרו ערכי UUID v7 הניתנים למיון.
חשבו HMAC מהודעה ומפתח סודי (SHA-1/256/384/512).
צרו את מאפיין integrity ואת תג ה-HTML לסקריפטים וגיליונות סגנונות שנטענים מ-CDN.
הצפינו ופענחו טקסט בצפנים נפוצים.
הסתירו את אמצע המחרוזת כדי להסתיר מפתחות/אימיילים בצילומי מסך.
צרו ביטוי זרע BIP39 (12-24 מילים) עם אנטרופיה וסכום ביקורת תקינים.
בנו Content-Security-Policy ומצאו חולשות במדיניות קיימת.
בדקו אם סיסמה מופיעה בדליפות ידועות מבלי לשלוח אותה.
חלצו כתובות IP, דומיינים, URL, דוא״ל, גיבובים ו-CVE מטקסט, ונטרלו או שחזרו קישורים.
צרו קובץ security.txt לפי RFC 9116 כדי שחוקרים ידעו איך לדווח על פגיעויות.
דרגו את חוזק הסיסמה והעריכו כמה זמן ייקח לפצח אותה, הכול בצד הלקוח.
פענחו תעודת X.509 או CSR: נושא, מנפיק, תוקף, SAN, מפתח וטביעות אצבע.
גלו איזה אלגוריתם יצר גיבוב, או חשבו סכום ביקורת לקובץ עם MD5, SHA-1 ו-SHA-2.
נטרו תאריכי תפוגה של אישורי SSL.
בנו קובץ .gitignore מרשימות סימון לפי שפה, עורך ומערכת הפעלה.
מדריך חיפוש לפקודות git נפוצות.
הציגו קונפליקטים במיזוג וסייעו בפתרונם.
צרו הודעת commit בפורמט Conventional Commits.
מצאו ענפים ישנים או ממוזגים לניקוי.
צרו תגי shields.io לגרסה, בנייה, רישיון והורדות והעתיקו אותם כ-Markdown או HTML.
צרו יומן שינויים מהיסטוריית commit.
צרו הערות גרסה מ-PR שמוזגו.
Fill in {{variable}} prompt templates and preview the resolved prompt.
שלחו התפרצות בקשות לנקודת קצה כדי למצוא את מגבלת הקצב בפועל.
מדריך חיפוש להתאמות בין סיומת קובץ <-> סוג MIME.
מדריך חיפוש לכל קודי הסטטוס הסטנדרטיים של תגובות HTTP.
צרו ושלחו בקשות HTTP, בדקו תגובות ושמרו היסטוריה.
בנו או פענחו כותרת HTTP Authorization: Basic.
אמתו בקשת chat completions או את מבנה סכמת הפונקציה/הכלי.
המירו פקודות curl ל-fetch, Python, PHP או HTTPie ובחזרה.
מושך כתובת URL ומסביר את כותרות התגובה שלה, עם ציון אבטחה.
עברו על זרימת קוד האימות של OAuth2 ובדקו את האסימונים.
תכננו מפרטי נקודות קצה של REST והפיקו מהם תיעוד ודמיות.
פענחו ובדקו את הכותרת והמטען של JWT ואמתו חתימות.
העריכו את מספר האסימונים בהנחיית LLM.
השוו בין שתי תגובות API וראו את ההבדלים בצורה מובנית.
הריצו שאילתות מול כל נקודת קצה של GraphQL וסיירו בסכמה שלה.
המירו מפרט OpenAPI/Swagger לאוסף Postman ובחזרה.
קבלו כתובת תיבת דואר ייחודית ובדקו בקשות webhook נכנסות בזמן אמת.
נטרו באופן רציף את זמינות נקודת הקצה ואת זמן התגובה שלה באמצעות cron.
אמתו ועצבו מסמכי YAML.
השוו בין שני מסמכי JSON.
אמתו, עצבו וצמצמו JSON.
עצבו ואמתו XML.
המירו JSON ל-XML לפי המוסכמות של ממיר ה-XML ל-JSON שלנו.
המירו בין TOML ל-JSON/YAML.
המירו JSON ל-CSV עם שיטוח, מפרידים ופלט ידידותי ל-Excel.
בנו סכמת JSON באופן חזותי מנתוני דוגמה.
צרו JSON לדוגמה ריאליסטי שעומד ב-JSON Schema, עם seed שניתן לחזור עליו.
צרו טיפוסי TypeScript, Go, Java, C# או Python מ-JSON לדוגמה.
סדרו מחדש את ההזחה של כללי האבטחה של Firestore.
אמתו TOML והציגו אותו כ-JSON.
בדקו ביטויי JSONPath על JSON לדוגמה.
המירו בין CSV ל-JSON.
המירו קובץ Java .properties ל-JSON או YAML ובחזרה.
המירו תת-קבוצה נפוצה של YAML ל-JSON ובחזרה.
המירו CSV לקובץ .xlsx אמיתי ובחזרה.
שחזרו את כתובת ה-URL המקורית מקישור שעטף Microsoft Safe Links.
המירו בין חותמות זמן של Unix לתאריכים.
בנו קישור עמוק עם סכמת URI מותאמת.
בנו קישור sms: חוצה פלטפורמות עם הודעה שמולאה מראש.
פרקו כתובת URL לפרוטוקול, מארח, נתיב, פרמטרי שאילתה ו-hash.
בנו קישור ל-Google Play Store משם חבילה.
בנו קישור ל-Apple App Store ממזהה אפליקציה.
בנו קישור mailto: עם נושא, גוף, העתק והעתק מוסתר.
בנו קישור wa.me לפתיחת צ'אט בלחיצה אחת.
עקבו אחר הפניות עד היעד הסופי.
צרו קישורי הפניה קצרים.
צרו כתובות אימייל לבדיקות בדומיינים השמורים לפי RFC 2606.
צרו מספרי טלפון מדומים (מרכזיית 555 האמריקאית ועוד).
צרו שמות, אימיילים ושמות משתמש מדומים לבדיקות.
צרו מספרי כרטיס פיקטיביים תקינים לפי Luhn לבדיקות בסביבת ארגז חול.
צרו כתובות דואר מדומות לבדיקות.
הקטינו תמונה בעזרת איכות JPEG/WebP מתכווננת.
הציגו קוד SVG בבטחה (מוצג כתמונה ולא מוזרק לדף).
שנו גודל של תמונה למידות מדויקות.
סמנו בגרירה וחתכו תמונה.
המירו תמונה ל-data URI של base64 ובחזרה.
הפכו קטע קוד ל-PNG מעוצב עם ערכות נושא, מסגרות חלון ומספרי שורות.
הפכו קוד SVG ל-PNG או JPEG בכל גודל.
המירו תמונה בין פורמטים.
בנו שאילתות MongoDB באופן חזותי.
המירו שורות CSV להצהרות INSERT.
נתחו שאילתה לאיתור בעיות ביצועים אפשריות.
עצבו ויפו שאילתות SQL.
נתחו הצהרות INSERT למערך JSON.
הציגו חזותית את הקשרים בין טבלאות.
השוו בין שני צילומי מצב של סכמה או שאילתות.
צרו דיאגרמת ER מסכמה.
הציגו חזותית תוכנית EXPLAIN.
עצבו שאילתה/מסמך של MongoDB בצורה קריאה.
עצבו Stack Trace גולמיים לצורה קריאה.
נתחו וסכמו דוחות קריסה.
סכמו שיעורי שגיאות ודפוסים ביומנים.
הוסיפו הערות לצילומי מסך כדי לדווח על באגים.
חפשו ועקבו בזמן אמת אחרי קובצי יומן שהועלו.
צרו ברקוד EAN-13.