עצבו JavaScript מכווץ או כווצו אותו, עם טיפול בטוח במחרוזות, תבניות וביטויים רגולריים.
בדוק אם אתר מקוון וראה את האחסון, זיהוי וורדפרס, SSL, DNS, SEO וביצועים.
השוו את מהירות הריצה של 2 קטעי JS או יותר ב-Web Worker מבודד.
קראו את מפת האתר של כל אתר, ראו את מבנה הדפים כעץ וכגרף ובדקו כותרות, תגי מטא וקודי מצב.
בנו Info.plist ל-iOS/macOS ממפתחות נפוצים של חבילה ופרטיות.
לחצו על מקש כדי לראות בזמן אמת את ערכי key, code ו-keyCode של KeyboardEvent.
עקבו אחרי כתובת אתר דרך כל הפניה וראו קודי מצב, לולאות ושדרוגים ל-HTTPS.
בנו מסמך JSON של מדיניות AWS IAM.
עצבו שאילתה/מסמך של MongoDB בצורה קריאה.
צרו מדיניות פרטיות לאפליקציה לנייד.
פענחו תעודת X.509 או CSR: נושא, מנפיק, תוקף, SAN, מפתח וטביעות אצבע.
הציגו חזותית תוכנית EXPLAIN.
שעון עצר בדפדפן עם זמני הקפות.
מציג את כתובת ה-IP שממנה השרת שלנו רואה אתכם מתחברים.
חפשו פרטי רישום של דומיין.
צרו קוד QR הניתן לסריקה עם הגדרות מוכנות, צבעים, ייצוא SVG/PNG ומצב אצווה.
צרו סיסמאות אקראיות חזקות.
צרו סיסמאות, מפתחות API, מפתחות AES, UUID וזוגות מפתחות RSA/SSH — הכול בצד הלקוח.
צרו UUID מגרסאות v4/v7 בכמות גדולה.
טקסט מילוי קלאסי לדגמים.
סדרו מחדש את ההזחה של CSS או צמצמו אותו.
המירו אורך CSS בין px, rem, em, pt ו-%.
צרו CSS בסגנון Glassmorphism.
עצבו וצמצמו קוד HTML.
עצבו אנימציות CSS עם @keyframes.
צמצמו ונקו קוד SVG.
המירו בין Markdown ל-HTML.
בנו טבלת HTML באופן חזותי.
עצבו וייצאו גרדיאנטים ב-CSS.
צרו את כל גדלי ה-favicon הסטנדרטיים.
עצבו box-shadow רב-שכבתי ב-CSS.
המירו קובץ גופן בין TTF/OTF ל-WOFF.
צרו תגי meta, Open Graph ו-Twitter Card לראש הדף.
צרו פלטות צבעים הרמוניות.
השוו בין שני צילומי מצב של HTML.
קודדו או פענחו ישויות HTML.
צרו CSS בסגנון Neumorphism.
בנו שילובי מחלקות Tailwind באופן חזותי.
הציגו תצוגה מקדימה של URL בגדלי אזור תצוגה של מכשירים נפוצים.
בדקו אילו יכולות של פלטפורמת האינטרנט הדפדפן שלכם תומך בהן.
מציג בזמן אמת את גודל המסך ואזור התצוגה.
בדקו כל מקש במקלדת חדשה או ישנה: פריסה על המסך, זיהוי הקשה כפולה, בדיקת Rollover, מפת חום ומהירות הקלדה.
הוסיפו משך זמן לשעת התחלה וראו את התאריך והשעה שיתקבלו.
המירו גדלי נתונים בין בתים/KB/MB/GB/TB, בשיטה עשרונית או בינארית.
אריתמטיקה בינארית וממיר בסיסים.
AND/OR/XOR/NOT/הזזה עם תצוגה ברמת הסיבית.
הרחיבו בלוק CIDR או טווח כתובות לכל כתובות ה-IP הבודדות.
המירו פורמטים של כתובות MAC וקבלו את כתובת ה-IPv6 מקומית-הקישור ואת חבילת הקסם של Wake-on-LAN.
ארבעה חישובי אחוזים נפוצים במקום אחד.
חישובי רשתות משנה: כתובת רשת ושידור, מסכת רשת, טווח מארחים.
המירו בין שניות, HH:MM:SS ומשכי זמן קריאים.
מצאו את הבעלים, ה-AS המקור, הקידומת המוכרזת והשכנים ב-BGP עבור IP, קידומת, מספר AS או שם מארח.
המירו בין CIDR, מסכת רשת משנה ומסכת wildcard וצרו שורות ACL של Cisco.
המירו IPv4 לצורת מספר שלם/הקסדצימלי ול-IPv6 ממופה מ-IPv4.
רשימה הניתנת לחיפוש של יציאות TCP ו-UDP נפוצות והשירותים שמשתמשים בהן.
פענחו את דגלי הסיביות של כתובת MAC וחפשו יצרן בכמיטב היכולת.
צרו כתובות MAC אקראיות בניהול מקומי.
סכמו נתיבי IPv4 ו-IPv6 לרשימת הקידומות הקטנה ביותר או לנתיב מסכם יחיד.
צרו מספרי פורט TCP/UDP אקראיים לשרתי פיתוח ולתצורות.
צרו קידומת כתובת מקומית ייחודית לפי RFC 4193 למספור IPv6 פרטי.
המירו bps/Mbps ועוד והעריכו זמן הורדה.
חשבו את חלון ה-TCP הדרוש ואת התפוקה בפועל לפי רוחב פס, השהיה ואובדן חבילות.
המירו בין צלזיוס, פרנהייט וקלווין.
אריתמטיקה ופעולות סיביות בהקסדצימלי וממיר בסיסים.
המירו שעה בין אזורי זמן כולל שעון קיץ ומצאו שעת פגישה לכולם.
בנו תגי link חלופיים של hreflang לגרסאות שפה.
בנו קובץ robots.txt מקבוצות כללים.
בנו sitemap.xml מרשימת כתובות URL שהדבקתם.
בנו תג link קנוני.
בנו נתונים מובנים בפורמט JSON-LD לסוגים נפוצים.
המירו טקסט לבתים בינאריים של 8 סיביות ובחזרה.
קודדו באחוזים או פענחו טקסט, במצב רכיב או URI מלא.
המירו טקסט לקודי תווים עשרוניים ובחזרה.
זהו ופענחו אוטומטית Base64, הקסדצימלי, קידוד URL, gzip ועוד, שכבה אחר שכבה.
המירו טקסט לנקודות קוד של Unicode (U+XXXX) ובחזרה.
המירו טקסט אל/מ-Base58 (האלפבית של ביטקוין).
המירו טקסט אל/מ-Base32 (RFC 4648).
המירו טקסט לבתים הקסדצימליים ובחזרה.
המירו כל קובץ ל-data URI של Base64 בתוך הדפדפן שלכם.
המירו מחרוזת שאילתה של URL לאובייקט JSON ובחזרה.
המירו Base64 למחרוזת בתים הקסדצימלית ובחזרה.
יחס ניגודיות WCAG בין טקסט לרקע, עם עובר/נכשל ל-AA/AAA.
המירו בין RGB ל-HSV/HSB, המודל שבו משתמשים בוררי הצבעים של Photoshop ו-Figma.
המירו בין קודי צבע הקסדצימליים לערכי RGB.
המירו בין RGB ל-HSL.
בחרו צבע וראו אותו כ-HEX/RGB/HSL.
צרו צבעים הקסדצימליים אקראיים (פסטל/חיוניים/כהים).
המירו בין ערכי צבע CMYK (הדפסה) ל-RGB (מסך).
עיינו בפלטת הצבעים המובנית של Tailwind CSS.
המירו בין שמות צבעים סטנדרטיים ב-CSS לקודים הקסדצימליים.
עיינו בפלטת הצבעים של Material Design מבית Google.
אמתו קובץ google-services.json מול מבנה התצורה הצפוי של Firebase.
בנו מטענים לדוגמה להתראות APNs ו-FCM.
צרו את כל גדלי סמל האפליקציה הנדרשים.
בנו קובץ .entitlements (דומיינים משויכים, קבוצות אפליקציות, דחיפה, iCloud ועוד).
נהלו מחרוזות תרגום בין שפות.
נתחו את רמת התחרותיות של מילות מפתח.
הציגו רשימת קבצים וגדלים בתוך APK.
מצאו מילות מפתח ל-ASO בעלות ערך גבוה.
צרו מטא-נתונים עבור App Store/Play Store.
צרו הערות גרסה לחנויות האפליקציות.
קודדו או פענחו טקסט וקבצים ב-Base64.
גבבו או אמתו טקסט באמצעות bcrypt, בעזרת password_hash/password_verify המובנות של PHP.
צרו ULID ניתנים למיון בקידוד Crockford Base32 בכמות גדולה.
הציגו את טביעת האצבע SHA256 ו-MD5, הסוג והגודל של מפתח SSH ציבורי והשוו אותו למפתח אחר.
בדקו את התנהגות ה-CORS של נקודת קצה.
צרו קוד TOTP חי (RFC 6238) מסוד Base32 או מ-URI בפורמט otpauth://.
חפשו מזהה CVE או מוצר: חומרה, מצב CISA KEV, הסתברות לניצול, מוצרים מושפעים והפניות.
דרגו פגיעויות לפי CVSS 3.1: ציון בסיס, זמני וסביבתי ומחרוזת הווקטור.
אמתו את סכום הביקורת mod-97 של IBAN ופרקו אותו למדינה ו-BBAN.
צרו אסימונים ומפתחות API אקראיים ובטוחים.
צרו גיבובים ממשפחת MD5/SHA.
חשבו HMAC מהודעה ומפתח סודי (SHA-1/256/384/512).
צרו את מאפיין integrity ואת תג ה-HTML לסקריפטים וגיליונות סגנונות שנטענים מ-CDN.
הצפינו ופענחו טקסט בצפנים נפוצים.
קראו את הגרסה וזמן היצירה בתוך UUID וצרו ערכי UUID v7 הניתנים למיון.
חלצו כתובות IP, דומיינים, URL, דוא״ל, גיבובים ו-CVE מטקסט, ונטרלו או שחזרו קישורים.
בנו Content-Security-Policy ומצאו חולשות במדיניות קיימת.
צרו ביטוי זרע BIP39 (12-24 מילים) עם אנטרופיה וסכום ביקורת תקינים.
בדקו אם סיסמה מופיעה בדליפות ידועות מבלי לשלוח אותה.
הסתירו את אמצע המחרוזת כדי להסתיר מפתחות/אימיילים בצילומי מסך.
צרו קובץ security.txt לפי RFC 9116 כדי שחוקרים ידעו איך לדווח על פגיעויות.
גלו איזה אלגוריתם יצר גיבוב, או חשבו סכום ביקורת לקובץ עם MD5, SHA-1 ו-SHA-2.
דרגו את חוזק הסיסמה והעריכו כמה זמן ייקח לפצח אותה, הכול בצד הלקוח.
נטרו תאריכי תפוגה של אישורי SSL.
חפשו קודי אזורים של AWS/GCP/Azure.
החליפו הרשאות קבצים ב-Unix כדי לבנות פקודת chmod.
בנו קובץ משתנים של Terraform.
המירו פקודת docker run לבלוק שירות מקביל ב-docker-compose.yml.
חלקו CIDR של VPC לרשתות משנה שוות בגודלן.
נהלו והשוו קובצי .env.
נתחו או בנו ARN של AWS.
מטענים לדוגמה לאירועי S3/API Gateway/SNS/SQS/EventBridge.
נטרו את זמינות האתרים והשירותים.
צרו workflow של GitHub Actions עבור Node, Python, PHP, Go, Java, Rust, .NET, Docker או Pages.
סדרו מחדש את ההזחה של תצורת Terraform.
המירו קובץ .env ל-JSON או YAML ובחזרה.
נתחו/בנו כתובות S3 (virtual-hosted, path-style, s3://).
בנו קובץ .htaccess של Apache להפניות, HTTPS, מטמון, דחיסה ואבטחה, עם כללי Nginx.
צרו בלוקי server של nginx.
המירו בין JSON רגיל ל-JSON בפורמט AttributeValue של DynamoDB.
בדקו אילו גרסאות עומדות בטווח גרסאות סמנטי בסגנון npm.
צרו Dockerfile למחסניות נפוצות.
בנו והסבירו ביטויי cron.
נתחו מחרוזת User-Agent.
צרו קובץ docker-compose.yml.
צרו מניפסטים של Kubernetes.
השוואת שורות בטקסט רגיל עם הדגשת תוספות והסרות.
חפשו והחליפו טקסט עם regex ואפשרויות של מילה שלמה.
עצבו רשימה מחדש: חיתוך רווחים, הסרת כפילויות, מיון, עטיפה וחיבור בכל מפריד.
חשבו ביטוי מתמטי באמצעות מנתח אמיתי (ללא eval) — אופרטורים, פונקציות וקבועים.
בדקו תבנית על טקסט עם הדגשה חיה של התאמות וקבוצות לכידה.
הפכו טקסט לאמנות ASCII על ידי דגימת גופן אמיתי ולא קבוצת גליפים קבועה.
ספירה חיה של תווים, מילים, שורות ומשפטים.
מדריך חיפוש לאסימוני regex, כמתים ותבניות נפוצות.
הסירו שורות חוזרות ושמרו את המופע הראשון.
הסירו שורות ריקות או שורות של רווחים בלבד.
סדרו את השורות בסדר אקראי.
המירו טקסט ל-slug בטוח לשימוש ב-URL.
קצרו מילים כמו "i18n": האות הראשונה, מספר האותיות שבאמצע והאות האחרונה.
נרמלו כתובת אימייל לצורה הקנונית של הספק כדי להסיר כפילויות.
אייתו טקסט באמצעות האלפבית הפונטי של נאט"ו.
טקסט מילוי אקראי ממילים נפוצות באנגלית.
המירו בין מספרים ערביים לספרות רומיות.
המירו בין UPPER/lower/Title/camelCase/snake_case ועוד.
מיינו שורות לפי סדר אלפביתי, A-Z או Z-A.
חפשו והעתיקו מתוך מבחר אמוג'י נפוצים, מקובצים לפי קטגוריה.
פרקו מספר טלפון לקידומת E.164, מדינה ומספר מקומי.
שלחו התפרצות בקשות לנקודת קצה כדי למצוא את מגבלת הקצב בפועל.
Fill in {{variable}} prompt templates and preview the resolved prompt.
מדריך חיפוש להתאמות בין סיומת קובץ <-> סוג MIME.
צרו ושלחו בקשות HTTP, בדקו תגובות ושמרו היסטוריה.
מדריך חיפוש לכל קודי הסטטוס הסטנדרטיים של תגובות HTTP.
בנו או פענחו כותרת HTTP Authorization: Basic.
המירו פקודות curl ל-fetch, Python, PHP או HTTPie ובחזרה.
אמתו בקשת chat completions או את מבנה סכמת הפונקציה/הכלי.
מושך כתובת URL ומסביר את כותרות התגובה שלה, עם ציון אבטחה.
עברו על זרימת קוד האימות של OAuth2 ובדקו את האסימונים.
פענחו ובדקו את הכותרת והמטען של JWT ואמתו חתימות.
העריכו את מספר האסימונים בהנחיית LLM.
תכננו מפרטי נקודות קצה של REST והפיקו מהם תיעוד ודמיות.
השוו בין שתי תגובות API וראו את ההבדלים בצורה מובנית.
הריצו שאילתות מול כל נקודת קצה של GraphQL וסיירו בסכמה שלה.
המירו מפרט OpenAPI/Swagger לאוסף Postman ובחזרה.
קבלו כתובת תיבת דואר ייחודית ובדקו בקשות webhook נכנסות בזמן אמת.
נטרו באופן רציף את זמינות נקודת הקצה ואת זמן התגובה שלה באמצעות cron.
בנו קובץ .gitignore מרשימות סימון לפי שפה, עורך ומערכת הפעלה.
מדריך חיפוש לפקודות git נפוצות.
הציגו קונפליקטים במיזוג וסייעו בפתרונם.
צרו הודעת commit בפורמט Conventional Commits.
מצאו ענפים ישנים או ממוזגים לניקוי.
צרו יומן שינויים מהיסטוריית commit.
צרו תגי shields.io לגרסה, בנייה, רישיון והורדות והעתיקו אותם כ-Markdown או HTML.
צרו הערות גרסה מ-PR שמוזגו.
צרו כתובות אימייל לבדיקות בדומיינים השמורים לפי RFC 2606.
צרו מספרי טלפון מדומים (מרכזיית 555 האמריקאית ועוד).
צרו מספרי כרטיס פיקטיביים תקינים לפי Luhn לבדיקות בסביבת ארגז חול.
צרו שמות, אימיילים ושמות משתמש מדומים לבדיקות.
צרו כתובות דואר מדומות לבדיקות.
שחזרו את כתובת ה-URL המקורית מקישור שעטף Microsoft Safe Links.
המירו בין חותמות זמן של Unix לתאריכים.
בנו קישור עמוק עם סכמת URI מותאמת.
פרקו כתובת URL לפרוטוקול, מארח, נתיב, פרמטרי שאילתה ו-hash.
בנו קישור sms: חוצה פלטפורמות עם הודעה שמולאה מראש.
בנו קישור ל-Google Play Store משם חבילה.
בנו קישור mailto: עם נושא, גוף, העתק והעתק מוסתר.
עקבו אחר הפניות עד היעד הסופי.
בנו קישור ל-Apple App Store ממזהה אפליקציה.
בנו קישור wa.me לפתיחת צ'אט בלחיצה אחת.
צרו קישורי הפניה קצרים.
אמתו ועצבו מסמכי YAML.
השוו בין שני מסמכי JSON.
עצבו ואמתו XML.
אמתו, עצבו וצמצמו JSON.
המירו JSON ל-XML לפי המוסכמות של ממיר ה-XML ל-JSON שלנו.
המירו בין TOML ל-JSON/YAML.
המירו JSON ל-CSV עם שיטוח, מפרידים ופלט ידידותי ל-Excel.
בנו סכמת JSON באופן חזותי מנתוני דוגמה.
המירו מסמכי XML ל-JSON.
צרו JSON לדוגמה ריאליסטי שעומד ב-JSON Schema, עם seed שניתן לחזור עליו.
צרו טיפוסי TypeScript, Go, Java, C# או Python מ-JSON לדוגמה.
סדרו מחדש את ההזחה של כללי האבטחה של Firestore.
בדקו ביטויי JSONPath על JSON לדוגמה.
אמתו TOML והציגו אותו כ-JSON.
המירו בין CSV ל-JSON.
המירו קובץ Java .properties ל-JSON או YAML ובחזרה.
המירו תת-קבוצה נפוצה של YAML ל-JSON ובחזרה.
המירו CSV לקובץ .xlsx אמיתי ובחזרה.
הקטינו תמונה בעזרת איכות JPEG/WebP מתכווננת.
שנו גודל של תמונה למידות מדויקות.
סמנו בגרירה וחתכו תמונה.
הפכו קטע קוד ל-PNG מעוצב עם ערכות נושא, מסגרות חלון ומספרי שורות.
המירו תמונה ל-data URI של base64 ובחזרה.
הציגו קוד SVG בבטחה (מוצג כתמונה ולא מוזרק לדף).
המירו תמונה בין פורמטים.
הפכו קוד SVG ל-PNG או JPEG בכל גודל.
צרו תמונה זמנית קלת משקל בפורמט SVG מוטבע ללא בקשת רשת.
הפכו צילומי מסך לתמונות מלוטשות עם מסגרות מכשיר, גרדיאנטים, צללים וטקסט.
עצבו ויפו שאילתות SQL.
נתחו שאילתה לאיתור בעיות ביצועים אפשריות.
המירו שורות CSV להצהרות INSERT.
בנו שאילתות MongoDB באופן חזותי.
נתחו הצהרות INSERT למערך JSON.
הציגו חזותית את הקשרים בין טבלאות.
השוו בין שני צילומי מצב של סכמה או שאילתות.
צרו דיאגרמת ER מסכמה.
עצבו Stack Trace גולמיים לצורה קריאה.
נתחו וסכמו דוחות קריסה.
סכמו שיעורי שגיאות ודפוסים ביומנים.
הוסיפו הערות לצילומי מסך כדי לדווח על באגים.
חפשו ועקבו בזמן אמת אחרי קובצי יומן שהועלו.
צרו ברקוד EAN-13.